From: Valentin Schneider <valentin.schneider@arm.com>
To: Quentin Perret <qperret@google.com>
Cc: linux-kernel@vger.kernel.org, peterz@infradead.org,
mingo@kernel.org, vincent.guittot@linaro.org,
dietmar.eggemann@arm.com, patrick.bellasi@matbug.net,
qais.yousef@arm.com, morten.rasmussen@arm.com
Subject: Re: [PATCH 3/3] sched/fair: Consider uclamp for "task fits capacity" checks
Date: Thu, 21 Nov 2019 12:56:39 +0000 [thread overview]
Message-ID: <f7e5dabb-a7e6-d110-abca-de7d4533bcc5@arm.com> (raw)
In-Reply-To: <20191121115602.GA213296@google.com>
On 21/11/2019 11:56, Quentin Perret wrote:
> On Wednesday 20 Nov 2019 at 17:55:33 (+0000), Valentin Schneider wrote:
>> +static inline
>> +unsigned long uclamp_task_util(struct task_struct *p, unsigned long util)
>
> This 'util' parameter is always task_util_est(p) right ? You might want
> to remove it.
>
I went with copying uclamp_rq_util()'s API, but you're right in that I don't
see what other value (than util_est) would make sense for this helper. If
there is no objections I'll kill the parameter for v2.
>> +{
>> + return clamp(util,
>> + (unsigned long)uclamp_eff_value(p, UCLAMP_MIN),
>> + (unsigned long)uclamp_eff_value(p, UCLAMP_MAX));
>> +}
>
> Thanks,
> Quentin
>
Another thing I realized overnight; tell me what you think:
> @@ -6274,6 +6274,15 @@ static int find_energy_efficient_cpu(struct task_struct *p, int prev_cpu)
> if (!fits_capacity(util, cpu_cap))
> continue;
>
> + /*
> + * Skip CPUs that don't satisfy uclamp requests. Note
> + * that the above already ensures the CPU has enough
> + * spare capacity for the task; this is only really for
> + * uclamp restrictions.
> + */
> + if (!task_fits_capacity(p, capacity_orig_of(cpu)))
> + continue;
This is partly redundant with the above, I think. What we really want here
is just
fits_capacity(uclamp_eff_value(p, UCLAMP_MIN), capacity_orig_of(cpu))
but this would require some inline #ifdeffery.
> +
> /* Always use prev_cpu as a candidate. */
> if (cpu == prev_cpu) {
> prev_delta = compute_energy(p, prev_cpu, pd);
next prev parent reply other threads:[~2019-11-21 12:56 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-11-20 17:55 [PATCH 0/3] sched/fair: Task placement biasing using uclamp Valentin Schneider
2019-11-20 17:55 ` [PATCH 1/3] sched/uclamp: Make uclamp_util_*() helpers use and return UL values Valentin Schneider
2019-11-20 17:55 ` [PATCH 2/3] sched/uclamp: Rename uclamp_util_*() into uclamp_rq_util_*() Valentin Schneider
2019-11-20 17:55 ` [PATCH 3/3] sched/fair: Consider uclamp for "task fits capacity" checks Valentin Schneider
2019-11-21 11:56 ` Quentin Perret
2019-11-21 12:56 ` Valentin Schneider [this message]
2019-11-21 13:30 ` Quentin Perret
2019-11-21 14:51 ` Valentin Schneider
2019-11-21 15:30 ` Quentin Perret
2019-11-21 17:22 ` Valentin Schneider
2019-11-24 22:20 ` Qais Yousef
2019-11-25 17:33 ` Valentin Schneider
2019-11-26 10:06 ` Qais Yousef
2019-11-21 12:00 ` [PATCH 0/3] sched/fair: Task placement biasing using uclamp Quentin Perret
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=f7e5dabb-a7e6-d110-abca-de7d4533bcc5@arm.com \
--to=valentin.schneider@arm.com \
--cc=dietmar.eggemann@arm.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@kernel.org \
--cc=morten.rasmussen@arm.com \
--cc=patrick.bellasi@matbug.net \
--cc=peterz@infradead.org \
--cc=qais.yousef@arm.com \
--cc=qperret@google.com \
--cc=vincent.guittot@linaro.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome