From mboxrd@z Thu Jan 1 00:00:00 1970 Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751303AbeAPIiX (ORCPT + 1 other); Tue, 16 Jan 2018 03:38:23 -0500 Received: from fllnx210.ext.ti.com ([198.47.19.17]:21915 "EHLO fllnx210.ext.ti.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1750852AbeAPIiV (ORCPT ); Tue, 16 Jan 2018 03:38:21 -0500 Subject: Re: [PATCH v5 04/44] clk: davinci: Add platform information for TI DA850 PLL To: David Lechner , , , CC: Michael Turquette , Stephen Boyd , Rob Herring , Mark Rutland , Kevin Hilman , Adam Ford , References: <1515377863-20358-1-git-send-email-david@lechnology.com> <1515377863-20358-5-git-send-email-david@lechnology.com> From: Sekhar Nori Message-ID: Date: Tue, 16 Jan 2018 14:07:07 +0530 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.5.0 MIME-Version: 1.0 In-Reply-To: <1515377863-20358-5-git-send-email-david@lechnology.com> Content-Type: text/plain; charset="utf-8" Content-Language: en-US Content-Transfer-Encoding: 7bit X-EXCLAIMER-MD-CONFIG: e1e8a2fd-e40a-4ac6-ac9b-f7e9cc9ee180 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Return-Path: On Monday 08 January 2018 07:47 AM, David Lechner wrote: > +void __init da850_pll_clk_init(void __iomem *pll0, void __iomem *pll1) > +{ > + const struct davinci_pll_divclk_info *info; > + > + davinci_pll_clk_register("pll0", "ref_clk", pll0); I think this will be more readable with empty lines between these function calls. So here .. > + davinci_pll_aux_clk_register("pll0_aux_clk", "ref_clk", pll0); .. here > + for (info = da850_pll0_divclk_info; info->name; info++) > + davinci_pll_divclk_register(info, pll0); > + > + davinci_pll_clk_register("pll1", "ref_clk", pll1); .. and here. > + for (info = da850_pll1_divclk_info; info->name; info++) > + davinci_pll_divclk_register(info, pll1); I see that you have included empty line only when changing the PLL, but I feel its more readable with the additional spacing suggested. Same comment for other patches too with similar function implemented. With that minor comment: Reviewed-by: Sekhar Nori Thanks, Sekhar