From: "Russ Dill" <russ.dill@gmail.com>
To: "Eric Miao" <eric.y.miao@gmail.com>
Cc: "Cyrill Gorcunov" <gorcunov@gmail.com>,
linux-arm-kernel@lists.arm.linux.org.uk,
"Alexey Dobriyan" <adobriyan@gmail.com>,
"Ben Dooks" <ben-linux@fluff.org>,
linux-kernel@vger.kernel.org
Subject: Re: kernel.h: add ARRAY_AND_SIZE() macro to complement ARRAY_SIZE().
Date: Fri, 19 Sep 2008 08:28:45 -0700 [thread overview]
Message-ID: <f9d2a5e10809190828g54a824b9od1ade53c96a518c8@mail.gmail.com> (raw)
In-Reply-To: <f17812d70809190022u6c862ae8j43b1c1a942e22497@mail.gmail.com>
On Fri, Sep 19, 2008 at 12:22 AM, Eric Miao <eric.y.miao@gmail.com> wrote:
> On Fri, Sep 19, 2008 at 2:54 PM, Cyrill Gorcunov <gorcunov@gmail.com> wrote:
>> [Eric Miao - Fri, Sep 19, 2008 at 02:38:21AM +0800]
>> | On Thu, Sep 18, 2008 at 11:06 PM, Alexey Dobriyan <adobriyan@gmail.com> wrote:
>> | > On Thu, Sep 18, 2008 at 02:24:47PM +0100, Ben Dooks wrote:
>> | >> Move the ARRAY_AND_SIZE() macro from arch/arm/mach-pxa/generic.h
>> | >> to a more useful position in include/linux/kernel.h. This macro
>> | >> is very useful to registration functions that take an array and
>> | >> the number of array elements in it as consecutive arguments.
>> | >>
>> | >> The macro also should ensure that mistakes where the wrong array
>> | >> is used to the ARRAY_SIZE() macro is passed. It also makes it
>> | >> easier to avoid wrapping registration function arguments.
>> | >
>> | >> --- linux-2.6.27-rc6-quilt4.orig/include/linux/kernel.h
>> | >> +++ linux-2.6.27-rc6-quilt4/include/linux/kernel.h
>> | >> @@ -43,6 +43,7 @@ extern const char linux_proc_banner[];
>> | >> #define IS_ALIGNED(x, a) (((x) & ((typeof(x))(a) - 1)) == 0)
>> | >>
>> | >> #define ARRAY_SIZE(arr) (sizeof(arr) / sizeof((arr)[0]) + __must_be_array(arr))
>> | >> +#define ARRAY_AND_SIZE(arr) (arr), ARRAY_SIZE(arr)
>> | >
>> | > Just like ARRAY_SIZE, it is misnamed.
>> | >
>> |
>> | Any hint about the correct spelling?
>> |
>> | > And it isn't obvious to what it expands. Hopefully arm people will
>> | > remove it. :-)
>> |
>> | This is handy to use, saving several key strokes and making the line
>> | shorter. If it's not obvious to what it expands, there must be some
>> | fix for it?
>> |
>>
>> well, it seems it's not that good to use ARRAY_AND_SIZE at all.
>> Yes it's short but quite frankly - hiding number of args is not
>> that good.
>>
>> example
>>
>> static void ssp_send_cmd(uint32_t *cmd, int num);
>>
>> called as
>>
>> ssp_send_cmd(ARRAY_AND_SIZE(lcd_panel_on));
>>
>> thanks it's not that spreaded across kernel.
>> Someday it could lead to ARRAY_AND_SIZE_CHECK_IF_EXIST_AND_PANIC :)
>
> Probably that not gonna happen.
>
> without ARRAY_AND_SIZE:
>
> ssp_send_cmd(lcd_panel_on, ARRAY_SIZE(lcd_panel_on));
>
> with:
>
> ssp_send_cmd(ARRAY_AND_SIZE(lcd_panel_on));
>
> where you don't have to repeat the array name. I have to admit
> that a macro expanding to something like an argument list instead
> of a single variable or something is not a good idea. But, we are
> using C, and there's no easy way just to pass the array itself,
> otherwise one may come up with:
>
> ssp_send_cmd(lcd_panel_on);
>
> ssp_send_cmd(array a)
> {
> int size = a.length();
>
> ........
> }
>
> I'm not trying to buy anyone anything, just illustrate this, and see
> if anyone else is interested in doing so.
>
My vote is for ARRAY_AND_SIZE to spread far and wide across the land.
ARRAY_SIZE is already very safe, as it has a __must_be_array macro
built in. So ARRAY_AND_SIZE is even safer, as it prevents you from
mixing up two different arrays. It also reduces line length and makes
driver and device (usually platform_device) registration code easier
to read.
next prev parent reply other threads:[~2008-09-19 15:28 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2008-09-18 13:24 Ben Dooks
2008-09-18 15:06 ` Alexey Dobriyan
2008-09-18 18:38 ` Eric Miao
2008-09-19 6:54 ` Cyrill Gorcunov
2008-09-19 7:22 ` Eric Miao
2008-09-19 7:32 ` Cyrill Gorcunov
2008-09-19 13:28 ` Stefan Richter
2008-09-19 15:28 ` Russ Dill [this message]
2008-09-19 17:55 ` Alexey Dobriyan
2008-09-20 13:05 ` Christer Weinigel
2008-09-20 13:45 ` Cyrill Gorcunov
2008-09-20 14:28 ` Christer Weinigel
2008-09-20 14:45 ` Cyrill Gorcunov
2008-09-20 16:38 ` Christer Weinigel
2008-09-20 17:12 ` Cyrill Gorcunov
2008-09-20 17:33 ` Cyrill Gorcunov
2008-09-20 22:07 ` Chris Moore
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=f9d2a5e10809190828g54a824b9od1ade53c96a518c8@mail.gmail.com \
--to=russ.dill@gmail.com \
--cc=adobriyan@gmail.com \
--cc=ben-linux@fluff.org \
--cc=eric.y.miao@gmail.com \
--cc=gorcunov@gmail.com \
--cc=linux-arm-kernel@lists.arm.linux.org.uk \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®