From: John Garry <john.garry@huawei.com>
To: "Rafael J. Wysocki" <rafael@kernel.org>
Cc: Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
Mika Westerberg <mika.westerberg@linux.intel.com>,
Lorenzo Pieralisi <lorenzo.pieralisi@arm.com>,
"Rafael J. Wysocki" <rjw@rjwysocki.net>,
"Hanjun Guo" <hanjun.guo@linaro.org>,
Rob Herring <robh+dt@kernel.org>,
Bjorn Helgaas <bhelgaas@google.com>,
Arnd Bergmann <arnd@arndb.de>,
Mark Rutland <mark.rutland@arm.com>,
Olof Johansson <olof@lixom.net>,
Dann Frazier <dann.frazier@canonical.com>,
Andy Shevchenko <andy.shevchenko@gmail.com>,
Rob Herring <robh@kernel.org>, Joe Perches <joe@perches.com>,
"Benjamin Herrenschmidt" <benh@kernel.crashing.org>,
Linux PCI <linux-pci@vger.kernel.org>,
Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
ACPI Devel Maling List <linux-acpi@vger.kernel.org>,
Linuxarm <linuxarm@huawei.com>, Corey Minyard <minyard@acm.org>,
"devicetree@vger.kernel.org" <devicetree@vger.kernel.org>,
linux-arch <linux-arch@vger.kernel.org>,
Randy Dunlap <rdunlap@infradead.org>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
Andrew Morton <akpm@linux-foundation.org>,
Frank Rowand <frowand.list@gmail.com>,
Alexander Graf <agraf@suse.de>
Subject: Re: [PATCH v16 0/9] LPC: legacy ISA I/O support
Date: Tue, 13 Mar 2018 10:42:22 +0000 [thread overview]
Message-ID: <fb457950-b0d7-0d77-02c5-f9531ea71d90@huawei.com> (raw)
In-Reply-To: <CAJZ5v0jTJ-LwyPUO7mbS47KyZ35pZeBfqkjxqubZjEGC=OJ82Q@mail.gmail.com>
On 13/03/2018 10:22, Rafael J. Wysocki wrote:
> On Tue, Mar 6, 2018 at 5:22 PM, John Garry <john.garry@huawei.com> wrote:
>>>>>>
>>>>>> Based on this patch-set, all the I/O accesses to Hip06/Hip07 LPC
>>>>>> peripherals can
>>>>>> be supported without any changes on the existing ipmi-si driver.
>>>>>>
>>>>>> The whole patchset has been tested on Hip07 D05 board both using DTB
>>>>>> and ACPI.
>>>>>>
>>>>>
>>>>>> V15 thread here: https://lkml.org/lkml/2018/2/26/584
>>>>>
>>>>>
>>>>>
>>>>> Thanks for an update.
>>>>> Though I answered to previous thread.
>>>>>
>>>>> Summary: I'm fine with the series as long as maintainers are fine
>>>>> (Rafael et al.). On personal side I think that the handler approach is
>>>>> better. Details are in v15 thread.
>>>>
>>>>
>>>>
>>>> Hi Andy,
>>>>
>>>> Thanks for your input and continued support. As I mentioned in reply in
>>>> v15,
>>>> the handler support would (or has) faced issues. And Rafael seems fine
>>>> with
>>>> deferring the probe to the LLDD in Patch #7/9
>>>
>>>
>>
>> Hi Rafael,
>>
>>> Well, the only sort-of concern is that these devices may not be
>>> "serial bus slaves" in general, so the naming is slightly confusing.
>>>
>>
>> Right, the name.
>>
>> The key point is that we model the bus the same as other serial buses like
>> I2C or SPI, so require the same treatment from the ACPI scan.
>>
>> Would you prefer acpi_is_serial_bus_slave() and
>> acpi_device_flags.serial_bus_slave symbols be modified also?
>
> Yeah, preferably.
>
> You can rename them to acpi_device_enumeration_by_parent() and
> acpi_device_flags.enumeration_by_parent, respectively, as far as I'm
> concerned.
>
> At least the names would match the purpose then. :-)
>
> And please update the comment in acpi_default_enumeration() while at it.
Hi Rafael,
That should be ok. I can just add this mentioned modification to my
series and send for review.
All the best,
John
>
> .
>
prev parent reply other threads:[~2018-03-13 10:42 UTC|newest]
Thread overview: 16+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-03-06 10:47 John Garry
2018-03-06 10:47 ` [PATCH v16 1/9] LIB: Introduce a generic PIO mapping method John Garry
2018-03-06 10:47 ` [PATCH v16 2/9] PCI: Remove unused __weak attribute in pci_register_io_range() John Garry
2018-03-06 10:47 ` [PATCH v16 3/9] PCI: Add fwnode handler as input param of pci_register_io_range() John Garry
2018-03-06 10:47 ` [PATCH v16 4/9] PCI: Apply the new generic I/O management on PCI IO hosts John Garry
2018-03-06 10:47 ` [PATCH v16 5/9] OF: Add missing I/O range exception for indirect-IO devices John Garry
2018-03-06 10:47 ` [PATCH v16 6/9] HISI LPC: Support the LPC host on Hip06/Hip07 with DT bindings John Garry
2018-03-06 10:47 ` [PATCH v16 7/9] ACPI / scan: do not enumerate Indirect IO host children John Garry
2018-03-06 10:47 ` [PATCH v16 8/9] HISI LPC: Add ACPI support John Garry
2018-03-06 10:47 ` [PATCH v16 9/9] MAINTAINERS: Add maintainer for HiSilicon LPC driver John Garry
2018-03-06 11:21 ` [PATCH v16 0/9] LPC: legacy ISA I/O support Andy Shevchenko
2018-03-06 11:36 ` John Garry
2018-03-06 15:30 ` Rafael J. Wysocki
2018-03-06 16:22 ` John Garry
2018-03-13 10:22 ` Rafael J. Wysocki
2018-03-13 10:42 ` John Garry [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=fb457950-b0d7-0d77-02c5-f9531ea71d90@huawei.com \
--to=john.garry@huawei.com \
--cc=agraf@suse.de \
--cc=akpm@linux-foundation.org \
--cc=andriy.shevchenko@linux.intel.com \
--cc=andy.shevchenko@gmail.com \
--cc=arnd@arndb.de \
--cc=benh@kernel.crashing.org \
--cc=bhelgaas@google.com \
--cc=dann.frazier@canonical.com \
--cc=devicetree@vger.kernel.org \
--cc=frowand.list@gmail.com \
--cc=gregkh@linuxfoundation.org \
--cc=hanjun.guo@linaro.org \
--cc=joe@perches.com \
--cc=linux-acpi@vger.kernel.org \
--cc=linux-arch@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=linuxarm@huawei.com \
--cc=lorenzo.pieralisi@arm.com \
--cc=mark.rutland@arm.com \
--cc=mika.westerberg@linux.intel.com \
--cc=minyard@acm.org \
--cc=olof@lixom.net \
--cc=rafael@kernel.org \
--cc=rdunlap@infradead.org \
--cc=rjw@rjwysocki.net \
--cc=robh+dt@kernel.org \
--cc=robh@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®