mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Guenter Roeck <linux@roeck-us.net>
To: James Seo <james@equiv.tech>, Jean Delvare <jdelvare@suse.com>,
	Jonathan Corbet <corbet@lwn.net>
Cc: linux-hwmon@vger.kernel.org, linux-doc@vger.kernel.org,
	linux-kernel@vger.kernel.org
Subject: Re: [RFC 02/11] hwmon: (core) Rename last parameter of devm_hwmon_register_with_info()
Date: Thu, 4 May 2023 08:29:57 -0700	[thread overview]
Message-ID: <ff6efe53-2173-1372-a1ca-c0928cf8a160@roeck-us.net> (raw)
In-Reply-To: <20230504075752.1320967-3-james@equiv.tech>

On 5/4/23 00:57, James Seo wrote:
> Change the name of the groups parameter of
> devm_hwmon_device_register_with_info() to extra_groups to
> match the name given by the hwmon API reference and in
> hwmon_device_register_with_info().
> 
> Signed-off-by: James Seo <james@equiv.tech>
> ---
>   drivers/hwmon/hwmon.c | 6 +++---
>   1 file changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/drivers/hwmon/hwmon.c b/drivers/hwmon/hwmon.c
> index 573b83b6c08c..5f205686065e 100644
> --- a/drivers/hwmon/hwmon.c
> +++ b/drivers/hwmon/hwmon.c
> @@ -1029,7 +1029,7 @@ EXPORT_SYMBOL_GPL(devm_hwmon_device_register_with_groups);
>    * @name:	hwmon name attribute
>    * @drvdata:	driver data to attach to created device
>    * @chip:	pointer to hwmon chip information
> - * @groups:	pointer to list of driver specific attribute groups
> + * @extra_groups: pointer to list of driver specific attribute groups
>    *
>    * Returns the pointer to the new device. The new device is automatically
>    * unregistered with the parent device.
> @@ -1038,7 +1038,7 @@ struct device *
>   devm_hwmon_device_register_with_info(struct device *dev, const char *name,
>   				     void *drvdata,
>   				     const struct hwmon_chip_info *chip,
> -				     const struct attribute_group **groups)
> +				     const struct attribute_group **extra_groups)

Please please please no such changes. I don't want to have to deal with
patch wars just because people believe variables should have other names.

Such changes add zero value unless one counts wasted review time as a "value".

Guenter

>   {
>   	struct device **ptr, *hwdev;
>   
> @@ -1050,7 +1050,7 @@ devm_hwmon_device_register_with_info(struct device *dev, const char *name,
>   		return ERR_PTR(-ENOMEM);
>   
>   	hwdev = hwmon_device_register_with_info(dev, name, drvdata, chip,
> -						groups);
> +						extra_groups);
>   	if (IS_ERR(hwdev))
>   		goto error;
>   


  reply	other threads:[~2023-05-04 15:30 UTC|newest]

Thread overview: 35+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-05-04  7:57 [RFC 00/11] hwmon: Modernize documentation James Seo
2023-05-04  7:57 ` [RFC 01/11] Documentation/hwmon: Move misplaced entry in hwmon docs index James Seo
2023-05-05  4:58   ` Bagas Sanjaya
2023-05-06 13:43   ` Guenter Roeck
2023-05-04  7:57 ` [RFC 02/11] hwmon: (core) Rename last parameter of devm_hwmon_register_with_info() James Seo
2023-05-04 15:29   ` Guenter Roeck [this message]
2023-05-05 13:15     ` James Seo
2023-05-05 13:30       ` Guenter Roeck
2023-05-05 14:39         ` James Seo
2023-05-04  7:57 ` [RFC 03/11] hwmon: (core) Revise kerneldoc comments James Seo
2023-07-25 23:51   ` Russell Haley
2023-05-04  7:57 ` [RFC 04/11] Documentation/hwmon: Revise hwmon kernel API reference James Seo
2023-05-05  4:12   ` Bagas Sanjaya
2023-05-05  4:20   ` Bagas Sanjaya
2023-05-05 13:29     ` James Seo
2023-05-06 13:52   ` Guenter Roeck
2023-05-07 14:40     ` James Seo
2023-05-04  7:57 ` [RFC 05/11] Documentation/hwmon: Revise PMBus core documentation James Seo
2023-05-05  4:27   ` Bagas Sanjaya
2023-05-05  4:32     ` Guenter Roeck
2023-05-05 13:35     ` James Seo
2023-05-04  7:57 ` [RFC 06/11] Documentation/hwmon: Revise patch submission checklist James Seo
2023-05-05  4:34   ` Bagas Sanjaya
2023-05-05 14:50     ` James Seo
2023-05-04  7:57 ` [RFC 07/11] Documentation/hwmon: Revise sysfs interface specification James Seo
2023-05-05  4:51   ` Bagas Sanjaya
2023-05-05 15:01     ` James Seo
2023-05-05 15:10       ` Jonathan Corbet
2023-05-04  7:57 ` [RFC 08/11] Documentation/hwmon: Revise userspace tools documentation James Seo
2023-05-05  5:03   ` Bagas Sanjaya
2023-05-05 15:12     ` James Seo
2023-05-05 21:10       ` Guenter Roeck
2023-05-04  7:57 ` [RFC 09/11] ABI: sysfs-class-hwmon: Revise hwmon ABI documentation James Seo
2023-05-04  7:57 ` [RFC 10/11] hwmon: (core) Add missing beep-related standard attributes James Seo
2023-05-04  7:57 ` [RFC 11/11] ABI: sysfs-class-hwmon: Add missing hwmon " James Seo

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=ff6efe53-2173-1372-a1ca-c0928cf8a160@roeck-us.net \
    --to=linux@roeck-us.net \
    --cc=corbet@lwn.net \
    --cc=james@equiv.tech \
    --cc=jdelvare@suse.com \
    --cc=linux-doc@vger.kernel.org \
    --cc=linux-hwmon@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®