mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Jeremy Linton <jeremy.linton@arm.com>
To: Steven Rostedt <rostedt@goodmis.org>
Cc: linux-kernel@vger.kernel.org, linux-arch@vger.kernel.org,
	mingo@redhat.com, rusty@rustcorp.com.au, jeyu@redhat.com,
	kirill.shutemov@linux.intel.com, christoffer.dall@linaro.org,
	marc.zyngier@arm.com, jcm@jonmasters.org
Subject: Re: [PATCH 12/12] tracing: Rename update the enum_map file
Date: Wed, 14 Jun 2017 13:43:26 -0500	[thread overview]
Message-ID: <ffb8c5fa-4ea7-cbea-b7ea-f88c0a49548b@arm.com> (raw)
In-Reply-To: <20170614130615.1c841159@gandalf.local.home>

On 06/14/2017 12:06 PM, Steven Rostedt wrote:
> On Tue, 13 Jun 2017 16:21:48 -0500
> Jeremy Linton <jeremy.linton@arm.com> wrote:
> 
>>> Hmm, I have to audit some userspace code to see if this is used. The
>>> enum_map was a debug feature, but it could have been used by some tools.
>>
>> I thought perf was using it, but I was mistaken. I didn't find anything
>> using it, but to be on the safe side I placed this patch last so it
>> could be dropped if a user was found. The CONFIG option seems to be
>> disabled in the couple distro's I checked, further indicating that if
>> someone is using it, they are seemingly obscure.
> 
> I pulled in all your patches but the samples one. Could you update that
> with a use case as well. You can create some crazy struct that you want
> to get the size of, or whatever. Maybe make an array out of it? Or I
> can come up with something creative.

I was actually working on that, it seems that the existing sample has 
the problem because of the __print_array(...sizeof(int)) case. So I 
think my general plan was just to update it to TRACE_DEFINE_SIZEOF(int).

Do you want a more complex example?

But this lead me to discover a number of other __print_array() cases 
where people have hardcoded the size, so I was running through those and 
converting them to sizeof() since it should work now.

> 
> I'll start testing your patches and do a push in a few days.
> 
> -- Steve
> 

  reply	other threads:[~2017-06-14 18:43 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-05-31 21:56 [PATCH 00/12] trace: add the ability to parse sizeof() Jeremy Linton
2017-05-31 21:56 ` [PATCH 01/12] trace: rename kernel enum section to eval Jeremy Linton
2017-05-31 21:56 ` [PATCH 02/12] trace: rename trace_enum_map to trace_eval_map Jeremy Linton
2017-05-31 21:56 ` [PATCH 03/12] trace: rename struct module entry for trace enums Jeremy Linton
2017-05-31 21:56 ` [PATCH 04/12] trace: rename trace enum data structures in trace.c Jeremy Linton
2017-05-31 21:56 ` [PATCH 05/12] trace: rename trace_enum_mutex to trace_eval_mutex Jeremy Linton
2017-05-31 21:56 ` [PATCH 06/12] trace: rename trace.c enum functions Jeremy Linton
2017-05-31 21:56 ` [PATCH 07/12] trace: rename enum_map functions Jeremy Linton
2017-05-31 21:56 ` [PATCH 08/12] tracing: Rename enum_replace to eval_replace Jeremy Linton
2017-05-31 21:56 ` [PATCH 09/12] tracing: define TRACE_DEFINE_SIZEOF() macro to map sizeof's to their values Jeremy Linton
2017-05-31 21:56 ` [PATCH 10/12] tracing: Update sample file to describe the new macro Jeremy Linton
2017-06-13 21:07   ` Steven Rostedt
2017-05-31 21:56 ` [PATCH 11/12] tracing: Add TRACE_DEFINE_SIZEOF() macros Jeremy Linton
2017-05-31 21:56 ` [PATCH 12/12] tracing: Rename update the enum_map file Jeremy Linton
2017-06-13 21:12   ` Steven Rostedt
2017-06-13 21:21     ` Jeremy Linton
2017-06-14 17:06       ` Steven Rostedt
2017-06-14 18:43         ` Jeremy Linton [this message]
2017-06-01  1:11 ` [PATCH 00/12] trace: add the ability to parse sizeof() Steven Rostedt

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=ffb8c5fa-4ea7-cbea-b7ea-f88c0a49548b@arm.com \
    --to=jeremy.linton@arm.com \
    --cc=christoffer.dall@linaro.org \
    --cc=jcm@jonmasters.org \
    --cc=jeyu@redhat.com \
    --cc=kirill.shutemov@linux.intel.com \
    --cc=linux-arch@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=marc.zyngier@arm.com \
    --cc=mingo@redhat.com \
    --cc=rostedt@goodmis.org \
    --cc=rusty@rustcorp.com.au \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®