mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Tachino Nobuhiro <tachino@open.nm.fujitsu.co.jp>
To: Christoph Rohland <cr@sap.com>
Cc: Tachino Nobuhiro <tachino@open.nm.fujitsu.co.jp>,
	Alan Cox <alan@lxorguk.ukuu.org.uk>,
	padraig@antefacto.com (Padraig Brady),
	scho1208@yahoo.com (Roy S.C. Ho),
	david@gibson.dropbear.id.au, linux-kernel@vger.kernel.org
Subject: Re: question about kernel 2.4 ramdisk
Date: Wed, 05 Dec 2001 17:42:25 +0900	[thread overview]
Message-ID: <itbmoy6m.wl@nisaaru.dvs.cs.fujitsu.co.jp> (raw)
In-Reply-To: <m3wv02oz2w.fsf@linux.local>
In-Reply-To: <3C0D2843.5060708@antefacto.com> <E16BLxI-0003Ic-00@the-village.bc.nu> <snaqhzhj.wl@nisaaru.dvs.cs.fujitsu.co.jp> <m3wv02oz2w.fsf@linux.local>


At 05 Dec 2001 09:23:03 +0100,
Christoph Rohland wrote:
> 
> Hi Tachino,
> 
> On Wed, 05 Dec 2001, Tachino Nobuhiro wrote:
> > +		if (!strcmp(optname, "maxfilesize") && value) {
> > +			p->filepages = simple_strtoul(value, &value, 0)
> > +				/ K_PER_PAGE;
> > +			if (*value)
> > +				return -EINVAL;
> > +		} else if (!strcmp(optname, "maxsize") && value) {
> > +			p->pages = simple_strtoul(value, &value, 0)
> > +				/ K_PER_PAGE;
> > +			if (*value)
> > +				return -EINVAL;
> > +		} else if (!strcmp(optname, "maxinodes") && value) {
> > +			p->inodes = simple_strtoul(value, &value, 0);
> > +			if (*value)
> > +				return -EINVAL;
> > +		} else if (!strcmp(optname, "maxdentries") && value) {
> > +			p->dentries = simple_strtoul(value, &value, 0);
> > +			if (*value)
> > +				return -EINVAL;
> > +		}
> 
> Please! If you do the limit checking for ramfs adapt the same options
> like shmem.c i.e. size,nr_inodes,nr_blocks,mode(+uid+gid). Don't
> invent yet another mount option set. Also give them the same
> semantics. Best would be to use shmem_parse_options.

These options are not my invention. Ramfs in 2.4.13-ac7 already has them.
But I agree the original options are not easy to understand, so if compatibility
does not matter, I am glad to change them.


> Further thought: Wouldn't it be better to add a no_swap mount option
> to shmem and try to merge the two? There is a lot of code duplication
> between mm/shmem.c and fs/ramfs/inode.c.
> 

I thought that too. but I don't know it should be done in stable kernel series.

  parent reply	other threads:[~2001-12-05  8:42 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2001-12-04 19:01 Roy S.C. Ho
2001-12-04 19:47 ` Padraig Brady
2001-12-04 20:14   ` Alan Cox
2001-12-05  7:49     ` Christoph Rohland
2001-12-05  7:56   ` Tachino Nobuhiro
2001-12-05  8:23     ` Christoph Rohland
2001-12-06 16:37       ` David Gibson
2001-12-06 16:55         ` Alan Cox
2001-12-08  9:53         ` Christoph Rohland
2001-12-14  5:35           ` David Gibson
2001-12-16 15:34             ` Christoph Rohland
2001-12-17  3:49               ` David Gibson
2001-12-17  7:55                 ` Christoph Rohland
2001-12-05  8:42     ` Tachino Nobuhiro [this message]
2001-12-05 13:51       ` Christoph Rohland
2001-12-05  9:37   ` Roy S.C. Ho

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=itbmoy6m.wl@nisaaru.dvs.cs.fujitsu.co.jp \
    --to=tachino@open.nm.fujitsu.co.jp \
    --cc=alan@lxorguk.ukuu.org.uk \
    --cc=cr@sap.com \
    --cc=david@gibson.dropbear.id.au \
    --cc=linux-kernel@vger.kernel.org \
    --cc=padraig@antefacto.com \
    --cc=scho1208@yahoo.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®