From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-3.8 required=3.0 tests=BAYES_00, HEADER_FROM_DIFFERENT_DOMAINS,MAILING_LIST_MULTI,SPF_HELO_NONE,SPF_PASS autolearn=no autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 864E6C6379D for ; Thu, 26 Nov 2020 18:19:08 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by mail.kernel.org (Postfix) with ESMTP id 4D9C321D7F for ; Thu, 26 Nov 2020 18:19:08 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S2404870AbgKZSSs (ORCPT ); Thu, 26 Nov 2020 13:18:48 -0500 Received: from foss.arm.com ([217.140.110.172]:42936 "EHLO foss.arm.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S2404410AbgKZSSs (ORCPT ); Thu, 26 Nov 2020 13:18:48 -0500 Received: from usa-sjc-imap-foss1.foss.arm.com (unknown [10.121.207.14]) by usa-sjc-mx-foss1.foss.arm.com (Postfix) with ESMTP id A24A91516; Thu, 26 Nov 2020 10:18:47 -0800 (PST) Received: from e113632-lin (e113632-lin.cambridge.arm.com [10.1.194.46]) by usa-sjc-imap-foss1.foss.arm.com (Postfix) with ESMTPSA id 508043F23F; Thu, 26 Nov 2020 10:18:46 -0800 (PST) References: <20201124141449.572446-1-maz@kernel.org> <20201124141449.572446-7-maz@kernel.org> User-agent: mu4e 0.9.17; emacs 26.3 From: Valentin Schneider To: Marc Zyngier Cc: LAK , linux-kernel , Will Deacon , Catalin Marinas , Thomas Gleixner , Peter Zijlstra , Mark Rutland , Russell King , Android Kernel Team Subject: Re: [PATCH v2 6/6] genirq: Rename IRQ_HIDDEN to IRQ_IPI In-reply-to: <20201124141449.572446-7-maz@kernel.org> Date: Thu, 26 Nov 2020 18:18:44 +0000 Message-ID: MIME-Version: 1.0 Content-Type: text/plain Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Hi Marc, On 24/11/20 14:14, Marc Zyngier wrote: > IRQ_HIDDEN was probably the wrong name, so let's rename it to IRQ_IPI, > which more accurately describe an IPI with special arch code handling. > >From the (new) name I would expect this to be set for IRQs requested via irq_reserve_ipi(), but that wouldn't be correct: MIPs uses that interface, but doesn't have our arch_show_interrupts() IPI faffery. With that in mind, perhaps the current name isn't so bad...