From: ebiederm@xmission.com (Eric W. Biederman)
To: Jamie Lokier <jamie@shareable.org>
Cc: JANAK DESAI <janak@us.ibm.com>,
viro@ftp.linux.org.uk, chrisw@osdl.org, dwmw2@infradead.org,
serue@us.ibm.com, mingo@elte.hu, linuxram@us.ibm.com,
jmorris@namei.org, sds@tycho.nsa.gov, akpm@osdl.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH -mm 1/9] unshare system call: system call handler function
Date: Thu, 15 Dec 2005 15:34:06 -0700 [thread overview]
Message-ID: <m18xum7zxd.fsf@ebiederm.dsl.xmission.com> (raw)
In-Reply-To: <20051215213234.GB6990@mail.shareable.org> (Jamie Lokier's message of "Thu, 15 Dec 2005 21:32:34 +0000")
Jamie Lokier <jamie@shareable.org> writes:
>
>> Part of the problem is the double negative in the name, leading
>> me to suggest that sys_share might almost be a better name.
>
> I agree with that suggestion, too.
>
> Alternatively, we could just add a flag to clone(): CLONE_SELF,
> meaning don't create a new task, just modify the properties of the
> current task.
Internally I doubt it would make much difference. There are
real differences from modifying current to copying from current.
Mostly it is ref counting but just enough that CLONE_SELF
is unlikely to be a sane thing to do.
Of course we could always implement spawn. The syscall with
every possible option :)
Eric
next prev parent reply other threads:[~2005-12-15 22:35 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2005-12-13 22:54 JANAK DESAI
2005-12-15 19:52 ` Eric W. Biederman
2005-12-15 20:38 ` JANAK DESAI
2005-12-15 21:13 ` Eric W. Biederman
2005-12-15 21:32 ` Jamie Lokier
2005-12-15 22:34 ` Eric W. Biederman [this message]
2005-12-16 4:36 ` JANAK DESAI
2005-12-16 4:32 ` JANAK DESAI
2005-12-16 10:50 ` Jamie Lokier
2005-12-16 12:46 ` Eric W. Biederman
2005-12-16 17:00 ` Jamie Lokier
2005-12-17 2:23 ` Eric W. Biederman
2005-12-16 14:32 ` Serge E. Hallyn
2005-12-16 12:39 ` Eric W. Biederman
2005-12-15 21:28 ` Jamie Lokier
2005-12-16 4:35 ` JANAK DESAI
-- strict thread matches above, loose matches on Subject: below --
2005-12-13 13:42 [PATCH -mm 1/9] unshare system call : " JANAK DESAI
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=m18xum7zxd.fsf@ebiederm.dsl.xmission.com \
--to=ebiederm@xmission.com \
--cc=akpm@osdl.org \
--cc=chrisw@osdl.org \
--cc=dwmw2@infradead.org \
--cc=jamie@shareable.org \
--cc=janak@us.ibm.com \
--cc=jmorris@namei.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linuxram@us.ibm.com \
--cc=mingo@elte.hu \
--cc=sds@tycho.nsa.gov \
--cc=serue@us.ibm.com \
--cc=viro@ftp.linux.org.uk \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®