From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1750897AbXDFS6E (ORCPT ); Fri, 6 Apr 2007 14:58:04 -0400 Received: (majordomo@vger.kernel.org) by vger.kernel.org id S1751023AbXDFS6E (ORCPT ); Fri, 6 Apr 2007 14:58:04 -0400 Received: from ebiederm.dsl.xmission.com ([166.70.28.69]:57993 "EHLO ebiederm.dsl.xmission.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1750897AbXDFS6B (ORCPT ); Fri, 6 Apr 2007 14:58:01 -0400 From: ebiederm@xmission.com (Eric W. Biederman) To: Davide Libenzi Cc: Oleg Nesterov , Robin Holt , Linus Torvalds , Chris Snook , Ingo Molnar , Linux Kernel Mailing List , Jack Steiner Subject: Re: init's children list is long and slows reaping children. References: <20070405195118.GH22762@lnx-holt.americas.sgi.com> <46159987.6090006@redhat.com> <20070406104301.GB19755@lnx-holt.americas.sgi.com> <20070406163100.GA554@tv-sign.ru> Date: Fri, 06 Apr 2007 12:56:57 -0600 In-Reply-To: (Davide Libenzi's message of "Fri, 6 Apr 2007 11:21:34 -0700 (PDT)") Message-ID: User-Agent: Gnus/5.110006 (No Gnus v0.6) Emacs/21.4 (gnu/linux) MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Sender: linux-kernel-owner@vger.kernel.org X-Mailing-List: linux-kernel@vger.kernel.org Davide Libenzi writes: > On Fri, 6 Apr 2007, Oleg Nesterov wrote: > >> Sure. It would be nice to move ->children into signal_struct at first. >> Except this change breaks (in fact fixes) ->pdeath_signal behaviour. > > Ohhh, the "signal" struct! Funny name for something that nowadays has > probably no more than a 5% affinity with signal-related tasks :/ Hmm. I wonder if we should just rename it the struct thread_group, or struct task_group. Those seem slightly more accurate names. I remember last time the conversation about renaming it came up no one had a good name for it that wasn't already taken. Eric