From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1754234AbbCYPbQ (ORCPT ); Wed, 25 Mar 2015 11:31:16 -0400 Received: from shonan.sfc.wide.ad.jp ([203.178.142.130]:35951 "EHLO mail.sfc.wide.ad.jp" rhost-flags-OK-OK-OK-FAIL) by vger.kernel.org with ESMTP id S1753319AbbCYPbN (ORCPT ); Wed, 25 Mar 2015 11:31:13 -0400 Date: Thu, 26 Mar 2015 00:31:09 +0900 Message-ID: From: Hajime Tazaki To: joe@perches.com Cc: linux-arch@vger.kernel.org, arnd@arndb.de, corbet@lwn.net, cl@linux.com, penberg@kernel.org, rientjes@google.com, iamjoonsoo.kim@lge.com, akpm@linux-foundation.org, linux-kernel@vger.kernel.org, linux-doc@vger.kernel.org, netdev@vger.kernel.org, linux-mm@kvack.org, jdike@addtoit.com, richard@nod.at, rusty@rustcorp.com.au, mathieu.lacage@gmail.com Subject: Re: [RFC PATCH 01/11] sysctl: make some functions unstatic to access by arch/lib In-Reply-To: <1427213619.5642.34.camel@perches.com> References: <1427202642-1716-1-git-send-email-tazaki@sfc.wide.ad.jp> <1427202642-1716-2-git-send-email-tazaki@sfc.wide.ad.jp> <1427213619.5642.34.camel@perches.com> User-Agent: Wanderlust/2.15.9 (Almost Unreal) Emacs/22.3 Mule/5.0 (SAKAKI) X-Face: "+?b:_s\r$dbBx'Ur*k#`5|~\>v~i`PzaxANTx_S?J>:mTQrtm:c7'f5b~W2eX~Fl[0Pw,0bow)8r8Z5,D&>]C/'ujqr:fbY>]/52T^Q~cX*y5\?!"i<^Vp=zCNguAeyPH$`ZTv{di25X8,%@! MIME-Version: 1.0 (generated by SEMI 1.14.6 - "Maruoka") Content-Type: text/plain; charset=US-ASCII Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org At Tue, 24 Mar 2015 09:13:39 -0700, Joe Perches wrote: > > On Tue, 2015-03-24 at 22:10 +0900, Hajime Tazaki wrote: > > libos (arch/lib) emulates a sysctl-like interface by a function call of > > userspace by enumerating sysctl tree from sysctl_table_root. It requires > > to be publicly accessible to this symbol and related functions. > [] > > diff --git a/fs/proc/proc_sysctl.c b/fs/proc/proc_sysctl.c > [] > > @@ -77,7 +77,7 @@ static int namecmp(const char *name1, int len1, const char *name2, int len2) > > } > > > > /* Called under sysctl_lock */ > > -static struct ctl_table *find_entry(struct ctl_table_header **phead, > > +struct ctl_table *find_entry(struct ctl_table_header **phead, > > find_entry and all of the _entry functions below it > are overly generic names. Maybe prefix with ctl_table_ agree. I will address this in the next version of the patch. thanks. -- Hajime