From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1758793AbcIHSIM (ORCPT ); Thu, 8 Sep 2016 14:08:12 -0400 Received: from mail-pa0-f50.google.com ([209.85.220.50]:36564 "EHLO mail-pa0-f50.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1754492AbcIHSIK (ORCPT ); Thu, 8 Sep 2016 14:08:10 -0400 From: Kevin Hilman To: Jerome Brunet Cc: Linus Walleij , Carlo Caione , linux-amlogic@lists.infradead.org, linux-arm-kernel@lists.infradead.org, linux-kernel@vger.kernel.org, linux-gpio@vger.kernel.org Subject: Re: [PATCH 1/7] pinctrl: amlogic: gxbb: add spifc pins Organization: BayLibre References: <1473261223-15412-1-git-send-email-jbrunet@baylibre.com> <1473261223-15412-2-git-send-email-jbrunet@baylibre.com> Date: Thu, 08 Sep 2016 11:08:07 -0700 In-Reply-To: <1473261223-15412-2-git-send-email-jbrunet@baylibre.com> (Jerome Brunet's message of "Wed, 7 Sep 2016 17:13:37 +0200") Message-ID: User-Agent: Gnus/5.13 (Gnus v5.13) Emacs/24.5 (darwin) MIME-Version: 1.0 Content-Type: text/plain Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Jerome Brunet writes: > Add EE domains pins for the SPI flash controller > > Signed-off-by: Jerome Brunet > --- > drivers/pinctrl/meson/pinctrl-meson-gxbb.c | 14 ++++++++++++++ > 1 file changed, 14 insertions(+) > > diff --git a/drivers/pinctrl/meson/pinctrl-meson-gxbb.c b/drivers/pinctrl/meson/pinctrl-meson-gxbb.c > index cb4d6ad..802ad83 100644 > --- a/drivers/pinctrl/meson/pinctrl-meson-gxbb.c > +++ b/drivers/pinctrl/meson/pinctrl-meson-gxbb.c > @@ -156,6 +156,11 @@ static const unsigned int emmc_clk_pins[] = { PIN(BOOT_8, EE_OFF) }; > static const unsigned int emmc_cmd_pins[] = { PIN(BOOT_10, EE_OFF) }; > static const unsigned int emmc_ds_pins[] = { PIN(BOOT_15, EE_OFF) }; > > +static const unsigned int spifc_d_pins[] = { PIN(BOOT_11, EE_OFF) }; > +static const unsigned int spifc_q_pins[] = { PIN(BOOT_12, EE_OFF) }; > +static const unsigned int spifc_c_pins[] = { PIN(BOOT_13, EE_OFF) }; > +static const unsigned int spifc_cs_pins[] = { PIN(BOOT_15, EE_OFF) }; In the datasheet, these are called nor_* instead of spifc_*. I'm trying to keep the names here aligned with the names in the datasheet. Please rename to nor_*. Thanks, Kevin