From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id ; Tue, 1 Jan 2002 08:32:23 -0500 Received: (majordomo@vger.kernel.org) by vger.kernel.org id ; Tue, 1 Jan 2002 08:32:15 -0500 Received: from fw134121.kitanet.ne.jp ([210.237.134.121]:46352 "EHLO gw.osaru.yi.org") by vger.kernel.org with ESMTP id ; Tue, 1 Jan 2002 08:32:06 -0500 Date: Tue, 01 Jan 2002 22:32:04 +0900 Message-ID: From: KANDA Mitsuru / =?ISO-2022-JP?B?GyRCP0BFRBsoQiAbJEI9PBsoQg==?= To: linux-kernel@vger.kernel.org Subject: USAGI stable release Cc: usagi-core@linux-ipv6.org User-Agent: Wanderlust/2.8.1 (Something) SEMI/1.14.3 (Ushinoya) FLIM/1.14.3 (=?ISO-8859-4?Q?Unebigory=F2mae?=) APEL/10.3 Emacs/21.1 (i386-debian-linux-gnu) MULE/5.0 (SAKAKI) X-GnuPG-fingerprint: 9A35 D378 F084 9EA4 EFBA 925B 1C93 B376 F0EF BE59 X-URL: http://www.osaru.yi.org/~mk/ X-My-AutoMobile: M2-1001 chassis#030 X-Using-IP-Version: IP version 6 MIME-Version: 1.0 (generated by SEMI 1.14.3 - "Ushinoya") Content-Type: text/plain; charset=US-ASCII Sender: linux-kernel-owner@vger.kernel.org X-Mailing-List: linux-kernel@vger.kernel.org A Happy New Year! We are glad that we can announce the 3rd STABLE RELEASE of USAGI (UniverSAl playGround for Ipv6)[1] product on January 1st, 2002. On this release, we provide ipv6 enhanced kernel (based on linux-2.2.20 and/or linux-2.4.13) and basic IPv6 libraries and applications. The improved features are listed below. - ICMPv6 Node Information Queries - Privacy Extensions (RFC 3041)(kernel-2.4 only) - IPv6 khttpd - Better source address selection - Per-device statistics for SNMP - IPv4/IPv6 socket binding on the same port - Dropping IPv6 packets with malicious address(es) - Enabling default route when IPv6 forwarding is enabled - Improving SO_REUSEADDR behavior - Fixing bugs in NDP(Neighbor Discovery Protocol) - Fixing bugs in Stateless Address Auto-configuration - Catching up and implementing RFC2553 / RFC2553bis APIs including IPV6_V6ONLY socket option - Catching up and implementing RFC2292 / RFC2292bis APIs - Making many basic applications IPv6 ready. You can get our source codes from the following URL. We also provide our code in the form divided into the patch against the main-line kernel and the tool. We plan to provide the binary packages for some distributions. They will appear under within several weeks. We announce latest information via web. Please check our web site . We also manage the mailing list for USAGI users. If you have questions, please join the mailing list. Comments and advises are also welcome on that mailing list. Please visit for further information. Thanks. About USAGI Project: The USAGI Project is managed by volunteers and aims to provide better IPv6 environment on Linux freely. We are tightly collaborating with WIDE Project[2], KAME Project[3] and TAHI Project[4], and trying improving Linux kernel, IPv6 related libraries and IPv6 applications. Our products are released every two weeks and stable release several times a year. Please check our web site for the latest detailed information. In-Reply-To: [1] USAGI Project [2] WIDE Project [3] KAME Project [4] TAHI Project -- USAGI Project