From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1755000AbbGCK6r (ORCPT ); Fri, 3 Jul 2015 06:58:47 -0400 Received: from ni.piap.pl ([195.187.100.4]:51100 "EHLO ni.piap.pl" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1754851AbbGCK6k (ORCPT ); Fri, 3 Jul 2015 06:58:40 -0400 From: khalasa@piap.pl (Krzysztof =?utf-8?Q?Ha=C5=82asa?=) To: Joe Perches Cc: Mario Bambagini , linux-kernel@vger.kernel.org, driverdev-devel@linuxdriverproject.org Subject: Re: [PATCH] defines modified to match the 80-char rule References: <1435094481-32275-1-git-send-email-mario.bambagini@gmail.com> <1435818026.2487.5.camel@perches.com> <1435860103.2487.30.camel@perches.com> Date: Fri, 03 Jul 2015 12:58:37 +0200 In-Reply-To: <1435860103.2487.30.camel@perches.com> (Joe Perches's message of "Thu, 02 Jul 2015 11:01:43 -0700") Message-ID: MIME-Version: 1.0 Content-Type: text/plain X-KLMS-Rule-ID: 1 X-KLMS-Message-Action: clean X-KLMS-AntiSpam-Lua-Profiles: 80312 [Jul 03 2015] X-KLMS-AntiSpam-Version: 5.5.6 X-KLMS-AntiSpam-Envelope-From: khalasa@piap.pl X-KLMS-AntiSpam-Rate: 0 X-KLMS-AntiSpam-Status: not_detected X-KLMS-AntiSpam-Method: none X-KLMS-AntiSpam-Moebius-Timestamps: 3633581, 3633623, 3633464 X-KLMS-AntiSpam-Info: LuaCore: 234 2015-06-28_22-28-24 b8758651e3de11965e9a6cf595acada6fc137d13, Auth:dkim=none X-KLMS-AntiSpam-Interceptor-Info: scan successful X-KLMS-AntiPhishing: Clean, 2015/07/01 09:11:51 X-KLMS-AntiVirus: Kaspersky Security 8.0 for Linux Mail Server, version 8.0.1.721, bases: 2015/07/03 06:53:00 #8582807 X-KLMS-AntiVirus-Status: Clean, skipped Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Joe Perches writes: > -#define LCONSOLE(mask, format, ...) CDEBUG(D_CONSOLE | (mask), format, ## __VA_ARGS__) > -#define LCONSOLE_INFO(format, ...) CDEBUG_LIMIT(D_CONSOLE, format, ## __VA_ARGS__) > -#define LCONSOLE_WARN(format, ...) CDEBUG_LIMIT(D_CONSOLE | D_WARNING, format, ## __VA_ARGS__) > -#define LCONSOLE_ERROR_MSG(errnum, format, ...) CDEBUG_LIMIT(D_CONSOLE | D_ERROR, \ > - "%x-%x: " format, errnum, LERRCHKSUM(errnum), ## __VA_ARGS__) > -#define LCONSOLE_ERROR(format, ...) LCONSOLE_ERROR_MSG(0x00, format, ## __VA_ARGS__) > +#define LCONSOLE(mask, fmt, ...) \ > + CDEBUG(D_CONSOLE | (mask), fmt, ##__VA_ARGS__) > +#define LCONSOLE_INFO(fmt, ...) \ > + CDEBUG_LIMIT(D_CONSOLE, fmt, ##__VA_ARGS__) > +#define LCONSOLE_WARN(fmt, ...) \ > + CDEBUG_LIMIT(D_CONSOLE | D_WARNING, fmt, ##__VA_ARGS__) > +#define LCONSOLE_ERROR_MSG(errnum, fmt, ...) \ > + CDEBUG_LIMIT(D_CONSOLE | D_ERROR, "%x-%x: " fmt, \ > + errnum, LERRCHKSUM(errnum), ##__VA_ARGS__) I don't find it better, actually I think it's much harder to read. Maybe that's just me. Call me extremist, but I think I could even like the following :-) #define CWARN(format, ...) CDEBUG_LIMIT(D_WARNING, format, ## __VA_ARGS__) #define CERROR(format, ...) CDEBUG_LIMIT(D_ERROR, format, ## __VA_ARGS__) #define CNETERR(format, ...) CDEBUG_LIMIT(D_NETERROR, format, ## __VA_ARGS__) #define CEMERG(format, ...) CDEBUG_LIMIT(D_EMERG, format, ## __VA_ARGS__) -- Krzysztof Halasa Industrial Research Institute for Automation and Measurements PIAP Al. Jerozolimskie 202, 02-486 Warsaw, Poland