From: Shay Agroskin <shayagr@amazon.com>
To: Joe Perches <joe@perches.com>
Cc: Wang Hai <wanghai38@huawei.com>, <netanel@amazon.com>,
<akiyano@amazon.com>, <gtzalik@amazon.com>, <saeedb@amazon.com>,
<zorik@amazon.com>, <davem@davemloft.net>, <kuba@kernel.org>,
<sameehj@amazon.com>, <netdev@vger.kernel.org>,
<linux-kernel@vger.kernel.org>
Subject: Re: [PATCH -next] net: ena: use NULL instead of zero
Date: Sun, 19 Jul 2020 13:08:35 +0300 [thread overview]
Message-ID: <pj41zlsgdn4y1o.fsf@ua97a68a4e7db56.ant.amazon.com> (raw)
In-Reply-To: <3093bc36c2ad86170e2e90a3451e5962d0815122.camel@perches.com>
Joe Perches <joe@perches.com> writes:
> On Sat, 2020-07-18 at 19:56 +0800, Wang Hai wrote:
>> Fix sparse build warning:
>>
>> drivers/net/ethernet/amazon/ena/ena_netdev.c:2193:34: warning:
>> Using plain integer as NULL pointer
>
> Better to remove the initialization altogether and
> move the declaration into the loop.
>
>> diff --git a/drivers/net/ethernet/amazon/ena/ena_netdev.c
>> b/drivers/net/ethernet/amazon/ena/ena_netdev.c
> []
>> @@ -2190,7 +2190,7 @@ static void ena_del_napi_in_range(struct
>> ena_adapter *adapter,
>> static void ena_init_napi_in_range(struct ena_adapter
>> *adapter,
>> int first_index, int count)
>> {
>> - struct ena_napi *napi = {0};
>> + struct ena_napi *napi = NULL;
>> int i;
>>
>> for (i = first_index; i < first_index + count; i++) {
>
> ---
> drivers/net/ethernet/amazon/ena/ena_netdev.c | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/drivers/net/ethernet/amazon/ena/ena_netdev.c
> b/drivers/net/ethernet/amazon/ena/ena_netdev.c
> index 91be3ffa1c5c..470d8f38b824 100644
> --- a/drivers/net/ethernet/amazon/ena/ena_netdev.c
> +++ b/drivers/net/ethernet/amazon/ena/ena_netdev.c
> @@ -2190,11 +2190,10 @@ static void ena_del_napi_in_range(struct
> ena_adapter *adapter,
> static void ena_init_napi_in_range(struct ena_adapter *adapter,
> int first_index, int count)
> {
> - struct ena_napi *napi = {0};
> int i;
>
> for (i = first_index; i < first_index + count; i++) {
> - napi = &adapter->ena_napi[i];
> + struct ena_napi *napi = &adapter->ena_napi[i];
>
> netif_napi_add(adapter->netdev,
> &adapter->ena_napi[i].napi,
We prefer the second variant as it improves code readability imo.
Thank you both for the time you invested in it (:
Acked-by: Shay Agroskin <shayagr@amazon.com>
next prev parent reply other threads:[~2020-07-19 10:08 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-07-18 11:56 Wang Hai
2020-07-18 15:06 ` Joe Perches
2020-07-19 10:08 ` Shay Agroskin [this message]
2020-07-20 1:48 ` wanghai (M)
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=pj41zlsgdn4y1o.fsf@ua97a68a4e7db56.ant.amazon.com \
--to=shayagr@amazon.com \
--cc=akiyano@amazon.com \
--cc=davem@davemloft.net \
--cc=gtzalik@amazon.com \
--cc=joe@perches.com \
--cc=kuba@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=netanel@amazon.com \
--cc=netdev@vger.kernel.org \
--cc=saeedb@amazon.com \
--cc=sameehj@amazon.com \
--cc=wanghai38@huawei.com \
--cc=zorik@amazon.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®