From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-13.8 required=3.0 tests=BAYES_00, HEADER_FROM_DIFFERENT_DOMAINS,INCLUDES_CR_TRAILER,INCLUDES_PATCH, MAILING_LIST_MULTI,SPF_HELO_NONE,SPF_PASS,URIBL_BLOCKED autolearn=ham autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 6BB77C433DB for ; Mon, 22 Mar 2021 11:26:17 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by mail.kernel.org (Postfix) with ESMTP id 4095461984 for ; Mon, 22 Mar 2021 11:26:17 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S229930AbhCVLZv (ORCPT ); Mon, 22 Mar 2021 07:25:51 -0400 Received: from mx2.suse.de ([195.135.220.15]:36648 "EHLO mx2.suse.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S229639AbhCVLZl (ORCPT ); Mon, 22 Mar 2021 07:25:41 -0400 X-Virus-Scanned: by amavisd-new at test-mx.suse.de Received: from relay2.suse.de (unknown [195.135.221.27]) by mx2.suse.de (Postfix) with ESMTP id 3D0BFAD4A; Mon, 22 Mar 2021 11:25:40 +0000 (UTC) Date: Mon, 22 Mar 2021 12:25:39 +0100 Message-ID: From: Takashi Iwai To: Fengfei Xi Cc: , , , Subject: Re: [PATCH] sound: remove unnecessary blank In-Reply-To: <20210321085948.11491-1-xi.fengfei@h3c.com> References: <20210321085948.11491-1-xi.fengfei@h3c.com> User-Agent: Wanderlust/2.15.9 (Almost Unreal) SEMI/1.14.6 (Maruoka) FLIM/1.14.9 (=?UTF-8?B?R29qxY0=?=) APEL/10.8 Emacs/25.3 (x86_64-suse-linux-gnu) MULE/6.0 (HANACHIRUSATO) MIME-Version: 1.0 (generated by SEMI 1.14.6 - "Maruoka") Content-Type: text/plain; charset=US-ASCII Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Sun, 21 Mar 2021 09:59:48 +0100, Fengfei Xi wrote: > > Remove unnecessary blank when calling kmalloc_array(). > > Signed-off-by: Fengfei Xi Thanks for the patch. We apply this kind of trivial coding-style fix only if it'd improve the readability significantly or when it's a preliminary work for the other actual fixes. So if you'd work on this driver further, let us know. Takashi > --- > sound/oss/dmasound/dmasound_core.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/sound/oss/dmasound/dmasound_core.c b/sound/oss/dmasound/dmasound_core.c > index 49679aa86..78bb9dfe2 100644 > --- a/sound/oss/dmasound/dmasound_core.c > +++ b/sound/oss/dmasound/dmasound_core.c > @@ -421,7 +421,7 @@ static int sq_allocate_buffers(struct sound_queue *sq, int num, int size) > return 0; > sq->numBufs = num; > sq->bufSize = size; > - sq->buffers = kmalloc_array (num, sizeof(char *), GFP_KERNEL); > + sq->buffers = kmalloc_array(num, sizeof(char *), GFP_KERNEL); > if (!sq->buffers) > return -ENOMEM; > for (i = 0; i < num; i++) { > -- > 2.17.1 >