From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-3.8 required=3.0 tests=BAYES_00, HEADER_FROM_DIFFERENT_DOMAINS,MAILING_LIST_MULTI,SPF_HELO_NONE,SPF_PASS, URIBL_BLOCKED autolearn=no autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id BFA63C43457 for ; Wed, 14 Oct 2020 08:07:08 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by mail.kernel.org (Postfix) with ESMTP id 6E45320BED for ; Wed, 14 Oct 2020 08:07:08 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1727023AbgJNIHH (ORCPT ); Wed, 14 Oct 2020 04:07:07 -0400 Received: from mx2.suse.de ([195.135.220.15]:50040 "EHLO mx2.suse.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1727451AbgJNIGw (ORCPT ); Wed, 14 Oct 2020 04:06:52 -0400 X-Virus-Scanned: by amavisd-new at test-mx.suse.de Received: from relay2.suse.de (unknown [195.135.221.27]) by mx2.suse.de (Postfix) with ESMTP id 2DB3BAFA7; Wed, 14 Oct 2020 08:06:50 +0000 (UTC) Date: Wed, 14 Oct 2020 10:06:49 +0200 Message-ID: From: Takashi Iwai To: Pavel Machek Cc: Randy Dunlap , Udo van den Heuvel , "linux-kernel@vger.kernel.org" , linux-leds@vger.kernel.org, Dan Murphy , moderated for non-subscribers Subject: Re: disabling CONFIG_LED_CLASS (SND_HDA_CODEC_REALTEK) In-Reply-To: <20201014075853.GB29881@amd> References: <3c6d174c-30db-3d03-3d16-42df405f38d9@xs4all.nl> <58e774c5-fc80-2060-2091-9a6398582cc5@infradead.org> <9fc679e9-e9a9-ad80-b24c-f04489b98aa7@xs4all.nl> <27e159be-4376-e87b-5e60-803bc3749ec2@infradead.org> <2739e1fd-75c6-4e43-cd79-9028479f91bf@infradead.org> <1e6b1961-9e9b-5f82-86a1-bf838cb68f55@xs4all.nl> <20201014075853.GB29881@amd> User-Agent: Wanderlust/2.15.9 (Almost Unreal) SEMI/1.14.6 (Maruoka) FLIM/1.14.9 (=?UTF-8?B?R29qxY0=?=) APEL/10.8 Emacs/25.3 (x86_64-suse-linux-gnu) MULE/6.0 (HANACHIRUSATO) MIME-Version: 1.0 (generated by SEMI 1.14.6 - "Maruoka") Content-Type: text/plain; charset=US-ASCII Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed, 14 Oct 2020 09:58:53 +0200, Pavel Machek wrote: > > Hi! > > > > > >>> I.e.: it looks like I will lose some funcionality when I disable > > > > >>> SND_HDA_CODEC_REALTEK. > > > > >> > > > > >> OK. At present you can't have it both ways, i.e., SND_HDA_CODEC_REALTEK > > > > >> with no LEDS. That driver apparently wants LEDS. > > > > > > > > > > Thanks but why have I gone for years without LEDS? > > > > > I do not need LEDS, I do not want LEDS, I do not have LEDS (that are > > > > > visible, usable, etc). > > > > > > > > > > Please make this selectable instead of forcing more bulk into my kernel. > > > > > > > > Hi Takashi, > > > > > > > > Regarding > > > > commit 7cdf8c49b1df0a385db06c4f9a5ba1b16510fdcc > > > > Author: Takashi Iwai > > > > Date: Thu Jun 18 13:08:31 2020 +0200 > > > > ALSA: hda: generic: Add a helper for mic-mute LED with LED classdev > > > > > > > > and this Kconfig entry: > > > > > > > > config SND_HDA_CODEC_REALTEK > > > > tristate "Build Realtek HD-audio codec support" > > > > select SND_HDA_GENERIC > > > > select SND_HDA_GENERIC_LEDS > > > > > > > > it seems that LED support is not always wanted (please see above). > > > > I.e., user(s) would like to build a kernel without LED support at all. > > > > > > > > Can you make it a build option? > > > > > > Something like this? > > > > This one is more suitable for the merge :) > > That will still break the build if SND_HDA_CODEC_REALTEK=y and > SND_HDA_GENERIC_LEDS=m, no? SND_HDA_GENERIC_LEDS is a bool, and this selects the actual LEDS_* stuff from SND_HDA_GENERIC, so the builtin vs module problem shouldn't happen. So I don't think the suggested patch would break builds. It'll hit an error at probe if the hardware actually uses the LEDs. > Lets keep things as they are. > > Contrary to his claims, Udo very probably has LEDs in his systems... Heh, a surprise :) thanks, Takashi