From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1755752AbZBIXGp (ORCPT ); Mon, 9 Feb 2009 18:06:45 -0500 Received: (majordomo@vger.kernel.org) by vger.kernel.org id S1752728AbZBIXGe (ORCPT ); Mon, 9 Feb 2009 18:06:34 -0500 Received: from mail.suse.de ([195.135.220.2]:35463 "EHLO mx1.suse.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752285AbZBIXGd (ORCPT ); Mon, 9 Feb 2009 18:06:33 -0500 Date: Tue, 10 Feb 2009 00:06:29 +0100 Message-ID: From: Takashi Iwai To: Arnd Bergmann Cc: Jaswinder Singh Rajput , Sam Ravnborg , alsa-devel@alsa-project.org, Ingo Molnar , LKML Subject: Re: usr/include/linux/soundcard.h warnings for 'make headers_check' In-Reply-To: <200902041502.08055.arnd@arndb.de> References: <1232465902.3088.31.camel@localhost.localdomain> <200902041351.18596.arnd@arndb.de> <1233755062.3135.3.camel@localhost.localdomain> <200902041502.08055.arnd@arndb.de> User-Agent: Wanderlust/2.12.0 (Your Wildest Dreams) SEMI/1.14.6 (Maruoka) FLIM/1.14.7 (=?ISO-8859-4?Q?Sanj=F2?=) APEL/10.6 Emacs/22.3 (x86_64-suse-linux-gnu) MULE/5.0 (SAKAKI) MIME-Version: 1.0 (generated by SEMI 1.14.6 - "Maruoka") Content-Type: text/plain; charset=ISO-8859-15 Content-Transfer-Encoding: 8bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org At Wed, 4 Feb 2009 15:02:07 +0100, Arnd Bergmann wrote: > > On Wednesday 04 February 2009, Jaswinder Singh Rajput wrote: > > > +#define _SEQ_EXTERN extern > > > +#define SEQ_USE_EXTBUF() \ > > > +             _SEQ_EXTERN unsigned char _seqbuf[]; \ > > > +             _SEQ_EXTERN int _seqbuflen;_SEQ_EXTERN int _seqbufptr > > > > hmm, you rename snake as rope, but actually snake is still there ;-) > > Yes, that's true. > > The alternative would be to remove all those macros entirely, breaking > also the applications from number 2 in my list. > > I see this header as another example of the byteorder.h type where > a kernel header provides functionality that is used by existing > applications. While it should have been part of a library to start > with, we cannot change it any more now without breaking stuff. > > Maybe a comment should be added to clarify this. Yes, that should help understanding, at least. I applied your previous patch with this change now no sound git tree, and will include it in the next pull request. Thanks! Takashi > > Arnd <>< > > --- a/include/linux/soundcard.h > +++ b/include/linux/soundcard.h > @@ -1050,7 +1050,17 @@ typedef struct mixer_vol_table { > * Some convenience macros to simplify programming of the > * /dev/sequencer interface > * > - * These macros define the API which should be used when possible. > + * This is a legacy interface for applications written against > + * the OSSlib-3.8 style interface. It is no longer possible > + * to actually link against OSSlib with this header, but we > + * still provide these macros for programs using them. > + * > + * If you want to use OSSlib, it is recommended that you get > + * the GPL version of OSS-4.x and build against that version > + * of the header. > + * > + * We redefine the extern keyword so that make headers_check > + * does not complain about SEQ_USE_EXTBUF. > */ > #define SEQ_DECLAREBUF() SEQ_USE_EXTBUF() > >