From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S942476AbdAIOsp (ORCPT ); Mon, 9 Jan 2017 09:48:45 -0500 Received: from mx2.suse.de ([195.135.220.15]:55560 "EHLO mx2.suse.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1033885AbdAIOrv (ORCPT ); Mon, 9 Jan 2017 09:47:51 -0500 Date: Mon, 09 Jan 2017 15:47:47 +0100 Message-ID: From: Takashi Iwai To: =?UTF-8?B?Ik1pY2hhxYIgS8SZcGllxYQi?= Cc: "Jaroslav Kysela" , , "Alex Hung" , "Anthony Wong" , "Hui Wang" , "Jim Dailey" , "Louis Davis" , "Bob Rodgers" , , "Darren Hart" , "Richard Purdie" , "Jacek Anaszewski" , "Matthew Garrett" , , , Subject: Re: [PATCH 3/7] ALSA: hda - use dell_micmute_led_set() instead of dell_app_wmi_led_set() In-Reply-To: <20170109132631.GA14411@ozzy.nask.waw.pl> References: <20161208123618.28603-1-kernel@kempniu.pl> <20161208123618.28603-4-kernel@kempniu.pl> <201612111140.38170@pali> <20161215144628.GB22695@kmp-mobile.hq.kempniu.pl> <1481816580.2090.5.camel@Pali-Nokia-N900> <20161215192253.GA4776@kmp-mobile.hq.kempniu.pl> <20170109132631.GA14411@ozzy.nask.waw.pl> User-Agent: Wanderlust/2.15.9 (Almost Unreal) SEMI/1.14.6 (Maruoka) FLIM/1.14.9 (=?UTF-8?B?R29qxY0=?=) APEL/10.8 Emacs/25.1 (x86_64-suse-linux-gnu) MULE/6.0 (HANACHIRUSATO) MIME-Version: 1.0 (generated by SEMI 1.14.6 - "Maruoka") Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 8bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Mon, 09 Jan 2017 14:26:31 +0100, Michał Kępień wrote: > > > > On Thu Dec 15 15:46:28 2016 Michał Kępień wrote: > > > > > On Thursday 08 December 2016 13:36:14 Michał Kępień wrote: > > > > > > --- a/sound/pci/hda/dell_wmi_helper.c > > > > > > +++ b/sound/pci/hda/dell_wmi_helper.c > > > > > > @@ -6,7 +6,7 @@ > > > > > > #include > > > > > > > > > > > > static int dell_led_value; > > > > > > -static int (*dell_led_set_func)(int, int); > > > > > > +static int (*dell_led_set_func)(int); > > > > > > > > > > Suggestion: what about changing name to dell_micmute_led_set_func to > > > > > match real function name which is used after this patch? > > > > > > > > While I like the idea itself, implementing it will double the number of > > > > lines that this patch changes (6 vs. 12), arguably making its intention > > > > > > If some patch makes final result of code better then metric number of lines is not priority. > > > > > > > less clear.  Please let me know if you would really like this to happen > > > > (perhaps as a separate patch?), otherwise I will skip this idea in v2. > > > > > > > > -- > > > > Best regards, > > > > Michał Kępień > > > > > > If it will be in this or another following patch... I dot care. But this is sound subsystem, so sound maintainers need to decide what they prefer. > > > > Good point. Jaroslav, Takashi, I will patiently wait for your opinion > > on this patch and Pali's suggestion quoted above before I post v2 of > > this series. > > As it has already been a month since I posted this patch series, this is > just a reminder that I am waiting for comments from the sound subsystem > maintainers before I post v2. > > Jaroslav, Takashi, I could really use your input. Please let me know if > something is unclear. Thanks, Sorry, the last post was overseen as I already went off to vacation. The rename can be done in another patch. Doing multiple things in a single patch often leads to more confusion and error-prone. Other than that, I'm fine with rename. thanks, Takashi