From: Takashi Iwai <tiwai@suse.de>
To: George Harker <george@george-graphics.co.uk>
Cc: alsa-devel@alsa-project.org, Clemens Ladisch <clemens@ladisch.de>,
Jaroslav Kysela <perex@perex.cz>, Takashi Iwai <tiwai@suse.com>,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH] sound/usb generate midi streaming substream names from jack names
Date: Wed, 24 Feb 2021 08:57:28 +0100 [thread overview]
Message-ID: <s5hczwpucd3.wl-tiwai@suse.de> (raw)
In-Reply-To: <20210221094333.30499-1-george@george-graphics.co.uk>
On Sun, 21 Feb 2021 10:43:32 +0100,
George Harker wrote:
>
> A number of devices have named substreams which are hard to remember /
> decypher from <device> MIDI n names. Eg. Korg puts a pass through on
> one substream and iConnectivity devices name the connections.
>
> This makes it easier to connect to the correct device. Devices which
> handle naming through quirks are unaffected by this change.
>
> Addresses TODO comment in sound/usb/midi.c
>
> Signed-off-by: George Harker <george@george-graphics.co.uk>
The code changes look almost OK, but could you try the following?
- Split the patch: one for rewriting with the structs in
linux/usb/midi.h, another for adding the MIDI device name support
- Try to avoid magic numbers: a few places should be replaced with
sizeof() or ARRAY_SIZE().
thanks,
Takashi
next prev parent reply other threads:[~2021-02-24 8:00 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <20210221094148.30447-1-george@george-graphics.co.uk>
2021-02-21 9:43 ` George Harker
2021-02-24 7:57 ` Takashi Iwai [this message]
2021-02-26 21:24 ` [PATCH 1/2] use usb headers rather than define structs locally George Harker
2021-02-26 21:26 ` [PATCH 2/2] midi streaming substream names from jack names A number of devices have named substreams which are hard to remember / decypher from <device> MIDI n names. Eg. Korg puts a pass through on one substream and iConnectivity devices name the connections George Harker
2021-02-26 21:36 ` George Harker
2021-03-01 8:27 ` Takashi Iwai
2021-02-21 8:53 [PATCH] sound/usb generate midi streaming substream names from jack names George Harker
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=s5hczwpucd3.wl-tiwai@suse.de \
--to=tiwai@suse.de \
--cc=alsa-devel@alsa-project.org \
--cc=clemens@ladisch.de \
--cc=george@george-graphics.co.uk \
--cc=linux-kernel@vger.kernel.org \
--cc=perex@perex.cz \
--cc=tiwai@suse.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome