From: Takashi Iwai <tiwai@suse.de>
To: "Satendra Singh Thakur" <satendra.t@samsung.com>
Cc: <alsa-devel@alsa-project.org>, <perex@perex.cz>,
<o-takashi@sakamocchi.jp>, <hemanshu.s@samsung.com>,
<nishant.s4@samsung.com>, <linux-kernel@vger.kernel.org>
Subject: Re: [RFC v2] [ALSA][CONTROL] 1. Added 2 ioctls for reading/writing values of multiple controls in one go (at once) 2. Restructured the code for read/write of a single control
Date: Fri, 03 Feb 2017 08:29:38 +0100 [thread overview]
Message-ID: <s5hefzfivfh.wl-tiwai@suse.de> (raw)
In-Reply-To: <1486099688-8057-1-git-send-email-satendra.t@samsung.com>
On Fri, 03 Feb 2017 06:28:08 +0100,
Satendra Singh Thakur wrote:
>
> From: satendra singh thakur <satendra.t@samsung.com>
>
> 1.Added 2 ioctls in alsa driver's control interface
> -Added an ioctl to read values of multiple elements at once
> -Added an ioctl to write values of multiple elements at once
> -In the absence of above ioctls user needs to call N ioctls to
> read/write value of N elements which requires N context switches
> -Proposed ioctls will allow accessing N elements' values in a single
> context switch
> -Above mentioned ioctl will be useful for alsa utils such as amixer
> which reads all controls of given sound card
> 2. Restructured/Combined two functions snd_ctl_elem_read_user and
> snd_ctl_elem_write_user into a single function snd_ctl_elem_rw_user
> -These functions were having most of the code which was similar
> to each other
> -Thus, there was redundant/duplicate code which was removed
> and a single function was formed/defined.
> -Removed functions snd_ctl_elem_read_user and snd_ctl_elem_write_user
> having redundant/duplicate code
> 3. This is version 2 of RFC, here we combine previous 2 patches
> submitted yesterday (02-Feb) with prefix [RFC] [ALSA][CONTROL]
> -Fixed doxygen comments related warnings
> -Fixed stack frame related warning
>
> Signed-off-by: Satendra Singh Thakur <satendra.t@samsung.com>
Thanks for the patch.
But, could you answer to the question Clemens posted for v1 patch?
Namely, do N-times context switching really matter? Does it give the
severe performance issue?
If we have a measured number, this thing is worth to consider.
OTOH, without the actual measurement but "just because it must be
better", it's no good reason for adding a new API/ABI.
thanks,
Takashi
next prev parent reply other threads:[~2017-02-03 7:29 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <CGME20170203052820epcas4p2287bdd4bb4de9e5e4c363bcd6872681e@epcas4p2.samsung.com>
2017-02-03 5:28 ` Satendra Singh Thakur
2017-02-03 7:29 ` Takashi Iwai [this message]
2017-02-07 4:33 ` Takashi Sakamoto
2017-02-07 6:24 ` Takashi Iwai
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=s5hefzfivfh.wl-tiwai@suse.de \
--to=tiwai@suse.de \
--cc=alsa-devel@alsa-project.org \
--cc=hemanshu.s@samsung.com \
--cc=linux-kernel@vger.kernel.org \
--cc=nishant.s4@samsung.com \
--cc=o-takashi@sakamocchi.jp \
--cc=perex@perex.cz \
--cc=satendra.t@samsung.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®