From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1755278Ab3AYJKM (ORCPT ); Fri, 25 Jan 2013 04:10:12 -0500 Received: from cantor2.suse.de ([195.135.220.15]:51575 "EHLO mx2.suse.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752115Ab3AYJJ7 (ORCPT ); Fri, 25 Jan 2013 04:09:59 -0500 Date: Fri, 25 Jan 2013 10:09:56 +0100 Message-ID: From: Takashi Iwai To: Stratos Karafotis Cc: Jaroslav Kysela , David Henningsson , alsa-devel@alsa-project.org, linux-kernel@vger.kernel.org, linux-next@vger.kernel.org Subject: Re: [PATCH next-20130124] Sound: pci: Fix unused variable warning in patch_sigmatel.c In-Reply-To: <5101B7CE.4070102@semaphore.gr> References: <5101B7CE.4070102@semaphore.gr> User-Agent: Wanderlust/2.15.9 (Almost Unreal) SEMI/1.14.6 (Maruoka) FLIM/1.14.9 (=?UTF-8?B?R29qxY0=?=) APEL/10.8 Emacs/24.2 (x86_64-suse-linux-gnu) MULE/6.0 (HANACHIRUSATO) MIME-Version: 1.0 (generated by SEMI 1.14.6 - "Maruoka") Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 8bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org At Fri, 25 Jan 2013 00:38:06 +0200, Stratos Karafotis wrote: > > Fix the following build warnings > > sound/pci/hda/patch_sigmatel.c: In function ‘stac92hd71bxx_fixup_hp’: > sound/pci/hda/patch_sigmatel.c:2434:24: warning: unused variable ‘spec’ [-Wunused-variable] Thanks for catching. But such temporal cast like your patch makes the code readability much worse. The code readability (thus its maintainability) is a more important factor. I'm going to fix the definition of snd_printd() itself for fixing this kind of warnings. We can use inline functions instead of empty macros to achieve the same but without triggering compiler warnings. Takashi > > Signed-off-by: Stratos Karafotis > --- > sound/pci/hda/patch_sigmatel.c | 14 +++++--------- > 1 file changed, 5 insertions(+), 9 deletions(-) > > diff --git a/sound/pci/hda/patch_sigmatel.c b/sound/pci/hda/patch_sigmatel.c > index 0aa0ceb..f269d1f 100644 > --- a/sound/pci/hda/patch_sigmatel.c > +++ b/sound/pci/hda/patch_sigmatel.c > @@ -2365,7 +2365,6 @@ static void stac92hd71bxx_fixup_ref(struct hda_codec *codec, > static void stac92hd71bxx_fixup_hp_m4(struct hda_codec *codec, > const struct hda_fixup *fix, int action) > { > - struct sigmatel_spec *spec = codec->spec; > struct hda_jack_tbl *jack; > > if (action != HDA_FIXUP_ACT_PRE_PROBE) > @@ -2381,7 +2380,7 @@ static void stac92hd71bxx_fixup_hp_m4(struct hda_codec *codec, > if (jack) > jack->private_data = 0x02; > > - spec->gpio_mask |= 0x02; > + ((struct sigmatel_spec *)codec->spec)->gpio_mask |= 0x02; > > /* enable internal microphone */ > snd_hda_codec_set_pincfg(codec, 0x0e, 0x01813040); > @@ -2420,19 +2419,15 @@ static void stac92hd71bxx_fixup_hp_dv5(struct hda_codec *codec, > static void stac92hd71bxx_fixup_hp_hdx(struct hda_codec *codec, > const struct hda_fixup *fix, int action) > { > - struct sigmatel_spec *spec = codec->spec; > - > if (action != HDA_FIXUP_ACT_PRE_PROBE) > return; > - spec->gpio_led = 0x08; > + ((struct sigmatel_spec *)codec->spec)->gpio_led = 0x08; > } > > > static void stac92hd71bxx_fixup_hp(struct hda_codec *codec, > const struct hda_fixup *fix, int action) > { > - struct sigmatel_spec *spec = codec->spec; > - > if (action != HDA_FIXUP_ACT_PRE_PROBE) > return; > > @@ -2456,8 +2451,9 @@ static void stac92hd71bxx_fixup_hp(struct hda_codec *codec, > > if (find_mute_led_cfg(codec, 1)) > snd_printd("mute LED gpio %d polarity %d\n", > - spec->gpio_led, > - spec->gpio_led_polarity); > + ((struct sigmatel_spec *)codec->spec)->gpio_led, > + ((struct sigmatel_spec *)codec->spec)-> > + gpio_led_polarity); > > } > > -- > 1.8.1 >