From: Takashi Iwai <tiwai@suse.de>
To: Sudip Mukherjee <sudipm.mukherjee@gmail.com>
Cc: Jaroslav Kysela <perex@perex.cz>,
alsa-devel@alsa-project.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2] ALSA: korg1212: cleanup of printk
Date: Mon, 24 Nov 2014 18:08:02 +0100 [thread overview]
Message-ID: <s5hh9xottl9.wl-tiwai@suse.de> (raw)
In-Reply-To: <1416730251-5194-1-git-send-email-sudipm.mukherjee@gmail.com>
At Sun, 23 Nov 2014 13:40:51 +0530,
Sudip Mukherjee wrote:
>
> From: Sudip Mukherjee <sudip@vectorindia.org>
>
> replaced all references of the debug messages via printk
> with dev_* macro (mostly dev_dbg).
> one reference was changed to pr_err as there the card might have been
> uninitialized.
>
> this patch will generate warning from checkpatch about broken quoted
> strings. but that was not fixed intentionally to improve the
> readability.
>
> Signed-off-by: Sudip Mukherjee <sudip@vectorindia.org>
> ---
>
> change in v2: the build warnings of v1 are fixed.
>
> hi Takashi,
> in your review of v1, you said about some lines which are not ending
> with \n. but i was not able to find them. did i miss them somewhere?
The problem is the one with multiple "\n", for example:
dev_dbg(korg1212->card->dev, "dspMemPhy = %08x U[%08x], "
"PlayDataPhy = %08x L[%08x]\n"
"korg1212: RecDataPhy = %08x L[%08x], "
"VolumeTablePhy = %08x L[%08x]\n"
"korg1212: RoutingTablePhy = %08x L[%08x], "
"AdatTimeCodePhy = %08x L[%08x]\n",
My biggest concern right now is, however, about the unnecessary code
increase by this patch. Currently, most of debug prints were simply
not built, because of:
> // ----------------------------------------------------------------------------
> -// Debug Stuff
> -// ----------------------------------------------------------------------------
> -#define K1212_DEBUG_LEVEL 0
> -#if K1212_DEBUG_LEVEL > 0
> -#define K1212_DEBUG_PRINTK(fmt,args...) printk(KERN_DEBUG fmt,##args)
> -#else
> -#define K1212_DEBUG_PRINTK(fmt,...)
> -#endif
> -#if K1212_DEBUG_LEVEL > 1
> -#define K1212_DEBUG_PRINTK_VERBOSE(fmt,args...) printk(KERN_DEBUG fmt,##args)
> -#else
> -#define K1212_DEBUG_PRINTK_VERBOSE(fmt,...)
> -#endif
With your patch, now all these codes are compiled.
I have no clear answer what would be the best in such a case. I'd say
it really depends. If they are just silly messages that can be
covered in a better way (like ftrace), just get rid of them. If they
are intended for some good register dumps, then dev_dbg() might make
sense.
Takashi
next prev parent reply other threads:[~2014-11-24 17:08 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-11-23 8:10 Sudip Mukherjee
2014-11-24 17:08 ` Takashi Iwai [this message]
2014-11-24 17:25 ` Joe Perches
2014-11-25 6:21 ` Sudip Mukherjee
2014-11-25 18:59 ` Joe Perches
2014-11-26 10:49 ` Sudip Mukherjee
2014-11-26 18:27 ` Joe Perches
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=s5hh9xottl9.wl-tiwai@suse.de \
--to=tiwai@suse.de \
--cc=alsa-devel@alsa-project.org \
--cc=linux-kernel@vger.kernel.org \
--cc=perex@perex.cz \
--cc=sudipm.mukherjee@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome