From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1426159AbcBRKVI (ORCPT ); Thu, 18 Feb 2016 05:21:08 -0500 Received: from mx2.suse.de ([195.135.220.15]:56171 "EHLO mx2.suse.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1426116AbcBRKUa (ORCPT ); Thu, 18 Feb 2016 05:20:30 -0500 Date: Thu, 18 Feb 2016 11:20:28 +0100 Message-ID: From: Takashi Iwai To: "Sudip Mukherjee" Cc: "Jaroslav Kysela" , , Subject: Re: [PATCH v5] portman2x4 - use new parport device model In-Reply-To: <1455713787-13382-1-git-send-email-sudipm.mukherjee@gmail.com> References: <1455713787-13382-1-git-send-email-sudipm.mukherjee@gmail.com> User-Agent: Wanderlust/2.15.9 (Almost Unreal) SEMI/1.14.6 (Maruoka) FLIM/1.14.9 (=?UTF-8?B?R29qxY0=?=) APEL/10.8 Emacs/24.5 (x86_64-suse-linux-gnu) MULE/6.0 (HANACHIRUSATO) MIME-Version: 1.0 (generated by SEMI 1.14.6 - "Maruoka") Content-Type: text/plain; charset=US-ASCII Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed, 17 Feb 2016 13:56:27 +0100, Sudip Mukherjee wrote: > > Modify portman driver to use the new parallel port device model. > The advantage of using the device model is that the device gets binded > to the hardware, we get the feature of hotplug, we can bind/unbind > the driver at runtime. > The changes are in the way the driver gets registered with the > parallel port subsystem and the temporary device to probe portman card > is removed and portman_probe() is used in the probe callback. > > Signed-off-by: Sudip Mukherjee > --- > > v5: claimed flag and one call to parport_claim() removed. > v4: temporary device to probe is removed. > v3: changed commit message > v2: > 1. pardev_cb is initialized while declaring, thus removing the use of > memset. > 2. used pdev->id. > 3. v1 did not have the parport probe callback, but we will need the > probe callback for binding as the name of the driver and the name of > the device is different. > 4. in v1 I missed modifying snd_portman_probe_port(). OK, I merged this one to for-next branch now. Let's cross fingers :) thanks, Takashi