From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-0.8 required=3.0 tests=HEADER_FROM_DIFFERENT_DOMAINS, MAILING_LIST_MULTI,SPF_HELO_NONE,SPF_PASS autolearn=no autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 7A112C432C3 for ; Wed, 13 Nov 2019 16:40:48 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [209.132.180.67]) by mail.kernel.org (Postfix) with ESMTP id A735820643 for ; Wed, 13 Nov 2019 16:40:46 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1728558AbfKMQkr (ORCPT ); Wed, 13 Nov 2019 11:40:47 -0500 Received: from mx2.suse.de ([195.135.220.15]:40962 "EHLO mx1.suse.de" rhost-flags-OK-OK-OK-FAIL) by vger.kernel.org with ESMTP id S1727687AbfKMQkq (ORCPT ); Wed, 13 Nov 2019 11:40:46 -0500 X-Virus-Scanned: by amavisd-new at test-mx.suse.de Received: from relay2.suse.de (unknown [195.135.220.254]) by mx1.suse.de (Postfix) with ESMTP id 5F9A6ACA7; Wed, 13 Nov 2019 16:40:44 +0000 (UTC) Date: Wed, 13 Nov 2019 17:40:43 +0100 Message-ID: From: Takashi Iwai To: Arnd Bergmann Cc: ALSA Development Mailing List , Takashi Iwai , Baolin Wang , y2038 Mailman List , "linux-kernel@vger.kernel.org" , Jaroslav Kysela , Mark Brown Subject: Re: [PATCH v6 0/8] Fix year 2038 issue for sound subsystem In-Reply-To: References: <20191112151642.680072-1-arnd@arndb.de> User-Agent: Wanderlust/2.15.9 (Almost Unreal) SEMI/1.14.6 (Maruoka) FLIM/1.14.9 (=?UTF-8?B?R29qxY0=?=) APEL/10.8 Emacs/25.3 (x86_64-suse-linux-gnu) MULE/6.0 (HANACHIRUSATO) MIME-Version: 1.0 (generated by SEMI 1.14.6 - "Maruoka") Content-Type: text/plain; charset=US-ASCII Sender: linux-kernel-owner@vger.kernel.org Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed, 13 Nov 2019 15:32:44 +0100, Arnd Bergmann wrote: > > On Tue, Nov 12, 2019 at 9:37 PM Takashi Iwai wrote: > > On Tue, 12 Nov 2019 16:16:34 +0100, Arnd Bergmann wrote: > > > I would like to propose merging this into the alsa tree after > > > the v5.5 merge window for inclusion into v5.6, to allow a good > > > amount of testing, in particular for the header changes that > > > may cause problems for user space applications. > > > > Agreed, it's still no urgent problem. > > I actually do think it's getting urgent, anything that touches > the ABI must be done carefully and not rushed. > > The urgency at the moment is that developers are starting to > deploy systems with 64-bit time_t with musl-libc making this > the default now, and 32-bit risc-v not offering 32-bit time_t at all. > > At the moment, this means that audio support is broken for > them, and that needs to be fixed. > > The other reason why lots of people care about moving all user > space to 64-bit time_t is that 32-bit hardware is slowly starting > to become less common. We know there will still be many > 32-bit ARM systems operational in 2038, but most of them will > be on (then) 10+ year old hardware, running even older software > that already being worked on today. The longer it takes us to > stop using 32-bit time_t in user space, the more systems will > end up having to be thrown away rather than fixed. Don't worry, I planned merging the whole changes for 5.6. > > So now taking a quick look through the series, I find this approach is > > the way to go. Although one might get a bit more optimization after > > squeeze, it's already a good compromise between the readability and > > the efficiency. > > Thanks! > > > A slight uncertain implementation is the timer tread stuff, especially > > the conditional definition of SNDRV_TIMER_IOCTL_TREAD (IIRC, I already > > complained it in the past, too). But I have no other idea as well, so > > unless someone else gives a better option, we can live with that. > > We had discussed alternatives for this one last time, and decided > to go with the solution I posted here. The main alternative would > be to change the 'timespec' in snd_timer_tread to a fixed-length > structure based on two 'long' members. This would avoid the > need to match the command with the time_t type, but the cost would > be requiring CLOCK_MONOTONIC timestamps to avoid the > overflow, and changing all application source code that requires > the type to be compatible with 'timespec'. Fair enough. One thing I forgot to mention: when we add/modify the ioctl or ABI, we need to increment the protocol version, e.g. SNDRV_PCM_VERSION to indicate user-space the supported ABI. Please change these in your next patches, too. thanks, Takashi