mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Rong Tao <rtoax@foxmail.com>
To: Quentin Monnet <qmo@kernel.org>, ast@kernel.org, daniel@iogearbox.net
Cc: rongtao@cestc.cn, Andrii Nakryiko <andrii@kernel.org>,
	Martin KaFai Lau <martin.lau@linux.dev>,
	Eduard Zingerman <eddyz87@gmail.com>, Song Liu <song@kernel.org>,
	Yonghong Song <yonghong.song@linux.dev>,
	John Fastabend <john.fastabend@gmail.com>,
	KP Singh <kpsingh@kernel.org>,
	Stanislav Fomichev <sdf@fomichev.me>, Hao Luo <haoluo@google.com>,
	Jiri Olsa <jolsa@kernel.org>,
	"open list:BPF [TOOLING] (bpftool)" <bpf@vger.kernel.org>,
	open list <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH bpf-next] bpftool: Check map name length when map create
Date: Tue, 11 Feb 2025 18:34:24 +0800	[thread overview]
Message-ID: <tencent_152195E35781D102C443834B219FACA04B07@qq.com> (raw)
In-Reply-To: <3da61b9b-fa44-4a45-bccb-40a23ef997ce@kernel.org>


On 2/11/25 18:20, Quentin Monnet wrote:
> 2025-02-11 16:45 UTC+0800 ~ Rong Tao <rtoax@foxmail.com>
>> From: Rong Tao <rongtao@cestc.cn>
>>
>> The size of struct bpf_map::name is BPF_OBJ_NAME_LEN (16).
>>
>> bpf(2) {
>>    map_create() {
>>      bpf_obj_name_cpy(map->name, attr->map_name, sizeof(attr->map_name));
>>    }
>> }
>>
>> When specifying a map name using bpftool map create name, no error is
>> reported if the name length is greater than 15.
>>
>>      $ sudo bpftool map create /sys/fs/bpf/12345678901234567890 \
>>          type array key 4 value 4 entries 5 name 12345678901234567890
>>
>> Users will think that 12345678901234567890 is legal, but this name cannot
>> be used to index a map.
>>
>>      $ sudo bpftool map show name 12345678901234567890
>>      Error: can't parse name
>>
>>      $ sudo bpftool map show
>>      ...
>>      1249: array  name 123456789012345  flags 0x0
>>      	key 4B  value 4B  max_entries 5  memlock 304B
>>
>>      $ sudo bpftool map show name 123456789012345
>>      1249: array  name 123456789012345  flags 0x0
>>      	key 4B  value 4B  max_entries 5  memlock 304B
>>
>> The map name provided in the command line is truncated, but no error is
>> reported. This submission checks the length of the map name.
>>
>> Signed-off-by: Rong Tao <rongtao@cestc.cn>
>> ---
>>   tools/bpf/bpftool/map.c | 6 ++++++
>>   1 file changed, 6 insertions(+)
>>
>> diff --git a/tools/bpf/bpftool/map.c b/tools/bpf/bpftool/map.c
>> index ed4a9bd82931..fa00f7865065 100644
>> --- a/tools/bpf/bpftool/map.c
>> +++ b/tools/bpf/bpftool/map.c
>> @@ -1330,6 +1330,12 @@ static int do_create(int argc, char **argv)
>>   		goto exit;
>>   	}
>>   
>> +	if (strlen(map_name) > BPF_OBJ_NAME_LEN - 1) {
>> +		p_err("The map name is too long, should be less than %d\n",
>
> Nit: I'd drop "The" (and the capital letter) for consistency with other
> messages in bpftool; and I'd replace "less than ..." with "no longer
> than %d characters\n" to make it explicit and avoid confusion between
> "strictly less" and "less or equal".

Thanks, i'll submit another patch.

Rong Tao.

>
>> +		      BPF_OBJ_NAME_LEN - 1);
>> +		goto exit;
>> +	}
>> +
>>   	set_max_rlimit();
>>   
>>   	fd = bpf_map_create(map_type, map_name, key_size, value_size, max_entries, &attr);
>
> There's no need to defer the check until after we've parsed all
> arguments. Can you move it to the location where we retrieve the name,
> please?:
>
> 		[...]
> 		} else if (is_prefix(*argv, "name")) {
> 			NEXT_ARG();
> 			map_name = GET_ARG();
> 		} else ...
>
> pw-bot: cr
>
> Apart from these, it's a good idea to fix it, thank you!
> Quentin


      reply	other threads:[~2025-02-11 10:39 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-02-11  8:45 Rong Tao
2025-02-11 10:20 ` Quentin Monnet
2025-02-11 10:34   ` Rong Tao [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=tencent_152195E35781D102C443834B219FACA04B07@qq.com \
    --to=rtoax@foxmail.com \
    --cc=andrii@kernel.org \
    --cc=ast@kernel.org \
    --cc=bpf@vger.kernel.org \
    --cc=daniel@iogearbox.net \
    --cc=eddyz87@gmail.com \
    --cc=haoluo@google.com \
    --cc=john.fastabend@gmail.com \
    --cc=jolsa@kernel.org \
    --cc=kpsingh@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=martin.lau@linux.dev \
    --cc=qmo@kernel.org \
    --cc=rongtao@cestc.cn \
    --cc=sdf@fomichev.me \
    --cc=song@kernel.org \
    --cc=yonghong.song@linux.dev \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®