From: "tip-bot for Jérémy Lefaure" <tipbot@zytor.com>
To: linux-tip-commits@vger.kernel.org
Cc: linux-kernel@vger.kernel.org, jeremy.lefaure@lse.epita.fr,
tglx@linutronix.de, hpa@zytor.com, mj@ucw.cz,
luto@amacapital.net, mingo@kernel.org
Subject: [tip:x86/cleanups] x86: Use ARRAY_SIZE
Date: Thu, 19 Oct 2017 07:18:51 -0700 [thread overview]
Message-ID: <tip-0cfe5b5fc0277463fa795dea312a3a2fd5e8bac2@git.kernel.org> (raw)
In-Reply-To: <20171001193101.8898-13-jeremy.lefaure@lse.epita.fr>
Commit-ID: 0cfe5b5fc0277463fa795dea312a3a2fd5e8bac2
Gitweb: https://git.kernel.org/tip/0cfe5b5fc0277463fa795dea312a3a2fd5e8bac2
Author: Jérémy Lefaure <jeremy.lefaure@lse.epita.fr>
AuthorDate: Sun, 1 Oct 2017 15:30:50 -0400
Committer: Thomas Gleixner <tglx@linutronix.de>
CommitDate: Thu, 19 Oct 2017 16:15:47 +0200
x86: Use ARRAY_SIZE
Using the ARRAY_SIZE macro improves the readability of the code.
Found with Coccinelle with the following semantic patch:
@r depends on (org || report)@
type T;
T[] E;
position p;
@@
(
(sizeof(E)@p /sizeof(*E))
|
(sizeof(E)@p /sizeof(E[...]))
|
(sizeof(E)@p /sizeof(T))
)
Signed-off-by: Jérémy Lefaure <jeremy.lefaure@lse.epita.fr>
Signed-off-by: Thomas Gleixner <tglx@linutronix.de>
Cc: linux-video@atrey.karlin.mff.cuni.cz
Cc: Martin Mares <mj@ucw.cz>
Cc: Andy Lutomirski <luto@amacapital.net>
Link: https://lkml.kernel.org/r/20171001193101.8898-13-jeremy.lefaure@lse.epita.fr
---
arch/x86/boot/video-vga.c | 6 +++---
arch/x86/entry/vdso/vdso2c.c | 3 ++-
arch/x86/platform/intel-mid/device_libs/platform_gpio_keys.c | 5 ++---
3 files changed, 7 insertions(+), 7 deletions(-)
diff --git a/arch/x86/boot/video-vga.c b/arch/x86/boot/video-vga.c
index 45bc940..a14c517 100644
--- a/arch/x86/boot/video-vga.c
+++ b/arch/x86/boot/video-vga.c
@@ -241,9 +241,9 @@ static int vga_probe(void)
vga_modes,
};
static int mode_count[] = {
- sizeof(cga_modes)/sizeof(struct mode_info),
- sizeof(ega_modes)/sizeof(struct mode_info),
- sizeof(vga_modes)/sizeof(struct mode_info),
+ ARRAY_SIZE(cga_modes),
+ ARRAY_SIZE(ega_modes),
+ ARRAY_SIZE(vga_modes),
};
struct biosregs ireg, oreg;
diff --git a/arch/x86/entry/vdso/vdso2c.c b/arch/x86/entry/vdso/vdso2c.c
index 0780a44..4674f58 100644
--- a/arch/x86/entry/vdso/vdso2c.c
+++ b/arch/x86/entry/vdso/vdso2c.c
@@ -65,6 +65,7 @@
#include <linux/elf.h>
#include <linux/types.h>
+#include <linux/kernel.h>
const char *outfilename;
@@ -151,7 +152,7 @@ extern void bad_put_le(void);
PLE(x, val, 64, PLE(x, val, 32, PLE(x, val, 16, LAST_PLE(x, val))))
-#define NSYMS (sizeof(required_syms) / sizeof(required_syms[0]))
+#define NSYMS ARRAY_SIZE(required_syms)
#define BITSFUNC3(name, bits, suffix) name##bits##suffix
#define BITSFUNC2(name, bits, suffix) BITSFUNC3(name, bits, suffix)
diff --git a/arch/x86/platform/intel-mid/device_libs/platform_gpio_keys.c b/arch/x86/platform/intel-mid/device_libs/platform_gpio_keys.c
index 7428387..e639e31 100644
--- a/arch/x86/platform/intel-mid/device_libs/platform_gpio_keys.c
+++ b/arch/x86/platform/intel-mid/device_libs/platform_gpio_keys.c
@@ -62,10 +62,9 @@ static struct platform_device pb_device = {
static int __init pb_keys_init(void)
{
struct gpio_keys_button *gb = gpio_button;
- int i, num, good = 0;
+ int i, good = 0;
- num = sizeof(gpio_button) / sizeof(struct gpio_keys_button);
- for (i = 0; i < num; i++) {
+ for (i = 0; i < ARRAY_SIZE(gpio_button); i++) {
gb[i].gpio = get_gpio_by_name(gb[i].desc);
pr_debug("info[%2d]: name = %s, gpio = %d\n", i, gb[i].desc,
gb[i].gpio);
next prev parent reply other threads:[~2017-10-19 14:21 UTC|newest]
Thread overview: 51+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-10-01 19:30 [PATCH 00/18] use ARRAY_SIZE macro Jérémy Lefaure
2017-10-01 19:30 ` [PATCH 01/18] sound: use ARRAY_SIZE Jérémy Lefaure
2017-10-02 4:16 ` Joe Perches
2017-10-03 1:12 ` Jérémy Lefaure
2017-10-03 7:03 ` Takashi Iwai
2017-10-01 19:30 ` [PATCH 02/18] tracing/filter: " Jérémy Lefaure
2017-10-04 1:05 ` Steven Rostedt
2017-10-01 19:30 ` [PATCH 03/18] media: " Jérémy Lefaure
2017-10-02 10:34 ` Michael Ira Krufky
2017-10-01 19:30 ` [PATCH 04/18] IB/mlx5: Use ARRAY_SIZE Jérémy Lefaure
2017-10-02 4:38 ` Leon Romanovsky
2017-10-01 19:30 ` [PATCH 05/18] net: use ARRAY_SIZE Jérémy Lefaure
2017-10-02 13:07 ` Andy Shevchenko
2017-10-03 1:22 ` Jérémy Lefaure
2017-10-03 8:09 ` Andy Shevchenko
2017-10-02 13:46 ` Kalle Valo
2017-10-03 1:23 ` Jérémy Lefaure
2017-10-01 19:30 ` [PATCH 06/18] drm: " Jérémy Lefaure
2017-10-02 7:43 ` Jani Nikula
2017-10-02 8:27 ` Thierry Reding
2017-10-01 19:30 ` [PATCH 07/18] scsi: bfa: " Jérémy Lefaure
2017-10-01 19:30 ` [PATCH 08/18] ecryptfs: " Jérémy Lefaure
2017-10-14 1:31 ` Tyler Hicks
2017-10-01 19:30 ` [PATCH 09/18] nfsd: " Jérémy Lefaure
2017-10-02 11:03 ` Jeff Layton
2017-10-01 19:30 ` [PATCH 10/18] orangefs: " Jérémy Lefaure
2017-10-01 19:30 ` [PATCH 11/18] dm space map metadata: " Jérémy Lefaure
2017-10-01 19:30 ` [PATCH 12/18] x86: " Jérémy Lefaure
2017-10-19 14:18 ` tip-bot for Jérémy Lefaure [this message]
2017-10-01 19:30 ` [PATCH 13/18] tpm: " Jérémy Lefaure
2017-10-04 12:14 ` Jarkko Sakkinen
2017-10-10 20:30 ` Jérémy Lefaure
2017-10-11 11:48 ` Jarkko Sakkinen
2017-10-01 19:30 ` [PATCH 14/18] ipmi: " Jérémy Lefaure
2017-10-01 19:30 ` [PATCH 15/18] acpi: " Jérémy Lefaure
2017-10-02 12:27 ` Rafael J. Wysocki
2017-10-03 1:16 ` Jérémy Lefaure
2017-10-03 11:39 ` Rafael J. Wysocki
2017-10-03 12:34 ` [Devel] " Colin Ian King
2017-10-03 16:04 ` Rafael J. Wysocki
2017-10-03 16:38 ` Moore, Robert
2017-10-01 19:30 ` [PATCH 16/18] media: staging: atomisp: " Jérémy Lefaure
2017-10-01 19:30 ` [PATCH 17/18] staging: rtl8723bs: " Jérémy Lefaure
2017-10-01 19:30 ` [PATCH 18/18] staging: rtlwifi: " Jérémy Lefaure
2017-10-01 22:01 ` [PATCH 00/18] use ARRAY_SIZE macro Tobin C. Harding
2017-10-02 0:52 ` Jérémy Lefaure
2017-10-02 5:35 ` Greg KH
2017-10-02 19:22 ` J. Bruce Fields
2017-10-03 1:33 ` Jérémy Lefaure
2017-10-05 17:57 ` J. Bruce Fields
2017-10-02 16:37 ` Mauro Carvalho Chehab
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=tip-0cfe5b5fc0277463fa795dea312a3a2fd5e8bac2@git.kernel.org \
--to=tipbot@zytor.com \
--cc=hpa@zytor.com \
--cc=jeremy.lefaure@lse.epita.fr \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-tip-commits@vger.kernel.org \
--cc=luto@amacapital.net \
--cc=mingo@kernel.org \
--cc=mj@ucw.cz \
--cc=tglx@linutronix.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome