From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1754829AbdBPOe6 (ORCPT ); Thu, 16 Feb 2017 09:34:58 -0500 Received: from terminus.zytor.com ([65.50.211.136]:33702 "EHLO terminus.zytor.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1754504AbdBPOe4 (ORCPT ); Thu, 16 Feb 2017 09:34:56 -0500 Date: Thu, 16 Feb 2017 06:34:42 -0800 From: tip-bot for Jeremy Kerr Message-ID: Cc: jk@ozlabs.org, tglx@linutronix.de, mingo@kernel.org, hpa@zytor.com, linux-kernel@vger.kernel.org Reply-To: linux-kernel@vger.kernel.org, jk@ozlabs.org, mingo@kernel.org, tglx@linutronix.de, hpa@zytor.com In-Reply-To: <1487219049-4061-1-git-send-email-jk@ozlabs.org> References: <1487219049-4061-1-git-send-email-jk@ozlabs.org> To: linux-tip-commits@vger.kernel.org Subject: [tip:irq/core] genirq: Clarify logic calculating bogus irqreturn_t values Git-Commit-ID: 5d4bac9a5f4ef24b2482529bda6661a58e5b5b65 X-Mailer: tip-git-log-daemon Robot-ID: Robot-Unsubscribe: Contact to get blacklisted from these emails MIME-Version: 1.0 Content-Transfer-Encoding: 8bit Content-Type: text/plain; charset=UTF-8 Content-Disposition: inline Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Commit-ID: 5d4bac9a5f4ef24b2482529bda6661a58e5b5b65 Gitweb: http://git.kernel.org/tip/5d4bac9a5f4ef24b2482529bda6661a58e5b5b65 Author: Jeremy Kerr AuthorDate: Thu, 16 Feb 2017 12:24:09 +0800 Committer: Thomas Gleixner CommitDate: Thu, 16 Feb 2017 15:32:19 +0100 genirq: Clarify logic calculating bogus irqreturn_t values Although irqreturn_t is an enum, we treat it (and its enumeration constants) as a bitmask. However, bad_action_ret() uses a less-than operator to determine whether an irqreturn_t falls within allowable bit values, which means we need to know the signededness of an enum type to read the logic, which is implementation-dependent. This change explicitly uses an unsigned type for the comparison. We do this instead of changing to a bitwise test, as the latter compiles to increased instructions in this hot path. It looks like we get the correct behaviour currently (bad_action_ret(-1) returns 1), so this is purely a readability fix. Signed-off-by: Jeremy Kerr Link: http://lkml.kernel.org/r/1487219049-4061-1-git-send-email-jk@ozlabs.org Signed-off-by: Thomas Gleixner --- kernel/irq/spurious.c | 4 +++- 1 file changed, 3 insertions(+), 1 deletion(-) diff --git a/kernel/irq/spurious.c b/kernel/irq/spurious.c index 5707f97..061ba7e 100644 --- a/kernel/irq/spurious.c +++ b/kernel/irq/spurious.c @@ -175,7 +175,9 @@ out: static inline int bad_action_ret(irqreturn_t action_ret) { - if (likely(action_ret <= (IRQ_HANDLED | IRQ_WAKE_THREAD))) + unsigned int r = action_ret; + + if (likely(r <= (IRQ_HANDLED | IRQ_WAKE_THREAD))) return 0; return 1; }