From: tip-bot for Kees Cook <tipbot@zytor.com>
To: linux-tip-commits@vger.kernel.org
Cc: keescook@chromium.org, bhe@redhat.com, hjl.tools@gmail.com,
dvyukov@google.com, bp@suse.de, torvalds@linux-foundation.org,
bp@alien8.de, peterz@infradead.org, luto@amacapital.net,
jpoimboe@redhat.com, hpa@zytor.com, akpm@linux-foundation.org,
linux-kernel@vger.kernel.org, luto@kernel.org,
tglx@linutronix.de, aryabinin@virtuozzo.com, mingo@kernel.org,
brgerst@gmail.com, yinghai@kernel.org, dvlasenk@redhat.com
Subject: [tip:x86/boot] x86/KASLR: Clarify purpose of kaslr.c
Date: Tue, 19 Apr 2016 02:32:53 -0700 [thread overview]
Message-ID: <tip-7de828dfe607013546ece7ce25aa9839e8f93a66@git.kernel.org> (raw)
In-Reply-To: <1460997735-24785-6-git-send-email-keescook@chromium.org>
Commit-ID: 7de828dfe607013546ece7ce25aa9839e8f93a66
Gitweb: http://git.kernel.org/tip/7de828dfe607013546ece7ce25aa9839e8f93a66
Author: Kees Cook <keescook@chromium.org>
AuthorDate: Mon, 18 Apr 2016 09:42:14 -0700
Committer: Ingo Molnar <mingo@kernel.org>
CommitDate: Tue, 19 Apr 2016 10:30:51 +0200
x86/KASLR: Clarify purpose of kaslr.c
The name "choose_kernel_location" isn't specific enough, and doesn't
describe the primary thing it does: choosing a random location. This
patch renames it to "choose_random_location", and clarifies the what
routines are contained in the kaslr.c source file.
Suggested-by: Ingo Molnar <mingo@kernel.org>
Signed-off-by: Kees Cook <keescook@chromium.org>
Cc: Andrew Morton <akpm@linux-foundation.org>
Cc: Andrey Ryabinin <aryabinin@virtuozzo.com>
Cc: Andy Lutomirski <luto@amacapital.net>
Cc: Andy Lutomirski <luto@kernel.org>
Cc: Baoquan He <bhe@redhat.com>
Cc: Borislav Petkov <bp@alien8.de>
Cc: Borislav Petkov <bp@suse.de>
Cc: Brian Gerst <brgerst@gmail.com>
Cc: Denys Vlasenko <dvlasenk@redhat.com>
Cc: Dmitry Vyukov <dvyukov@google.com>
Cc: H. Peter Anvin <hpa@zytor.com>
Cc: H.J. Lu <hjl.tools@gmail.com>
Cc: Josh Poimboeuf <jpoimboe@redhat.com>
Cc: Linus Torvalds <torvalds@linux-foundation.org>
Cc: Peter Zijlstra <peterz@infradead.org>
Cc: Thomas Gleixner <tglx@linutronix.de>
Cc: Yinghai Lu <yinghai@kernel.org>
Link: http://lkml.kernel.org/r/1460997735-24785-6-git-send-email-keescook@chromium.org
Signed-off-by: Ingo Molnar <mingo@kernel.org>
---
arch/x86/boot/compressed/kaslr.c | 13 ++++++++++++-
arch/x86/boot/compressed/misc.c | 2 +-
arch/x86/boot/compressed/misc.h | 4 ++--
3 files changed, 15 insertions(+), 4 deletions(-)
diff --git a/arch/x86/boot/compressed/kaslr.c b/arch/x86/boot/compressed/kaslr.c
index a51ec84..9e03190 100644
--- a/arch/x86/boot/compressed/kaslr.c
+++ b/arch/x86/boot/compressed/kaslr.c
@@ -1,3 +1,14 @@
+/*
+ * kaslr.c
+ *
+ * This contains the routines needed to generate a reasonable level of
+ * entropy to choose a randomized kernel base address offset in support
+ * of Kernel Address Space Layout Randomization (KASLR). Additionally
+ * handles walking the physical memory maps (and tracking memory regions
+ * to avoid) in order to select a physical memory location that can
+ * contain the entire properly aligned running kernel image.
+ *
+ */
#include "misc.h"
#include <asm/msr.h>
@@ -295,7 +306,7 @@ static unsigned long find_random_addr(unsigned long minimum,
return slots_fetch_random();
}
-unsigned char *choose_kernel_location(unsigned char *input,
+unsigned char *choose_random_location(unsigned char *input,
unsigned long input_size,
unsigned char *output,
unsigned long output_size)
diff --git a/arch/x86/boot/compressed/misc.c b/arch/x86/boot/compressed/misc.c
index 0d69e80..ad8c01a 100644
--- a/arch/x86/boot/compressed/misc.c
+++ b/arch/x86/boot/compressed/misc.c
@@ -431,7 +431,7 @@ asmlinkage __visible void *extract_kernel(void *rmode, memptr heap,
* the entire decompressed kernel plus relocation table, or the
* entire decompressed kernel plus .bss and .brk sections.
*/
- output = choose_kernel_location(input_data, input_len, output,
+ output = choose_random_location(input_data, input_len, output,
output_len > run_size ? output_len
: run_size);
diff --git a/arch/x86/boot/compressed/misc.h b/arch/x86/boot/compressed/misc.h
index 1f750a51..9887e0d 100644
--- a/arch/x86/boot/compressed/misc.h
+++ b/arch/x86/boot/compressed/misc.h
@@ -67,7 +67,7 @@ int cmdline_find_option_bool(const char *option);
#if CONFIG_RANDOMIZE_BASE
/* kaslr.c */
-unsigned char *choose_kernel_location(unsigned char *input,
+unsigned char *choose_random_location(unsigned char *input,
unsigned long input_size,
unsigned char *output,
unsigned long output_size);
@@ -75,7 +75,7 @@ unsigned char *choose_kernel_location(unsigned char *input,
bool has_cpuflag(int flag);
#else
static inline
-unsigned char *choose_kernel_location(unsigned char *input,
+unsigned char *choose_random_location(unsigned char *input,
unsigned long input_size,
unsigned char *output,
unsigned long output_size)
next prev parent reply other threads:[~2016-04-19 9:34 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-04-18 16:42 [PATCH 0/6] x86, boot: clean up KASLR code Kees Cook
2016-04-18 16:42 ` [PATCH 1/6] x86, KASLR: rename aslr.c to kaslr.c Kees Cook
2016-04-19 9:31 ` [tip:x86/boot] x86/KASLR: Rename " tip-bot for Kees Cook
2016-04-18 16:42 ` [PATCH 2/6] x86, KASLR: Remove unneeded boot_params argument Kees Cook
2016-04-19 9:31 ` [tip:x86/boot] x86/KASLR: " tip-bot for Yinghai Lu
2016-04-18 16:42 ` [PATCH 3/6] x86, boot: Rename "real_mode" to "boot_params" Kees Cook
2016-04-19 9:32 ` [tip:x86/boot] x86/boot: " tip-bot for Kees Cook
2016-04-18 16:42 ` [PATCH 4/6] x86, boot: Clarify purpose of functions in misc.c Kees Cook
2016-04-19 9:32 ` [tip:x86/boot] x86/boot: " tip-bot for Kees Cook
2016-04-18 16:42 ` [PATCH 5/6] x86, KASLR: Clarify purpose of kaslr.c Kees Cook
2016-04-19 9:32 ` tip-bot for Kees Cook [this message]
2016-04-18 16:42 ` [PATCH 6/6] x86, KASLR: Rename "random" to "random_addr" Kees Cook
2016-04-19 9:33 ` [tip:x86/boot] x86/KASLR: " tip-bot for Kees Cook
2016-04-19 8:36 ` [PATCH 0/6] x86, boot: clean up KASLR code Ingo Molnar
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=tip-7de828dfe607013546ece7ce25aa9839e8f93a66@git.kernel.org \
--to=tipbot@zytor.com \
--cc=akpm@linux-foundation.org \
--cc=aryabinin@virtuozzo.com \
--cc=bhe@redhat.com \
--cc=bp@alien8.de \
--cc=bp@suse.de \
--cc=brgerst@gmail.com \
--cc=dvlasenk@redhat.com \
--cc=dvyukov@google.com \
--cc=hjl.tools@gmail.com \
--cc=hpa@zytor.com \
--cc=jpoimboe@redhat.com \
--cc=keescook@chromium.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-tip-commits@vger.kernel.org \
--cc=luto@amacapital.net \
--cc=luto@kernel.org \
--cc=mingo@kernel.org \
--cc=peterz@infradead.org \
--cc=tglx@linutronix.de \
--cc=torvalds@linux-foundation.org \
--cc=yinghai@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome