From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753751AbcDSJea (ORCPT ); Tue, 19 Apr 2016 05:34:30 -0400 Received: from terminus.zytor.com ([198.137.202.10]:56470 "EHLO terminus.zytor.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753726AbcDSJe2 (ORCPT ); Tue, 19 Apr 2016 05:34:28 -0400 Date: Tue, 19 Apr 2016 02:33:17 -0700 From: tip-bot for Kees Cook Message-ID: Cc: yinghai@kernel.org, aryabinin@virtuozzo.com, bhe@redhat.com, hjl.tools@gmail.com, dvyukov@google.com, dvlasenk@redhat.com, brgerst@gmail.com, luto@kernel.org, bp@alien8.de, peterz@infradead.org, mingo@kernel.org, hpa@zytor.com, bp@suse.de, jpoimboe@redhat.com, tglx@linutronix.de, luto@amacapital.net, torvalds@linux-foundation.org, linux-kernel@vger.kernel.org, keescook@chromium.org, akpm@linux-foundation.org Reply-To: brgerst@gmail.com, bp@alien8.de, luto@kernel.org, hjl.tools@gmail.com, dvyukov@google.com, dvlasenk@redhat.com, bhe@redhat.com, aryabinin@virtuozzo.com, yinghai@kernel.org, linux-kernel@vger.kernel.org, torvalds@linux-foundation.org, akpm@linux-foundation.org, keescook@chromium.org, tglx@linutronix.de, luto@amacapital.net, mingo@kernel.org, jpoimboe@redhat.com, bp@suse.de, hpa@zytor.com, peterz@infradead.org In-Reply-To: <1460997735-24785-7-git-send-email-keescook@chromium.org> References: <1460997735-24785-7-git-send-email-keescook@chromium.org> To: linux-tip-commits@vger.kernel.org Subject: [tip:x86/boot] x86/KASLR: Rename "random" to "random_addr" Git-Commit-ID: 9016875df408fc5db6a94a3c5f5f5503c916cf81 X-Mailer: tip-git-log-daemon Robot-ID: Robot-Unsubscribe: Contact to get blacklisted from these emails MIME-Version: 1.0 Content-Transfer-Encoding: 8bit Content-Type: text/plain; charset=UTF-8 Content-Disposition: inline Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Commit-ID: 9016875df408fc5db6a94a3c5f5f5503c916cf81 Gitweb: http://git.kernel.org/tip/9016875df408fc5db6a94a3c5f5f5503c916cf81 Author: Kees Cook AuthorDate: Mon, 18 Apr 2016 09:42:15 -0700 Committer: Ingo Molnar CommitDate: Tue, 19 Apr 2016 10:30:51 +0200 x86/KASLR: Rename "random" to "random_addr" The variable "random" is also the name of a libc function. It's better coding style to avoid overloading such things, so rename it to the more accurate "random_addr". Suggested-by: Ingo Molnar Signed-off-by: Kees Cook Cc: Andrew Morton Cc: Andrey Ryabinin Cc: Andy Lutomirski Cc: Andy Lutomirski Cc: Baoquan He Cc: Borislav Petkov Cc: Borislav Petkov Cc: Brian Gerst Cc: Denys Vlasenko Cc: Dmitry Vyukov Cc: H. Peter Anvin Cc: H.J. Lu Cc: Josh Poimboeuf Cc: Linus Torvalds Cc: Peter Zijlstra Cc: Thomas Gleixner Cc: Yinghai Lu Link: http://lkml.kernel.org/r/1460997735-24785-7-git-send-email-keescook@chromium.org Signed-off-by: Ingo Molnar --- arch/x86/boot/compressed/kaslr.c | 10 +++++----- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/arch/x86/boot/compressed/kaslr.c b/arch/x86/boot/compressed/kaslr.c index 9e03190..9c29e78 100644 --- a/arch/x86/boot/compressed/kaslr.c +++ b/arch/x86/boot/compressed/kaslr.c @@ -312,7 +312,7 @@ unsigned char *choose_random_location(unsigned char *input, unsigned long output_size) { unsigned long choice = (unsigned long)output; - unsigned long random; + unsigned long random_addr; #ifdef CONFIG_HIBERNATION if (!cmdline_find_option_bool("kaslr")) { @@ -333,17 +333,17 @@ unsigned char *choose_random_location(unsigned char *input, (unsigned long)output, output_size); /* Walk e820 and find a random address. */ - random = find_random_addr(choice, output_size); - if (!random) { + random_addr = find_random_addr(choice, output_size); + if (!random_addr) { debug_putstr("KASLR could not find suitable E820 region...\n"); goto out; } /* Always enforce the minimum. */ - if (random < choice) + if (random_addr < choice) goto out; - choice = random; + choice = random_addr; out: return (unsigned char *)choice; }