From: tip-bot for Mukesh Ojha <tipbot@zytor.com>
To: linux-tip-commits@vger.kernel.org
Cc: mojha@codeaurora.org, hpa@zytor.com, malat@debian.org,
tglx@linutronix.de, brendan.jackman@arm.com,
jiangshanlai@gmail.com, peterz@infradead.org, mingo@kernel.org,
linux-kernel@vger.kernel.org
Subject: [tip:smp/hotplug] cpu/hotplug: Clarify CPU hotplug step name for timers
Date: Mon, 30 Jul 2018 12:33:53 -0700 [thread overview]
Message-ID: <tip-d018031f562b9c2eff038969ab1955a370c52d8f@git.kernel.org> (raw)
In-Reply-To: <1532443668-26810-1-git-send-email-mojha@codeaurora.org>
Commit-ID: d018031f562b9c2eff038969ab1955a370c52d8f
Gitweb: https://git.kernel.org/tip/d018031f562b9c2eff038969ab1955a370c52d8f
Author: Mukesh Ojha <mojha@codeaurora.org>
AuthorDate: Tue, 24 Jul 2018 20:17:48 +0530
Committer: Thomas Gleixner <tglx@linutronix.de>
CommitDate: Mon, 30 Jul 2018 21:30:52 +0200
cpu/hotplug: Clarify CPU hotplug step name for timers
After commit 249d4a9b3246 ("timers: Reinitialize per cpu bases on hotplug")
i.e. the introduction of state CPUHP_TIMERS_PREPARE instead of
CPUHP_TIMERS_DEAD the step name "timers:dead" is not longer accurate.
Rename it to "timers:prepare".
[ tglx: Massaged changelog ]
Signed-off-by: Mukesh Ojha <mojha@codeaurora.org>
Signed-off-by: Thomas Gleixner <tglx@linutronix.de>
Cc: gkohli@codeaurora.org
Cc: neeraju@codeaurora.org
Cc: Peter Zijlstra <peterz@infradead.org>
Cc: Lai Jiangshan <jiangshanlai@gmail.com>
Cc: Brendan Jackman <brendan.jackman@arm.com>
Cc: Mathieu Malaterre <malat@debian.org>
Link: https://lkml.kernel.org/r/1532443668-26810-1-git-send-email-mojha@codeaurora.org
---
kernel/cpu.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/kernel/cpu.c b/kernel/cpu.c
index 0db8938fbb23..8e6606ac3d72 100644
--- a/kernel/cpu.c
+++ b/kernel/cpu.c
@@ -1274,7 +1274,7 @@ static struct cpuhp_step cpuhp_hp_states[] = {
* otherwise a RCU stall occurs.
*/
[CPUHP_TIMERS_PREPARE] = {
- .name = "timers:dead",
+ .name = "timers:prepare",
.startup.single = timers_prepare_cpu,
.teardown.single = timers_dead_cpu,
},
prev parent reply other threads:[~2018-07-30 19:34 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-07-24 14:47 [PATCH v2] cpu/hotplug: Fix cpuhp_step " Mukesh Ojha
2018-07-26 11:52 ` Mukesh Ojha
2018-07-30 12:19 ` Thomas Gleixner
2018-07-30 13:33 ` Mukesh Ojha
2018-07-30 19:33 ` tip-bot for Mukesh Ojha [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=tip-d018031f562b9c2eff038969ab1955a370c52d8f@git.kernel.org \
--to=tipbot@zytor.com \
--cc=brendan.jackman@arm.com \
--cc=hpa@zytor.com \
--cc=jiangshanlai@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-tip-commits@vger.kernel.org \
--cc=malat@debian.org \
--cc=mingo@kernel.org \
--cc=mojha@codeaurora.org \
--cc=peterz@infradead.org \
--cc=tglx@linutronix.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome