From: tip-bot for David Rientjes <tipbot@zytor.com>
To: linux-tip-commits@vger.kernel.org
Cc: linux-kernel@vger.kernel.org, hpa@zytor.com, mingo@kernel.org,
tglx@linutronix.de, rientjes@google.com
Subject: [tip:x86/apic] x86/apic: Only use default_wait_for_init_deassert( )
Date: Mon, 10 Feb 2014 05:31:13 -0800 [thread overview]
Message-ID: <tip-d3c63ae1e2e35e4250390c079dc3fb7291347f5c@git.kernel.org> (raw)
In-Reply-To: <alpine.DEB.2.02.1402042353030.7839@chino.kir.corp.google.com>
Commit-ID: d3c63ae1e2e35e4250390c079dc3fb7291347f5c
Gitweb: http://git.kernel.org/tip/d3c63ae1e2e35e4250390c079dc3fb7291347f5c
Author: David Rientjes <rientjes@google.com>
AuthorDate: Tue, 4 Feb 2014 23:54:58 -0800
Committer: Ingo Molnar <mingo@kernel.org>
CommitDate: Sun, 9 Feb 2014 15:15:07 +0100
x86/apic: Only use default_wait_for_init_deassert()
es7000_wait_for_init_deassert() is functionally equivalent to
default_wait_for_init_deassert(), so remove the duplicate code
and use only a single function.
Signed-off-by: David Rientjes <rientjes@google.com>
Reviewed-by: Thomas Gleixner <tglx@linutronix.de>
Link: http://lkml.kernel.org/r/alpine.DEB.2.02.1402042353030.7839@chino.kir.corp.google.com
Signed-off-by: Ingo Molnar <mingo@kernel.org>
---
arch/x86/include/asm/apic.h | 1 -
arch/x86/kernel/apic/es7000_32.c | 8 +-------
2 files changed, 1 insertion(+), 8 deletions(-)
diff --git a/arch/x86/include/asm/apic.h b/arch/x86/include/asm/apic.h
index 1d2091a..2ef7013 100644
--- a/arch/x86/include/asm/apic.h
+++ b/arch/x86/include/asm/apic.h
@@ -521,7 +521,6 @@ static inline void default_wait_for_init_deassert(atomic_t *deassert)
{
while (!atomic_read(deassert))
cpu_relax();
- return;
}
extern void generic_bigsmp_probe(void);
diff --git a/arch/x86/kernel/apic/es7000_32.c b/arch/x86/kernel/apic/es7000_32.c
index c552247..d03d57e 100644
--- a/arch/x86/kernel/apic/es7000_32.c
+++ b/arch/x86/kernel/apic/es7000_32.c
@@ -394,12 +394,6 @@ static void es7000_enable_apic_mode(void)
WARN(1, "Command failed, status = %x\n", mip_status);
}
-static void es7000_wait_for_init_deassert(atomic_t *deassert)
-{
- while (!atomic_read(deassert))
- cpu_relax();
-}
-
static unsigned int es7000_get_apic_id(unsigned long x)
{
return (x >> 24) & 0xFF;
@@ -722,7 +716,7 @@ static struct apic __refdata apic_es7000 = {
.trampoline_phys_low = 0x467,
.trampoline_phys_high = 0x469,
- .wait_for_init_deassert = es7000_wait_for_init_deassert,
+ .wait_for_init_deassert = default_wait_for_init_deassert,
/* Nothing to do for most platforms, since cleared by the INIT cycle: */
.smp_callin_clear_local_apic = NULL,
prev parent reply other threads:[~2014-02-10 13:31 UTC|newest]
Thread overview: 26+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-02-05 7:54 [patch 1/4] x86, apic: Only use default_wait_for_init_deassert David Rientjes
2014-02-05 7:55 ` [patch 2/4] x86, apic: Switch wait_for_init_deassert to bool David Rientjes
2014-02-05 20:29 ` Thomas Gleixner
2014-02-10 13:31 ` [tip:x86/apic] x86/apic: Switch wait_for_init_deassert() to a bool flag tip-bot for David Rientjes
2014-02-05 7:55 ` [patch 3/4] x86, apic: Remove unused function prototypes David Rientjes
2014-02-05 20:31 ` Thomas Gleixner
2014-02-10 13:31 ` [tip:x86/apic] x86/apic: " tip-bot for David Rientjes
2014-02-05 7:55 ` [patch 4/4] x86, apic: Always define nox2apic and define it as initdata David Rientjes
2014-02-05 20:31 ` Thomas Gleixner
2014-02-10 13:31 ` [tip:x86/apic] x86/apic: " tip-bot for David Rientjes
2014-02-06 19:59 ` [patch 1/4] x86, apic: Only use default_wait_for_init_deassert Andi Kleen
2014-02-06 22:31 ` David Rientjes
2014-02-06 22:39 ` H. Peter Anvin
2014-02-06 22:52 ` Thomas Gleixner
2014-02-06 22:57 ` H. Peter Anvin
2014-02-06 22:58 ` Dave Hansen
2014-02-12 2:53 ` [GIT PULL] x86, apic: Remove support for Summit and ES7000 David Rientjes
2014-02-12 2:53 ` [patch 1/2] x86, apic: Remove support for ia32-based Unisys ES7000 David Rientjes
2014-02-12 2:53 ` [patch 2/2] x86, apic: Remove support for IBM Summit/EXA chipset David Rientjes
2014-02-12 4:29 ` [GIT PULL] x86, apic: Remove support for Summit and ES7000 H. Peter Anvin
2014-02-12 5:20 ` David Rientjes
2014-02-12 7:06 ` Ingo Molnar
2014-02-12 8:39 ` H. Peter Anvin
2014-02-12 12:50 ` Andi Kleen
2014-02-12 15:17 ` H. Peter Anvin
2014-02-10 13:31 ` tip-bot for David Rientjes [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=tip-d3c63ae1e2e35e4250390c079dc3fb7291347f5c@git.kernel.org \
--to=tipbot@zytor.com \
--cc=hpa@zytor.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-tip-commits@vger.kernel.org \
--cc=mingo@kernel.org \
--cc=rientjes@google.com \
--cc=tglx@linutronix.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome