From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1757235Ab0CaMHB (ORCPT ); Wed, 31 Mar 2010 08:07:01 -0400 Received: from cam-admin0.cambridge.arm.com ([217.140.96.50]:38142 "EHLO cam-admin0.cambridge.arm.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1756535Ab0CaMG7 (ORCPT ); Wed, 31 Mar 2010 08:06:59 -0400 From: Catalin Marinas To: Sachin Pandhare Cc: Linux Kernel Mailing List Subject: Re: kmemleak_scan_area References: Date: Wed, 31 Mar 2010 13:06:49 +0100 In-Reply-To: (Sachin Pandhare's message of "Wed, 31 Mar 2010 15:30:11 +0530") Message-ID: User-Agent: Gnus/5.13 (Gnus v5.13) Emacs/23.1 (gnu/linux) MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii X-OriginalArrivalTime: 31 Mar 2010 12:06:54.0494 (UTC) FILETIME=[A77563E0:01CAD0CA] Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Sachin Pandhare wrote: > In kmemleak.c file "kmemleak_scan_area" is appearing as a structure as > well as a function. > e.g.: > - struct kmemleak_scan_area { > - void __ref kmemleak_scan_area(const void *ptr, size_t size, gfp_t gfp) > > Do you think it is a good to have it like that? Does it cause any problems? I think C has different namespaces for types and functions, so they should not collide. I agree that from a readability perspective, it would be better if they are named differently (like kmemleak_scan_area_node :)). -- Catalin