From: Jeff Moyer <jmoyer@redhat.com>
To: Ross Zwisler <ross.zwisler@linux.intel.com>
Cc: Dan Williams <dan.j.williams@intel.com>,
axboe@fb.com, Jens Axboe <axboe@kernel.dk>,
jack@suse.cz, linux-nvdimm@ml01.01.org, david@fromorbit.com,
linux-kernel@vger.kernel.org, Jan Kara <jack@suse.com>,
hch@lst.de
Subject: Re: [PATCH v3 03/15] block, dax: fix lifetime of in-kernel dax mappings with dax_map_atomic()
Date: Tue, 03 Nov 2015 14:09:36 -0500 [thread overview]
Message-ID: <x494mh23nnz.fsf@segfault.boston.devel.redhat.com> (raw)
In-Reply-To: <20151103190140.GB23366@linux.intel.com> (Ross Zwisler's message of "Tue, 3 Nov 2015 12:01:40 -0700")
Ross Zwisler <ross.zwisler@linux.intel.com> writes:
> On Sun, Nov 01, 2015 at 11:29:58PM -0500, Dan Williams wrote:
>> The DAX implementation needs to protect new calls to ->direct_access()
>> and usage of its return value against unbind of the underlying block
>> device. Use blk_queue_enter()/blk_queue_exit() to either prevent
>> blk_cleanup_queue() from proceeding, or fail the dax_map_atomic() if the
>> request_queue is being torn down.
>>
>> Cc: Jan Kara <jack@suse.com>
>> Cc: Jens Axboe <axboe@kernel.dk>
>> Cc: Christoph Hellwig <hch@lst.de>
>> Cc: Dave Chinner <david@fromorbit.com>
>> Cc: Ross Zwisler <ross.zwisler@linux.intel.com>
>> Reviewed-by: Jeff Moyer <jmoyer@redhat.com>
>> Signed-off-by: Dan Williams <dan.j.williams@intel.com>
>> ---
> <>
>> @@ -42,9 +76,9 @@ int dax_clear_blocks(struct inode *inode, sector_t block, long size)
>> long count, sz;
>>
>> sz = min_t(long, size, SZ_1M);
>> - count = bdev_direct_access(bdev, sector, &addr, &pfn, sz);
>> - if (count < 0)
>> - return count;
>> + addr = __dax_map_atomic(bdev, sector, size, &pfn, &count);
>
> I think you can use dax_map_atomic() here instead, allowing you to avoid
> having a local pfn variable that otherwise goes unused.
But __dax_map_atomic doesn't return the count, and I believe that is
what's used.
>> @@ -138,21 +176,27 @@ static ssize_t dax_io(struct inode *inode, struct iov_iter *iter,
>> bh->b_size -= done;
>> }
>>
>> - hole = iov_iter_rw(iter) != WRITE && !buffer_written(bh);
>> + hole = rw == READ && !buffer_written(bh);
>> if (hole) {
>> addr = NULL;
>> size = bh->b_size - first;
>> } else {
>> - retval = dax_get_addr(bh, &addr, blkbits);
>> - if (retval < 0)
>> + dax_unmap_atomic(bdev, kmap);
>> + kmap = __dax_map_atomic(bdev,
>> + to_sector(bh, inode),
>> + bh->b_size, &pfn, &map_len);
>
> Same as above, you can use dax_map_atomic() here instead and nix the pfn variable.
same as above. ;-)
>> @@ -305,11 +353,10 @@ static int dax_insert_mapping(struct inode *inode, struct buffer_head *bh,
>> goto out;
>> }
>>
>> - error = bdev_direct_access(bh->b_bdev, sector, &addr, &pfn, bh->b_size);
>> - if (error < 0)
>> - goto out;
>> - if (error < PAGE_SIZE) {
>> - error = -EIO;
>> + addr = __dax_map_atomic(bdev, to_sector(bh, inode), bh->b_size,
>> + &pfn, NULL);
>> + if (IS_ERR(addr)) {
>> + error = PTR_ERR(addr);
>
> Just a note that we lost the check for bdev_direct_access() returning less
> than PAGE_SIZE. Are we sure this can't happen and that it's safe to remove
> the check?
Yes, it's safe, I checked during my review. This page size assumption
is present throughout the file, and makes reviewing it very frustrating
for the uninitiated. I think that's worth a follow-on cleanup patch.
Cheers,
Jeff
>> @@ -609,15 +655,20 @@ int __dax_pmd_fault(struct vm_area_struct *vma, unsigned long address,
>> result = VM_FAULT_NOPAGE;
>> spin_unlock(ptl);
>> } else {
>> - sector = bh.b_blocknr << (blkbits - 9);
>> - length = bdev_direct_access(bh.b_bdev, sector, &kaddr, &pfn,
>> - bh.b_size);
>> - if (length < 0) {
>> + long length;
>> + unsigned long pfn;
>> + void __pmem *kaddr = __dax_map_atomic(bdev,
>> + to_sector(&bh, inode), HPAGE_SIZE, &pfn,
>> + &length);
>
> Let's use PMD_SIZE instead of HPAGE_SIZE to be consistent with the rest of the
> DAX code.
>
>> +
>> + if (IS_ERR(kaddr)) {
>> result = VM_FAULT_SIGBUS;
>> goto out;
>> }
>> - if ((length < PMD_SIZE) || (pfn & PG_PMD_COLOUR))
>> + if ((length < PMD_SIZE) || (pfn & PG_PMD_COLOUR)) {
>> + dax_unmap_atomic(bdev, kaddr);
>> goto fallback;
>> + }
>>
>> if (buffer_unwritten(&bh) || buffer_new(&bh)) {
>> clear_pmem(kaddr, HPAGE_SIZE);
>
> Ditto, let's use PMD_SIZE for consistency (I realize this was changed ealier
> in the series).
next prev parent reply other threads:[~2015-11-03 19:09 UTC|newest]
Thread overview: 48+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-11-02 4:29 [PATCH v3 00/15] block, dax updates for 4.4 Dan Williams
2015-11-02 4:29 ` [PATCH v3 01/15] pmem, dax: clean up clear_pmem() Dan Williams
2015-11-02 4:29 ` [PATCH v3 02/15] dax: increase granularity of dax_clear_blocks() operations Dan Williams
2015-11-03 0:51 ` Dave Chinner
2015-11-03 3:27 ` Dan Williams
2015-11-03 4:48 ` Dave Chinner
2015-11-03 5:31 ` Dan Williams
2015-11-03 5:52 ` Dave Chinner
2015-11-03 7:24 ` Dan Williams
2015-11-03 16:21 ` Jan Kara
2015-11-03 17:57 ` Ross Zwisler
2015-11-03 20:59 ` Dave Chinner
2015-11-02 4:29 ` [PATCH v3 03/15] block, dax: fix lifetime of in-kernel dax mappings with dax_map_atomic() Dan Williams
2015-11-03 19:01 ` Ross Zwisler
2015-11-03 19:09 ` Jeff Moyer [this message]
2015-11-03 22:50 ` Dan Williams
2016-01-18 10:42 ` Geert Uytterhoeven
2015-11-02 4:30 ` [PATCH v3 04/15] libnvdimm, pmem: move request_queue allocation earlier in probe Dan Williams
2015-11-03 19:15 ` Ross Zwisler
2015-11-02 4:30 ` [PATCH v3 05/15] libnvdimm, pmem: fix size trim in pmem_direct_access() Dan Williams
2015-11-03 19:32 ` Ross Zwisler
2015-11-03 21:39 ` Dan Williams
2015-11-02 4:30 ` [PATCH v3 06/15] um: kill pfn_t Dan Williams
2015-11-02 4:30 ` [PATCH v3 07/15] kvm: rename pfn_t to kvm_pfn_t Dan Williams
2015-11-02 4:30 ` [PATCH v3 08/15] mm, dax, pmem: introduce pfn_t Dan Williams
2015-11-02 16:30 ` Joe Perches
2015-11-02 4:30 ` [PATCH v3 09/15] block: notify queue death confirmation Dan Williams
2015-11-02 4:30 ` [PATCH v3 10/15] dax, pmem: introduce zone_device_revoke() and devm_memunmap_pages() Dan Williams
2015-11-02 4:30 ` [PATCH v3 11/15] block: introduce bdev_file_inode() Dan Williams
2015-11-02 4:30 ` [PATCH v3 12/15] block: enable dax for raw block devices Dan Williams
2015-11-02 4:30 ` [PATCH v3 13/15] block, dax: make dax mappings opt-in by default Dan Williams
2015-11-03 0:32 ` Dave Chinner
2015-11-03 7:35 ` Dan Williams
2015-11-03 20:20 ` Dave Chinner
2015-11-03 23:04 ` Dan Williams
2015-11-04 19:23 ` Dan Williams
2015-11-02 4:30 ` [PATCH v3 14/15] dax: dirty extent notification Dan Williams
2015-11-03 1:16 ` Dave Chinner
2015-11-03 4:56 ` Dan Williams
2015-11-03 5:40 ` Dave Chinner
2015-11-03 7:20 ` Dan Williams
2015-11-03 20:51 ` Dave Chinner
2015-11-03 21:19 ` Dan Williams
2015-11-03 21:37 ` Ross Zwisler
2015-11-03 21:43 ` Dan Williams
2015-11-03 21:18 ` Ross Zwisler
2015-11-03 21:34 ` Dan Williams
2015-11-02 4:31 ` [PATCH v3 15/15] pmem: blkdev_issue_flush support Dan Williams
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=x494mh23nnz.fsf@segfault.boston.devel.redhat.com \
--to=jmoyer@redhat.com \
--cc=axboe@fb.com \
--cc=axboe@kernel.dk \
--cc=dan.j.williams@intel.com \
--cc=david@fromorbit.com \
--cc=hch@lst.de \
--cc=jack@suse.com \
--cc=jack@suse.cz \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-nvdimm@ml01.01.org \
--cc=ross.zwisler@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®