From: Michal Nazarewicz <mina86@mina86.com>
To: David Cohen <david.a.cohen@linux.intel.com>
Cc: balbi@ti.com, gregkh@linuxfoundation.org,
stern@rowland.harvard.edu, linux-usb@vger.kernel.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH v5 2/5] usb: gadget: add quirk_ep_out_aligned_size field to struct usb_gadget
Date: Tue, 12 Nov 2013 13:54:28 +0100 [thread overview]
Message-ID: <xa1t1u2ln5kr.fsf@mina86.com> (raw)
In-Reply-To: <5281706F.5050507@linux.intel.com>
[-- Attachment #1: Type: text/plain, Size: 1076 bytes --]
On Tue, Nov 12 2013, David Cohen wrote:
> On 11/11/2013 03:55 PM, Michal Nazarewicz wrote:
>> Come to think of it, perhaps even better helper would be:
>>
>> static inline size_t usb_ep_align_maybe(
>> struct usb_gadget *gadget, struct usb_ep *ep, size_t len) {
>> return gadget->quir_ep_out_aligned_size ?
>> round_up(len, (size_t)ep->desc->wMaxPacketSize) : len;
>> }
>
> The CPU time to check unsigned:1 and possibly jump is about the same as
> round_up() itself. For readability matters, we can round_up() directly.
I was proposing to have this function and than not have functions check
for the flag. I.e. instead of
if (gadget->quirk_ep_out_aligned_size)
len = usb_ep_align_maxpacketsize(ep, len);
the code would just be:
len = usb_ep_align_maybe(gadget, ep, len);
--
Best regards, _ _
.o. | Liege of Serenely Enlightened Majesty of o' \,=./ `o
..o | Computer Science, Michał “mina86” Nazarewicz (o o)
ooo +--<mpn@google.com>--<xmpp:mina86@jabber.org>--ooO--(_)--Ooo--
[-- Attachment #2.1: Type: text/plain, Size: 0 bytes --]
[-- Attachment #2.2: signature.asc --]
[-- Type: application/pgp-signature, Size: 835 bytes --]
next prev parent reply other threads:[~2013-11-12 12:54 UTC|newest]
Thread overview: 21+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-11-11 20:16 [PATCH v5 0/5] add gadget quirk to adapt f_fs for DWC3 David Cohen
2013-11-11 20:16 ` [PATCH v5 1/5] usb: gadget: move bitflags to the end of usb_gadget struct David Cohen
2013-11-11 23:52 ` Michal Nazarewicz
2013-11-11 20:16 ` [PATCH v5 2/5] usb: gadget: add quirk_ep_out_aligned_size field to struct usb_gadget David Cohen
2013-11-11 23:55 ` Michal Nazarewicz
2013-11-12 0:03 ` David Cohen
2013-11-12 12:54 ` Michal Nazarewicz [this message]
2013-12-06 20:13 ` Felipe Balbi
2013-12-06 20:14 ` David Cohen
2013-11-11 20:16 ` [PATCH v5 3/5] usb: gadget: f_fs: remove loop from I/O function David Cohen
2013-11-11 23:21 ` David Cohen
2013-11-11 23:57 ` [PATCHv5.1 " Michal Nazarewicz
2013-12-06 20:18 ` Felipe Balbi
2013-11-11 20:16 ` [PATCH v5 4/5] usb: f_fs: check quirk to pad epout buf size when not aligned to maxpacketsize David Cohen
2013-11-11 23:58 ` [PATCHv5.1 4/5] " Michal Nazarewicz
2013-11-12 0:12 ` David Cohen
2013-11-12 12:59 ` Michal Nazarewicz
2013-11-12 18:26 ` David Cohen
2013-12-06 20:19 ` Felipe Balbi
2013-11-11 20:16 ` [PATCH v5 5/5] usb: dwc3: set gadget's quirk ep_out_align_size David Cohen
2013-12-06 20:19 ` Felipe Balbi
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=xa1t1u2ln5kr.fsf@mina86.com \
--to=mina86@mina86.com \
--cc=balbi@ti.com \
--cc=david.a.cohen@linux.intel.com \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=stern@rowland.harvard.edu \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome