On Wed, Nov 28 2012, Sebastian Andrzej Siewior wrote: > - > /functions/acm-function/ > > instead of > > /functions/function1/ > +name > with attribute file named "name" which contains the name of the > function (i.e. acm). My point is to keep "name" in the directory name > instead having an extra attribute. Right. But as I've suggested: mkdir functions/ mkdir functions// which IMO is easier to handle in kernel (no parsing) and looks nicer in user space. -- Best regards, _ _ .o. | Liege of Serenely Enlightened Majesty of o' \,=./ `o ..o | Computer Science, Michał “mina86” Nazarewicz (o o) ooo +------------------ooO--(_)--Ooo--