From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1757299Ab0CaMKt (ORCPT ); Wed, 31 Mar 2010 08:10:49 -0400 Received: from mail-bw0-f209.google.com ([209.85.218.209]:41155 "EHLO mail-bw0-f209.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1757037Ab0CaMKs (ORCPT ); Wed, 31 Mar 2010 08:10:48 -0400 DomainKey-Signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:from:date:message-id:subject:to :cc:content-type; b=pGD2jHTGuVrX5mTuxqBNS3nSUC1iX/Vet7Aq0c1/YJWi8fldvO+n9J3bd+B1W4WWZI uIljNgHhDXjoyqRfeLic1t0U7yRuUpwCR0tjN9m31i8/G68gHQbCNC41lVR9k3HfHP31 w0xb/Al3RMRjkFo9hyIzKGe5LzwnYSZL5yX0M= MIME-Version: 1.0 In-Reply-To: References: From: Sachin Pandhare Date: Wed, 31 Mar 2010 17:40:25 +0530 Message-ID: Subject: Re: kmemleak_scan_area To: Catalin Marinas Cc: Linux Kernel Mailing List Content-Type: text/plain; charset=ISO-8859-1 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed, Mar 31, 2010 at 5:36 PM, Catalin Marinas wrote: > Sachin Pandhare wrote: >> In kmemleak.c file "kmemleak_scan_area" is appearing as a structure as >> well as a function. >> e.g.: >> - struct kmemleak_scan_area { >> - void __ref kmemleak_scan_area(const void *ptr, size_t size, gfp_t gfp) >> >> Do you think it is a good to have it like that? > > Does it cause any problems? I think C has different namespaces for types > and functions, so they should not collide. I agree that from a > readability perspective, it would be better if they are named > differently (like kmemleak_scan_area_node :)). It has not caused any problem. Thanks, > > -- > Catalin