mirror of https://lore.kernel.org/linux-amlogic/
 help / color / mirror / Atom feed
* [PATCH v1] ARM: dts: meson: drop iio-hwmon in favour of generic-adc-thermal
@ 2025-11-08 21:15 Martin Blumenstingl
  2026-01-06  9:07 ` Martin Blumenstingl
  2026-01-07 14:02 ` Neil Armstrong
  0 siblings, 2 replies; 3+ messages in thread
From: Martin Blumenstingl @ 2025-11-08 21:15 UTC (permalink / raw)
  To: linux-amlogic
  Cc: linux-arm-kernel, linux-kernel, devicetree, neil.armstrong,
	Martin Blumenstingl

Commit 85b21fdec906e ("thermal/drivers/generic-adc: Register thermal
zones as hwmon sensors") made "generic-adc-thermal" also register hwmon
attributes. That means we now have the temperature sensor shown twice:
- once from iio-hwmon
- and another time from generic-adc-thermal

We need the latter for SoC temperature control, so simply drop the
former so userspace doesn't see duplicate sensors. Also
generic-adc-thermal provides a better name to userspace
("soc_thermal-virtual-0") than iio_hwmon.

Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com>
---
 arch/arm/boot/dts/amlogic/meson.dtsi | 5 -----
 1 file changed, 5 deletions(-)

diff --git a/arch/arm/boot/dts/amlogic/meson.dtsi b/arch/arm/boot/dts/amlogic/meson.dtsi
index 28ec2c821cdc..6792377b2841 100644
--- a/arch/arm/boot/dts/amlogic/meson.dtsi
+++ b/arch/arm/boot/dts/amlogic/meson.dtsi
@@ -12,11 +12,6 @@ / {
 	#size-cells = <1>;
 	interrupt-parent = <&gic>;
 
-	iio-hwmon {
-		compatible = "iio-hwmon";
-		io-channels = <&saradc 8>;
-	};
-
 	soc {
 		compatible = "simple-bus";
 		#address-cells = <1>;
-- 
2.51.2


_______________________________________________
linux-amlogic mailing list
linux-amlogic@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-amlogic

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH v1] ARM: dts: meson: drop iio-hwmon in favour of generic-adc-thermal
  2025-11-08 21:15 [PATCH v1] ARM: dts: meson: drop iio-hwmon in favour of generic-adc-thermal Martin Blumenstingl
@ 2026-01-06  9:07 ` Martin Blumenstingl
  2026-01-07 14:02 ` Neil Armstrong
  1 sibling, 0 replies; 3+ messages in thread
From: Martin Blumenstingl @ 2026-01-06  9:07 UTC (permalink / raw)
  To: linux-amlogic, neil.armstrong; +Cc: linux-arm-kernel, linux-kernel, devicetree

Hi Neil,

On Sat, Nov 8, 2025 at 10:15 PM Martin Blumenstingl
<martin.blumenstingl@googlemail.com> wrote:
>
> Commit 85b21fdec906e ("thermal/drivers/generic-adc: Register thermal
> zones as hwmon sensors") made "generic-adc-thermal" also register hwmon
> attributes. That means we now have the temperature sensor shown twice:
> - once from iio-hwmon
> - and another time from generic-adc-thermal
>
> We need the latter for SoC temperature control, so simply drop the
> former so userspace doesn't see duplicate sensors. Also
> generic-adc-thermal provides a better name to userspace
> ("soc_thermal-virtual-0") than iio_hwmon.
>
> Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com>
gentle ping on this

_______________________________________________
linux-amlogic mailing list
linux-amlogic@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-amlogic

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH v1] ARM: dts: meson: drop iio-hwmon in favour of generic-adc-thermal
  2025-11-08 21:15 [PATCH v1] ARM: dts: meson: drop iio-hwmon in favour of generic-adc-thermal Martin Blumenstingl
  2026-01-06  9:07 ` Martin Blumenstingl
@ 2026-01-07 14:02 ` Neil Armstrong
  1 sibling, 0 replies; 3+ messages in thread
From: Neil Armstrong @ 2026-01-07 14:02 UTC (permalink / raw)
  To: linux-amlogic, Martin Blumenstingl
  Cc: linux-arm-kernel, linux-kernel, devicetree

Hi,

On Sat, 08 Nov 2025 22:15:03 +0100, Martin Blumenstingl wrote:
> Commit 85b21fdec906e ("thermal/drivers/generic-adc: Register thermal
> zones as hwmon sensors") made "generic-adc-thermal" also register hwmon
> attributes. That means we now have the temperature sensor shown twice:
> - once from iio-hwmon
> - and another time from generic-adc-thermal
> 
> We need the latter for SoC temperature control, so simply drop the
> former so userspace doesn't see duplicate sensors. Also
> generic-adc-thermal provides a better name to userspace
> ("soc_thermal-virtual-0") than iio_hwmon.
> 
> [...]

Thanks, Applied to https://git.kernel.org/pub/scm/linux/kernel/git/amlogic/linux.git (v6.20/arm-dt)

[1/1] ARM: dts: meson: drop iio-hwmon in favour of generic-adc-thermal
      https://git.kernel.org/amlogic/c/5ea75722eaec226c60472dc578a302aae1d1fa3e

These changes has been applied on the intermediate git tree [1].

The v6.20/arm-dt branch will then be sent via a formal Pull Request to the Linux SoC maintainers
for inclusion in their intermediate git branches in order to be sent to Linus during
the next merge window, or sooner if it's a set of fixes.

In the cases of fixes, those will be merged in the current release candidate
kernel and as soon they appear on the Linux master branch they will be
backported to the previous Stable and Long-Stable kernels [2].

The intermediate git branches are merged daily in the linux-next tree [3],
people are encouraged testing these pre-release kernels and report issues on the
relevant mailing-lists.

If problems are discovered on those changes, please submit a signed-off-by revert
patch followed by a corrective changeset.

[1] https://git.kernel.org/pub/scm/linux/kernel/git/amlogic/linux.git
[2] https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git
[3] https://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git

-- 
Neil


_______________________________________________
linux-amlogic mailing list
linux-amlogic@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-amlogic

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2026-01-07 14:03 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2025-11-08 21:15 [PATCH v1] ARM: dts: meson: drop iio-hwmon in favour of generic-adc-thermal Martin Blumenstingl
2026-01-06  9:07 ` Martin Blumenstingl
2026-01-07 14:02 ` Neil Armstrong

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox