From: Harry Yoo <harry@kernel.org>
To: Hao Li <hao.li@linux.dev>
Cc: vbabka@kernel.org, akpm@linux-foundation.org, cl@gentwo.org,
rientjes@google.com, roman.gushchin@linux.dev,
linux-mm@kvack.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v3 1/2] mm/slub: introduce helpers for node partial slab state
Date: Mon, 1 Jun 2026 15:17:33 +0900 [thread overview]
Message-ID: <0dd720f2-7732-4801-85d5-4593e90e8cde@kernel.org> (raw)
In-Reply-To: <ah0VlxGBk11LRg53@fedora>
[-- Attachment #1.1: Type: text/plain, Size: 1049 bytes --]
On 6/1/26 2:26 PM, Hao Li wrote:
> On Mon, Jun 01, 2026 at 12:38:48PM +0900, Harry Yoo wrote:
>>
>>
>> On 5/29/26 12:50 PM, Hao Li wrote:
>>> Wrap partial slab count inc/dec and flag set/clear into
>>> helper functions to reduce code duplication.
>>>
>>> Note that __add_partial() is called locklessly in
>>> early_kmem_cache_node_alloc(), but since there is no such use case for
>>> removal, __remove_partial() does not exist.
>>
>> nit: __remove_partial() -> clear_partial_node_state()
>
> Ah, in this sentence, I just wanted to clarify that __remove_partial doesn't
> exist. it's not a typo :)
>
>> oh wait, it does exist. Let's drop this paragraph?
>
> This paragraph is just a quick side note to explain why __remove_partial()
> doesn't exist. I noticed that __add_partial lacks a symmetric counterpart,
> which felt a bit abrupt/inconsistent, so I wanted to share some context on why
> that is.
Ah, I see. I was confused because it didn't touch those functions :)
Thanks!
--
Cheers,
Harry / Hyeonggon
[-- Attachment #2: OpenPGP digital signature --]
[-- Type: application/pgp-signature, Size: 228 bytes --]
next prev parent reply other threads:[~2026-06-01 6:17 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-05-29 3:50 [PATCH v3 0/2] mm/slub: batch partial slab list operations Hao Li
2026-05-29 3:50 ` [PATCH v3 1/2] mm/slub: introduce helpers for node partial slab state Hao Li
2026-06-01 3:38 ` Harry Yoo
2026-06-01 5:26 ` Hao Li
2026-06-01 6:17 ` Harry Yoo [this message]
2026-05-29 3:50 ` [PATCH v3 2/2] mm/slub: detach and reattach partial slabs in batch Hao Li
2026-06-01 3:51 ` Harry Yoo
2026-05-29 8:01 ` [PATCH v3 0/2] mm/slub: batch partial slab list operations Vlastimil Babka (SUSE)
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=0dd720f2-7732-4801-85d5-4593e90e8cde@kernel.org \
--to=harry@kernel.org \
--cc=akpm@linux-foundation.org \
--cc=cl@gentwo.org \
--cc=hao.li@linux.dev \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=rientjes@google.com \
--cc=roman.gushchin@linux.dev \
--cc=vbabka@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome