mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Kanak Shilledar <Kanak.Shilledar@axis.com>
To: "jic23@kernel.org" <jic23@kernel.org>,
	"macromorgan@hotmail.com" <macromorgan@hotmail.com>
Cc: "dlechner@baylibre.com" <dlechner@baylibre.com>,
	"joshua.crofts1@gmail.com" <joshua.crofts1@gmail.com>,
	Henrik Grimler <Henrik.Grimler@axis.com>,
	"nuno.sa@analog.com" <nuno.sa@analog.com>,
	"jean-baptiste.maneyrol@tdk.com" <jean-baptiste.maneyrol@tdk.com>,
	"robh@kernel.org" <robh@kernel.org>,
	"marcelo.schmitt1@gmail.com" <marcelo.schmitt1@gmail.com>,
	"andy@kernel.org" <andy@kernel.org>,
	"krzk+dt@kernel.org" <krzk+dt@kernel.org>,
	"linux-iio@vger.kernel.org" <linux-iio@vger.kernel.org>,
	"conor+dt@kernel.org" <conor+dt@kernel.org>,
	Kernel <Kernel@axis.com>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"devicetree@vger.kernel.org" <devicetree@vger.kernel.org>
Subject: Re: [PATCH v3 3/8] iio: imu: inv_icm42607: Update _odr_to_period_us formatting
Date: Wed, 16 Sep 2026 09:23:09 +0000	[thread overview]
Message-ID: <0eff05d9e2769d44f1cea8c874d2d0e39df1b2e5.camel@axis.com> (raw)
In-Reply-To: <PH0PR19MB997338A79A8E6DEE464AC775E3A5BA2@PH0PR19MB997338.namprd19.prod.outlook.com>

[-- Attachment #1: Type: text/plain, Size: 2565 bytes --]

Hi Chris,

On Tue, 2026-09-15 at 12:20 -0500, Chris Morgan wrote:
> [Some people who received this message don't often get email from
> macromorgan@hotmail.com. Learn why this is important at
> https://aka.ms/LearnAboutSenderIdentification ]
> 
> On Mon, Sep 07, 2026 at 02:54:51AM +0100, Jonathan Cameron wrote:
> > > Update the function formatting for the
> > > inv_icm42607_odr_to_period_us
> > > function. This enhances the readability of the function and drop
> > > the
> > > unnecessary comments in the array elements.
> > The description doesn't mention the change I don't think is
> > beneficial.  Which makes it even easier to drop that change.
> > 
> > Thanks,
> > 
> > Jonathan
> > 
> > > 
> > > Signed-off-by: Kanak Shilledar <kanak.shilledar@axis.com>
> > > 
> > > diff --git a/drivers/iio/imu/inv_icm42607/inv_icm42607.h
> > > b/drivers/iio/imu/inv_icm42607/inv_icm42607.h
> > > index 4d51b0da1aa1..fa85cf738cc0 100644
> > > --- a/drivers/iio/imu/inv_icm42607/inv_icm42607.h
> > > +++ b/drivers/iio/imu/inv_icm42607/inv_icm42607.h
> > > @@ -62,16 +62,16 @@ enum inv_icm42607_accel_fs {
> > >  /* ODR values  - Note Gyro does not support ODR less than 12.5Hz
> > > */
> > >  enum inv_icm42607_odr {
> > >     INV_ICM42607_ODR_1600HZ = 5,
> > > -   INV_ICM42607_ODR_800HZ = 6,
> > > -   INV_ICM42607_ODR_400HZ = 7,
> > > -   INV_ICM42607_ODR_200HZ = 8,
> > > -   INV_ICM42607_ODR_100HZ = 9,
> > > -   INV_ICM42607_ODR_50HZ = 10,
> > > -   INV_ICM42607_ODR_25HZ = 11,
> > > -   INV_ICM42607_ODR_12_5HZ = 12,
> > > -   INV_ICM42607_ODR_6_25HZ_LP = 13,
> > > -   INV_ICM42607_ODR_3_125HZ_LP = 14,
> > > -   INV_ICM42607_ODR_1_5625HZ_LP = 15,
> > 
> > Why?  We often put all the values when they are mapping to hardware
> > register values simply because it makes them easier to compare to
> > a datasheet.
> > 
> > --
> > Jonathan Cameron <jonathan.cameron@oss.qualcomm.com>
> 
> Just to provide context, the only reason I chose the byte order I did
> is because that's how the existing icm42600 driver did it. I'm not
> opposed to changing it especially if it simplifies things or makes
> sense, but if we're going to do it now's the time (as the only
> current
> consumer of this driver is the rk3568 based anbernic-rg-ds and the
> rk3576 based anbernic-vita-pro).

I have dropped this change in my upcoming v4 of this patchset. It can
be fixed, but I think it should done be in a separate patch not part of
this series.

Thanks and Regards,
Kanak Shilledar


[-- Attachment #2: This is a digitally signed message part --]
[-- Type: application/pgp-signature, Size: 228 bytes --]

  reply	other threads:[~2026-09-16  9:23 UTC|newest]

Thread overview: 29+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-09-01 14:35 [PATCH v3 0/8] Add support for InvenSense ICM-42370-P accelerometer Kanak Shilledar
2026-09-01 14:35 ` [PATCH v3 1/8] dt-bindings: Add InvenSense ICM-42370-p accelerometer Kanak Shilledar
2026-09-07  1:54   ` Jonathan Cameron
2026-09-16  9:25     ` Kanak Shilledar
2026-09-01 14:35 ` [PATCH v3 2/8] iio: imu: inv_icm42607: Update IIO channel macros Kanak Shilledar
2026-09-01 14:35 ` [PATCH v3 3/8] iio: imu: inv_icm42607: Update _odr_to_period_us formatting Kanak Shilledar
2026-09-07  1:54   ` Jonathan Cameron
2026-09-15 17:20     ` Chris Morgan
2026-09-16  9:23       ` Kanak Shilledar [this message]
2026-09-01 14:35 ` [PATCH v3 4/8] iio: imu: inv_icm42607: Switch to little endian Kanak Shilledar
2026-09-07  1:54   ` Jonathan Cameron
2026-09-16  9:26     ` Kanak Shilledar
2026-09-01 14:35 ` [PATCH v3 5/8] iio: imu: inv_icm42607: Add support for ICM-42370-P Kanak Shilledar
2026-09-07  1:54   ` Jonathan Cameron
2026-09-16  9:28     ` Kanak Shilledar
2026-09-01 14:35 ` [PATCH v3 6/8] iio: imu: inv_icm42607: Implement MREGx register access Kanak Shilledar
2026-09-07  1:54   ` Jonathan Cameron
2026-09-07 11:52   ` Jean-Baptiste Maneyrol
2026-09-16  9:30     ` Kanak Shilledar
2026-09-01 14:36 ` [PATCH v3 7/8] iio: imu: inv_icm42607: Add accelerometer calibbias support Kanak Shilledar
2026-09-07  1:54   ` Jonathan Cameron
2026-09-16  9:37     ` Kanak Shilledar
2026-09-16  9:44       ` Joshua Crofts
2026-09-15 17:27   ` Chris Morgan
2026-09-16  9:42     ` Kanak Shilledar
2026-09-01 14:36 ` [PATCH v3 8/8] iio: imu: inv_icm42607: Add gyroscope " Kanak Shilledar
2026-09-07  1:54   ` Jonathan Cameron
2026-09-02  5:30 ` [PATCH v3 0/8] Add support for InvenSense ICM-42370-P accelerometer Andy Shevchenko
2026-09-07  1:54   ` Jonathan Cameron

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=0eff05d9e2769d44f1cea8c874d2d0e39df1b2e5.camel@axis.com \
    --to=kanak.shilledar@axis.com \
    --cc=Henrik.Grimler@axis.com \
    --cc=Kernel@axis.com \
    --cc=andy@kernel.org \
    --cc=conor+dt@kernel.org \
    --cc=devicetree@vger.kernel.org \
    --cc=dlechner@baylibre.com \
    --cc=jean-baptiste.maneyrol@tdk.com \
    --cc=jic23@kernel.org \
    --cc=joshua.crofts1@gmail.com \
    --cc=krzk+dt@kernel.org \
    --cc=linux-iio@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=macromorgan@hotmail.com \
    --cc=marcelo.schmitt1@gmail.com \
    --cc=nuno.sa@analog.com \
    --cc=robh@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®