From: Sudeep Holla <sudeep.holla@arm.com>
To: Frank Rowand <frowand.list@gmail.com>
Cc: linux-kernel@vger.kernel.org, Rob Herring <robh+dt@kernel.org>,
Sudeep Holla <sudeep.holla@arm.com>,
Arnd Bergmann <arnd@arndb.de>,
devicetree@vger.kernel.org
Subject: Re: [PATCH 1/2] of: base: add support to get machine model name
Date: Mon, 21 Nov 2016 16:20:15 +0000 [thread overview]
Message-ID: <0f150e21-ba46-d4f2-98e8-a226eb82ca3e@arm.com> (raw)
In-Reply-To: <582F6312.5040009@gmail.com>
On 18/11/16 20:22, Frank Rowand wrote:
> On 11/18/16 02:41, Sudeep Holla wrote:
>>
>>
>> On 17/11/16 21:00, Frank Rowand wrote:
>>> On 11/17/16 07:32, Sudeep Holla wrote:
>>>> Currently platforms/drivers needing to get the machine model name are
>>>> replicating the same snippet of code. In some case, the OF reference
>>>> counting is either missing or incorrect.
>>>>
>>>> This patch adds support to read the machine model name either using
>>>> the "model" or the "compatible" property in the device tree root node
>>>> to the core OF/DT code.
>>>>
>>>> This can be used to remove all the duplicate code snippets doing exactly
>>>> same thing later.
>>>
>>> I find five instances of reading only property "model":
>>>
>>> arch/arm/mach-imx/cpu.c
>>> arch/arm/mach-mxs/mach-mxs.c
>>> arch/c6x/kernel/setup.c
>>> arch/mips/cavium-octeon/setup.c
>>> arch/sh/boards/of-generic.c
>>>
>>
>> Ah sorry you were not Cc-ed in 2/2, but that shows all the instances
>> that this will be used for.
>
> I have not seen 2/2. I do not see it on the devicetree list or on lkml.
>
Yes on both [1][2]
> I did see a list of drivers in the RFC patch that you sent several hours
> before this patch.
>
> In that patch you replaced reading the model name from the _flat_ device
> tree with the new function in at least one location. That is not
> correct.
>
>
>>
>>> I find one instance of reading property "model", then if
>>> that does not exist, property "compatible":
>>>
>>> arch/mips/generic/proc.c
>>>
>>
>> Correct as you can check in patch 2/2
>>
>>> The proposed patch matches the code used in one place, and thus
>>> current usage does not match the patch description.
>>>
>>
>> Yes, but does it matter ? compatibles are somewhat informative about the
>> model IMO.
>
> Yes it does matter. That is just sloppy and makes devicetree yet harder
> to understand. It hurts clarity. The new function name says get "model",
> not get "model" or "first element of the compatible list".
>
This is a implementation in the Linux and it doesn't change anything in
DT semantics. I am not able to get your concern.
> And using the _first_ element only of the compatible list to determine
> model is not a good paradigm. It is yet another hidden, special case,
> undocumented trap to lure in the unwary.
>
The function is documented and again this doesn't enforce anything in
the bindings. It's just the way it's used by the Linux kernel.
[...]
>
> You also ignored Arnd's comment in reply to your RFC patch.
>
OK, all I can see is that Arnd wanted to reuse of_root, which I did.
Did I miss anything else ?
--
Regards,
Sudeep
[1] http://marc.info/?l=linux-kernel&m=147940586616629&w=2
[2] http://marc.info/?l=linux-kernel&m=147940575116579&w=2
next prev parent reply other threads:[~2016-11-21 16:20 UTC|newest]
Thread overview: 21+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-11-17 15:32 Sudeep Holla
2016-11-17 15:32 ` [PATCH 2/2] of: base: replace all duplicate code with of_machine_get_model_name Sudeep Holla
2016-11-17 21:00 ` [PATCH 1/2] of: base: add support to get machine model name Frank Rowand
2016-11-17 22:12 ` Frank Rowand
2016-11-18 10:41 ` Sudeep Holla
2016-11-18 20:22 ` Frank Rowand
2016-11-21 16:05 ` Frank Rowand
2016-11-21 16:23 ` Sudeep Holla
2016-11-21 19:24 ` Frank Rowand
2016-11-21 20:49 ` Frank Rowand
2016-11-21 16:20 ` Sudeep Holla [this message]
2016-11-21 20:21 ` Frank Rowand
2016-11-18 14:46 ` Rob Herring
2016-11-18 20:00 ` Frank Rowand
2016-11-22 18:44 ` Frank Rowand
2016-11-22 21:35 ` Rob Herring
2016-11-23 10:25 ` Sudeep Holla
2016-12-09 16:03 ` Rob Herring
2016-12-09 23:54 ` Frank Rowand
2016-12-12 15:17 ` Rob Herring
2016-11-23 10:23 ` Sudeep Holla
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=0f150e21-ba46-d4f2-98e8-a226eb82ca3e@arm.com \
--to=sudeep.holla@arm.com \
--cc=arnd@arndb.de \
--cc=devicetree@vger.kernel.org \
--cc=frowand.list@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=robh+dt@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome