From: Sudeep Holla <sudeep.holla@arm.com>
To: Rob Herring <robh@kernel.org>
Cc: Frank Rowand <frowand.list@gmail.com>,
Sudeep Holla <sudeep.holla@arm.com>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
Arnd Bergmann <arnd@arndb.de>,
"devicetree@vger.kernel.org" <devicetree@vger.kernel.org>
Subject: Re: [PATCH 1/2] of: base: add support to get machine model name
Date: Wed, 23 Nov 2016 10:25:57 +0000 [thread overview]
Message-ID: <195d492b-c674-e096-4f84-d37ca5448db2@arm.com> (raw)
In-Reply-To: <CAL_JsqLsw6BNSDY8pGJ8x3XF21WdciLC7WC+z796pYtDk_kvxA@mail.gmail.com>
On 22/11/16 21:35, Rob Herring wrote:
> On Tue, Nov 22, 2016 at 12:44 PM, Frank Rowand <frowand.list@gmail.com> wrote:
[...]
>>
>> This patch adds a function that leads to conflating the "model" property
>> and the "compatible" property. This leads to opaque, confusing and unclear
>> code where ever it is used. I think it is not good for the device tree
>> framework to contribute to writing unclear code.
>>
>> Further, only two of the proposed users of this new function appear to
>> be proper usage. I do not think that the small amount of reduced lines
>> of code is a good trade off for the reduced code clarity and for the
>> potential for future mis-use of this function.
>>
>> Can I convince you to revert this patch?
>
> Yes, I will revert.
>
>> If not, will you accept a patch to change the function name to more
>> clearly indicate what it does? (One possible name would be
>> of_model_or_1st_compatible().)
>
> I took it as there's already the FDT equivalent function.
Yes it was mainly for non of_flat_* replacement for
of_flat_dt_get_machine_name
--
Regards,
Sudeep
next prev parent reply other threads:[~2016-11-23 10:33 UTC|newest]
Thread overview: 21+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-11-17 15:32 Sudeep Holla
2016-11-17 15:32 ` [PATCH 2/2] of: base: replace all duplicate code with of_machine_get_model_name Sudeep Holla
2016-11-17 21:00 ` [PATCH 1/2] of: base: add support to get machine model name Frank Rowand
2016-11-17 22:12 ` Frank Rowand
2016-11-18 10:41 ` Sudeep Holla
2016-11-18 20:22 ` Frank Rowand
2016-11-21 16:05 ` Frank Rowand
2016-11-21 16:23 ` Sudeep Holla
2016-11-21 19:24 ` Frank Rowand
2016-11-21 20:49 ` Frank Rowand
2016-11-21 16:20 ` Sudeep Holla
2016-11-21 20:21 ` Frank Rowand
2016-11-18 14:46 ` Rob Herring
2016-11-18 20:00 ` Frank Rowand
2016-11-22 18:44 ` Frank Rowand
2016-11-22 21:35 ` Rob Herring
2016-11-23 10:25 ` Sudeep Holla [this message]
2016-12-09 16:03 ` Rob Herring
2016-12-09 23:54 ` Frank Rowand
2016-12-12 15:17 ` Rob Herring
2016-11-23 10:23 ` Sudeep Holla
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=195d492b-c674-e096-4f84-d37ca5448db2@arm.com \
--to=sudeep.holla@arm.com \
--cc=arnd@arndb.de \
--cc=devicetree@vger.kernel.org \
--cc=frowand.list@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=robh@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome