* [PATCH v4 0/2] wireless: ray_cs: Improve card_status[] @ 2022-04-06 15:22 Benjamin Stürz 2022-04-06 15:22 ` [PATCH v4 1/2] " Benjamin Stürz 2022-04-06 15:22 ` [PATCH v4 2/2] ray_cs: Make card_status[] const Benjamin Stürz 0 siblings, 2 replies; 4+ messages in thread From: Benjamin Stürz @ 2022-04-06 15:22 UTC (permalink / raw) To: kvalo Cc: davem, kuba, pabeni, linux-wireless, netdev, linux-kernel, Benjamin Stürz This small patch series improves the card_status[] array in ray_cs.c. It essentially replaces comments describing the index with designated initializers using enum constants as indexes. It also makes the array const because it shouldn't be modified at runtime. Benjamin Stürz (2): ray_cs: Improve card_status[] ray_cs: Make card_status[] const drivers/net/wireless/ray_cs.c | 33 ++++++++++++++++++--------------- 1 file changed, 18 insertions(+), 15 deletions(-) -- 2.35.1 ^ permalink raw reply [flat|nested] 4+ messages in thread
* [PATCH v4 1/2] ray_cs: Improve card_status[] 2022-04-06 15:22 [PATCH v4 0/2] wireless: ray_cs: Improve card_status[] Benjamin Stürz @ 2022-04-06 15:22 ` Benjamin Stürz 2022-04-06 17:58 ` Joe Perches 2022-04-06 15:22 ` [PATCH v4 2/2] ray_cs: Make card_status[] const Benjamin Stürz 1 sibling, 1 reply; 4+ messages in thread From: Benjamin Stürz @ 2022-04-06 15:22 UTC (permalink / raw) To: kvalo Cc: davem, kuba, pabeni, linux-wireless, netdev, linux-kernel, Benjamin Stürz Replace comments with C99's designated initializers to improve readability and maintainability. Signed-off-by: Benjamin Stürz <benni@stuerz.xyz> --- drivers/net/wireless/ray_cs.c | 31 +++++++++++++++++-------------- 1 file changed, 17 insertions(+), 14 deletions(-) diff --git a/drivers/net/wireless/ray_cs.c b/drivers/net/wireless/ray_cs.c index 87e98ab068ed..3df795dc3d9f 100644 --- a/drivers/net/wireless/ray_cs.c +++ b/drivers/net/wireless/ray_cs.c @@ -2529,20 +2529,23 @@ static void clear_interrupt(ray_dev_t *local) #define MAXDATA (PAGE_SIZE - 80) static const char *card_status[] = { - "Card inserted - uninitialized", /* 0 */ - "Card not downloaded", /* 1 */ - "Waiting for download parameters", /* 2 */ - "Card doing acquisition", /* 3 */ - "Acquisition complete", /* 4 */ - "Authentication complete", /* 5 */ - "Association complete", /* 6 */ - "???", "???", "???", "???", /* 7 8 9 10 undefined */ - "Card init error", /* 11 */ - "Download parameters error", /* 12 */ - "???", /* 13 */ - "Acquisition failed", /* 14 */ - "Authentication refused", /* 15 */ - "Association failed" /* 16 */ + [CARD_INSERTED] = "Card inserted - uninitialized", + [CARD_AWAITING_PARAM] = "Card not downloaded", + [CARD_DL_PARAM] = "Waiting for download parameters", + [CARD_DOING_ACQ] = "Card doing acquisition", + [CARD_ACQ_COMPLETE] = "Acquisition complete", + [CARD_AUTH_COMPLETE] = "Authentication complete", + [CARD_ASSOC_COMPLETE] = "Association complete", + [7] = "???", + [8] = "???", + [9] = "???", + [10] = "???", + [CARD_INIT_ERROR] = "Card init error", + [CARD_DL_PARAM_ERROR] = "Download parameters error", + [13] = "???", + [CARD_ACQ_FAILED] = "Acquisition failed", + [CARD_AUTH_REFUSED] = "Authentication refused", + [CARD_ASSOC_FAILED] = "Association failed" }; static const char *nettype[] = { "Adhoc", "Infra " }; -- 2.35.1 ^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: [PATCH v4 1/2] ray_cs: Improve card_status[] 2022-04-06 15:22 ` [PATCH v4 1/2] " Benjamin Stürz @ 2022-04-06 17:58 ` Joe Perches 0 siblings, 0 replies; 4+ messages in thread From: Joe Perches @ 2022-04-06 17:58 UTC (permalink / raw) To: Benjamin Stürz, kvalo Cc: davem, kuba, pabeni, linux-wireless, netdev, linux-kernel On Wed, 2022-04-06 at 17:22 +0200, Benjamin Stürz wrote: > Replace comments with C99's designated initializers to improve > readability and maintainability. [] > diff --git a/drivers/net/wireless/ray_cs.c b/drivers/net/wireless/ray_cs.c [] > @@ -2529,20 +2529,23 @@ static void clear_interrupt(ray_dev_t *local) > #define MAXDATA (PAGE_SIZE - 80) > > static const char *card_status[] = { > - "Card inserted - uninitialized", /* 0 */ > - "Card not downloaded", /* 1 */ > - "Waiting for download parameters", /* 2 */ > - "Card doing acquisition", /* 3 */ > - "Acquisition complete", /* 4 */ > - "Authentication complete", /* 5 */ > - "Association complete", /* 6 */ > - "???", "???", "???", "???", /* 7 8 9 10 undefined */ > - "Card init error", /* 11 */ > - "Download parameters error", /* 12 */ > - "???", /* 13 */ > - "Acquisition failed", /* 14 */ > - "Authentication refused", /* 15 */ > - "Association failed" /* 16 */ > + [CARD_INSERTED] = "Card inserted - uninitialized", > + [CARD_AWAITING_PARAM] = "Card not downloaded", > + [CARD_DL_PARAM] = "Waiting for download parameters", > + [CARD_DOING_ACQ] = "Card doing acquisition", > + [CARD_ACQ_COMPLETE] = "Acquisition complete", > + [CARD_AUTH_COMPLETE] = "Authentication complete", > + [CARD_ASSOC_COMPLETE] = "Association complete", > + [7] = "???", > + [8] = "???", > + [9] = "???", > + [10] = "???", Rather than using specific numbers and "???" it's probably better to use no initialization at all and change the output call to test the array index ao all of the [number] = "???" could be removed. --- drivers/net/wireless/ray_cs.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/net/wireless/ray_cs.c b/drivers/net/wireless/ray_cs.c index 87e98ab068ed..29451cd0a22a 100644 --- a/drivers/net/wireless/ray_cs.c +++ b/drivers/net/wireless/ray_cs.c @@ -2600,7 +2600,7 @@ static int ray_cs_proc_show(struct seq_file *m, void *v) i = 10; if (i > 16) i = 10; - seq_printf(m, "Card status = %s\n", card_status[i]); + seq_printf(m, "Card status = %s\n", card_status[i] ?: "???"); seq_printf(m, "Framing mode = %s\n", framing[translate]); ^ permalink raw reply [flat|nested] 4+ messages in thread
* [PATCH v4 2/2] ray_cs: Make card_status[] const 2022-04-06 15:22 [PATCH v4 0/2] wireless: ray_cs: Improve card_status[] Benjamin Stürz 2022-04-06 15:22 ` [PATCH v4 1/2] " Benjamin Stürz @ 2022-04-06 15:22 ` Benjamin Stürz 1 sibling, 0 replies; 4+ messages in thread From: Benjamin Stürz @ 2022-04-06 15:22 UTC (permalink / raw) To: kvalo Cc: davem, kuba, pabeni, linux-wireless, netdev, linux-kernel, Benjamin Stürz Make the const because it shouldn't be modified. Signed-off-by: Benjamin Stürz <benni@stuerz.xyz> --- drivers/net/wireless/ray_cs.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/net/wireless/ray_cs.c b/drivers/net/wireless/ray_cs.c index 3df795dc3d9f..07f36aaefbde 100644 --- a/drivers/net/wireless/ray_cs.c +++ b/drivers/net/wireless/ray_cs.c @@ -2528,7 +2528,7 @@ static void clear_interrupt(ray_dev_t *local) #ifdef CONFIG_PROC_FS #define MAXDATA (PAGE_SIZE - 80) -static const char *card_status[] = { +static const char * const card_status[] = { [CARD_INSERTED] = "Card inserted - uninitialized", [CARD_AWAITING_PARAM] = "Card not downloaded", [CARD_DL_PARAM] = "Waiting for download parameters", -- 2.35.1 ^ permalink raw reply [flat|nested] 4+ messages in thread
end of thread, other threads:[~2022-04-06 19:07 UTC | newest] Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed) -- links below jump to the message on this page -- 2022-04-06 15:22 [PATCH v4 0/2] wireless: ray_cs: Improve card_status[] Benjamin Stürz 2022-04-06 15:22 ` [PATCH v4 1/2] " Benjamin Stürz 2022-04-06 17:58 ` Joe Perches 2022-04-06 15:22 ` [PATCH v4 2/2] ray_cs: Make card_status[] const Benjamin Stürz
This is a public inbox, see mirroring instructions for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®