* Kernel panic while upgrading from 2.4.20-6 to 2.4.22
@ 2003-12-25 2:39 Elwin Eliazer
2003-12-29 19:31 ` Marcelo Tosatti
0 siblings, 1 reply; 3+ messages in thread
From: Elwin Eliazer @ 2003-12-25 2:39 UTC (permalink / raw)
To: linux-kernel; +Cc: elwinietf
Hi,
I am getting kernel panic, when i try to upgrade my
kernel from 2.4.20-6 to 2.4.22.
This is on a Compaq desktop, and the 2.4.20-6 is what
i got as kernel from Redhat 9.0 CDs. I use GRUB
loader, and there is no other OS in the system.
Following are the steps i took, based on the
/usr/src/linux-2.4.20-6/README file.
Downloaded the linux-2.4.22.tar.gz file into /usr/src,
and untarred, which created /usr/src/linux-2.4.22.
# cd /usr/src/linux-2.4.22
# make config
# make dep
# make bzImage
# make modules
# make modules_install
# make install
No error came in any of these steps, and i could see
additional entries added for GRUB, and the boot image
appropriately copied into /boot
After these, when i reboot, i could see the additional
entry for 2.4.22 shown in GRUB menu. When i select
that and enter, following are some of the final
messages i get, saying kernel panic.
ds: no socket drivers loaded!
VFS: Cannot open root device "LABEL=/" or 00:00
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on 00:00
Not sure if i am missing some step, or missing to read
some already written document.
Your help will be appreciated.
Thanks,
Elwin.
__________________________________
Do you Yahoo!?
New Yahoo! Photos - easier uploading and sharing.
http://photos.yahoo.com/
^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: Kernel panic while upgrading from 2.4.20-6 to 2.4.22
2003-12-25 2:39 Kernel panic while upgrading from 2.4.20-6 to 2.4.22 Elwin Eliazer
@ 2003-12-29 19:31 ` Marcelo Tosatti
2003-12-30 0:04 ` Joshua Schmidlkofer
0 siblings, 1 reply; 3+ messages in thread
From: Marcelo Tosatti @ 2003-12-29 19:31 UTC (permalink / raw)
To: Elwin Eliazer; +Cc: linux-kernel
On Wed, 24 Dec 2003, Elwin Eliazer wrote:
> ds: no socket drivers loaded!
> VFS: Cannot open root device "LABEL=/" or 00:00
> Please append a correct "root=" boot option
> Kernel panic: VFS: Unable to mount root fs on 00:00
If you want to use the vanilla kernel, you need to use "root=/dev/xxx"
instead "LABEL=/".
^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: Kernel panic while upgrading from 2.4.20-6 to 2.4.22
2003-12-29 19:31 ` Marcelo Tosatti
@ 2003-12-30 0:04 ` Joshua Schmidlkofer
0 siblings, 0 replies; 3+ messages in thread
From: Joshua Schmidlkofer @ 2003-12-30 0:04 UTC (permalink / raw)
To: Linux Kernel
On Mon, 2003-12-29 at 11:31, Marcelo Tosatti wrote:
> On Wed, 24 Dec 2003, Elwin Eliazer wrote:
>
> > ds: no socket drivers loaded!
> > VFS: Cannot open root device "LABEL=/" or 00:00
> > Please append a correct "root=" boot option
> > Kernel panic: VFS: Unable to mount root fs on 00:00
>
> If you want to use the vanilla kernel, you need to use "root=/dev/xxx"
> instead "LABEL=/".
>
You can also use the mkinitrd that comes with redhat:
# cd /usr/src/linux-2.4.22
# make config
# make dep
# make bzImage
# make modules
# make modules_install
# cp System.map /boot/System.map-2.4.22
# cp arch/i386/boot/bzImage /boot/vmlinuz-2.4.22
# mkinitrd /boot/initrd-2.4.22.img 2.4.22
If you get errors, it will most likely be SCSI or something.
Try:
--omit-raid-modules or --omit-scsi-modules.
man mkinitrd.
js
^ permalink raw reply [flat|nested] 3+ messages in thread
end of thread, other threads:[~2003-12-30 0:04 UTC | newest]
Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2003-12-25 2:39 Kernel panic while upgrading from 2.4.20-6 to 2.4.22 Elwin Eliazer
2003-12-29 19:31 ` Marcelo Tosatti
2003-12-30 0:04 ` Joshua Schmidlkofer
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®