From: john stultz <johnstul@us.ibm.com>
To: Krzysztof Halasa <khc@pm.waw.pl>
Cc: Marcelo Tosatti <marcelo.tosatti@cyclades.com>,
lkml <linux-kernel@vger.kernel.org>
Subject: Re: [TRIVIAL PATCH] 2.4.25pre7 warning fix
Date: Thu, 29 Jan 2004 11:22:31 -0800 [thread overview]
Message-ID: <1075404151.1592.97.camel@cog.beaverton.ibm.com> (raw)
In-Reply-To: <m3wu7azp46.fsf@defiant.pm.waw.pl>
On Thu, 2004-01-29 at 08:38, Krzysztof Halasa wrote:
> Marcelo Tosatti <marcelo.tosatti@cyclades.com> writes:
>
> > Btw, why do we need cyclone_setup() for !CONFIG_X86_SUMMIT ?
> >
> > /* No-cyclone stubs */
> > #ifndef CONFIG_X86_SUMMIT
> > int __init cyclone_setup(char *str)
> > {
> > printk(KERN_ERR "cyclone: Kernel not compiled with
> > CONFIG_X86_SUMMIT, cannot use the cyclone-timer.\n");
> > return 1;
> > }
This is needed because cyclone_setup() is called by
detect_clustered_apic(), which may or may not be done on a kernel w/
CONFIG_X86_SUMMIT enabled.
>
> After having a closer look at it I think we should:
>
> 1. if CONFIG_X86_TSC is set:
> - make calibrate_tsc() failure a fatal error
> - assume use_tsc = 1 and x86_udelay_tsc = 1 and optimize them out
> with preprocessor
Sounds fair.
>
> 2. if CONFIG_X86_SUMMIT is _not_ set:
> - assume use_cyclone = 0 and optimize it out as well.
We already do this.
> - cyclone_setup() etc should go out.
cyclone_setup() is still needed.
> 3. I would rename CONFIG_X86_TSC to something like CONFIG_X86_TSC_FORCE
> - the current name is misleading. It wouldn't affect .config.
Agreed.
thanks
-john
prev parent reply other threads:[~2004-01-29 19:23 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2004-01-27 21:28 Krzysztof Halasa
2004-01-28 11:42 ` Marcelo Tosatti
2004-01-28 22:17 ` Krzysztof Halasa
2004-01-29 16:38 ` Krzysztof Halasa
2004-01-29 19:22 ` john stultz [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1075404151.1592.97.camel@cog.beaverton.ibm.com \
--to=johnstul@us.ibm.com \
--cc=khc@pm.waw.pl \
--cc=linux-kernel@vger.kernel.org \
--cc=marcelo.tosatti@cyclades.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®