mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Greg KH <gregkh@suse.de>
To: linux-kernel@vger.kernel.org
Cc: gregkh@suse.de
Subject: [PATCH] INPUT: Fix oops when accessing sysfs files of nested input devices
Date: Thu, 27 Oct 2005 23:30:26 -0700	[thread overview]
Message-ID: <11304810262190@kroah.com> (raw)
In-Reply-To: <11304810263348@kroah.com>

[PATCH] INPUT: Fix oops when accessing sysfs files of nested input devices

Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>

---
commit 706d2a7c95014882307f31cd0f3c2a95b0544819
tree d13cecf9467ec8812058bad516c451e1d2c7263e
parent ae2ea92c4fa1b32ab686bf48243b3671b3aa7c3a
author Greg Kroah-Hartman <gregkh@suse.de> Thu, 27 Oct 2005 22:25:43 -0700
committer Greg Kroah-Hartman <gregkh@suse.de> Thu, 27 Oct 2005 22:48:06 -0700

 drivers/input/input.c |   19 ++++++++++++-------
 1 files changed, 12 insertions(+), 7 deletions(-)

diff --git a/drivers/input/input.c b/drivers/input/input.c
index b0ede4c..0d570cf 100644
--- a/drivers/input/input.c
+++ b/drivers/input/input.c
@@ -642,17 +642,22 @@ static ssize_t input_dev_show_##name(str
 	up(&input_dev->sem);							\
 										\
 	return retval;								\
-}
+}										\
+static CLASS_DEVICE_ATTR(name, S_IRUGO, input_dev_show_##name, NULL);
 
 INPUT_DEV_STRING_ATTR_SHOW(name);
 INPUT_DEV_STRING_ATTR_SHOW(phys);
 INPUT_DEV_STRING_ATTR_SHOW(uniq);
 
-static struct class_device_attribute input_dev_attrs[] = {
-	__ATTR(name, S_IRUGO, input_dev_show_name, NULL),
-	__ATTR(phys, S_IRUGO, input_dev_show_phys, NULL),
-	__ATTR(uniq, S_IRUGO, input_dev_show_uniq, NULL),
-	__ATTR_NULL
+static struct attribute *input_dev_attrs[] = {
+	&class_device_attr_name.attr,
+	&class_device_attr_phys.attr,
+	&class_device_attr_uniq.attr,
+	NULL
+};
+
+static struct attribute_group input_dev_group = {
+	.attrs	= input_dev_attrs,
 };
 
 #define INPUT_DEV_ID_ATTR(name)							\
@@ -728,7 +733,6 @@ static void input_dev_release(struct cla
 struct class input_dev_class = {
 	.name			= "input_dev",
 	.release		= input_dev_release,
-	.class_dev_attrs	= input_dev_attrs,
 };
 
 struct input_dev *input_allocate_device(void)
@@ -766,6 +770,7 @@ static void input_register_classdevice(s
 	kfree(path);
 
 	class_device_add(&dev->cdev);
+	sysfs_create_group(&dev->cdev.kobj, &input_dev_group);
 	sysfs_create_group(&dev->cdev.kobj, &input_dev_id_attr_group);
 	sysfs_create_group(&dev->cdev.kobj, &input_dev_caps_attr_group);
 }


  reply	other threads:[~2005-10-28  6:48 UTC|newest]

Thread overview: 22+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <11304810253548@kroah.com>
2005-10-28  6:30 ` [PATCH] Input: convert drivers/macintosh to dynamic input_dev allocation Greg KH
2005-10-28  6:30   ` [PATCH] Input: convert sound/ppc/beep " Greg KH
2005-10-28  6:30     ` [PATCH] drivers/media: convert " Greg KH
2005-10-28  6:30       ` [PATCH] Input: show sysfs path in /proc/bus/input/devices Greg KH
2005-10-28  6:30         ` [PATCH] Input: export input_dev data via sysfs attributes Greg KH
2005-10-28  6:30           ` [PATCH] INPUT: remove the input_class structure, as it is unused Greg KH
2005-10-28  6:30             ` [PATCH] INPUT: export input_dev_class so that input drivers can use it Greg KH
2005-10-28  6:30               ` Greg KH [this message]
2005-10-28  6:30                 ` [PATCH] INPUT: register the input class device sooner Greg KH
2005-10-28  6:30                   ` [PATCH] INPUT: move the input class devices under their new input_dev devices Greg KH
2005-10-28  6:30                     ` [PATCH] INPUT: rename input_dev_class to input_class to be correct Greg KH
2005-10-28  6:30                       ` [PATCH] input core: remove custom-made hotplug handler Greg KH
2005-10-28  6:30                         ` [PATCH] update required version of udev Greg KH
2005-10-28  6:30                           ` [PATCH] Driver Core: Big kfree NULL check cleanup - Documentation Greg KH
2005-10-28  6:30                             ` [PATCH] INPUT: Create symlinks for backwards compatibility Greg KH
2005-10-28  6:30                               ` [PATCH] drivers/base - fix sparse warnings Greg KH
2005-10-28  6:30                                 ` [PATCH] kernel-doc: drivers/base fixes Greg KH
2005-10-28  6:30                                   ` [PATCH] DRIVER MODEL: Get rid of the obsolete tri-level suspend/resume callbacks Greg KH
2005-10-28  9:14                                     ` Russell King
2005-10-28 10:04                                     ` Takashi Iwai
2005-10-28 11:13                                       ` Russell King
2005-10-28 14:45                                         ` Takashi Iwai

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=11304810262190@kroah.com \
    --to=gregkh@suse.de \
    --cc=greg@kroah.com \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome