From: Greg KH <gregkh@suse.de>
To: linux-kernel@vger.kernel.org
Cc: gregkh@suse.de
Subject: [PATCH] INPUT: remove the input_class structure, as it is unused.
Date: Thu, 27 Oct 2005 23:30:26 -0700 [thread overview]
Message-ID: <11304810262929@kroah.com> (raw)
In-Reply-To: <11304810264196@kroah.com>
[PATCH] INPUT: remove the input_class structure, as it is unused.
Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
---
commit 4fccc75dab34abbbf9368d2fa21bed0918cdaec7
tree aac77ee746bae2328684201596b2860d94fd1e02
parent 706d2a7c95014882307f31cd0f3c2a95b0544819
author Greg Kroah-Hartman <gregkh@suse.de> Thu, 27 Oct 2005 22:25:43 -0700
committer Greg Kroah-Hartman <gregkh@suse.de> Thu, 27 Oct 2005 22:48:06 -0700
drivers/input/input.c | 18 +++---------------
include/linux/input.h | 1 -
2 files changed, 3 insertions(+), 16 deletions(-)
diff --git a/drivers/input/input.c b/drivers/input/input.c
index 0d570cf..5c9044d 100644
--- a/drivers/input/input.c
+++ b/drivers/input/input.c
@@ -39,7 +39,6 @@ EXPORT_SYMBOL(input_close_device);
EXPORT_SYMBOL(input_accept_process);
EXPORT_SYMBOL(input_flush_device);
EXPORT_SYMBOL(input_event);
-EXPORT_SYMBOL(input_class);
EXPORT_SYMBOL_GPL(input_dev_class);
#define INPUT_DEVICES 256
@@ -927,8 +926,6 @@ static struct file_operations input_fops
.open = input_open_file,
};
-struct class *input_class;
-
static int __init input_init(void)
{
int err;
@@ -939,27 +936,19 @@ static int __init input_init(void)
return err;
}
- input_class = class_create(THIS_MODULE, "input");
- if (IS_ERR(input_class)) {
- printk(KERN_ERR "input: unable to register input class\n");
- err = PTR_ERR(input_class);
- goto fail1;
- }
-
err = input_proc_init();
if (err)
- goto fail2;
+ goto fail1;
err = register_chrdev(INPUT_MAJOR, "input", &input_fops);
if (err) {
printk(KERN_ERR "input: unable to register char major %d", INPUT_MAJOR);
- goto fail3;
+ goto fail2;
}
return 0;
- fail3: input_proc_exit();
- fail2: class_destroy(input_class);
+ fail2: input_proc_exit();
fail1: class_unregister(&input_dev_class);
return err;
}
@@ -968,7 +957,6 @@ static void __exit input_exit(void)
{
input_proc_exit();
unregister_chrdev(INPUT_MAJOR, "input");
- class_destroy(input_class);
class_unregister(&input_dev_class);
}
diff --git a/include/linux/input.h b/include/linux/input.h
index 5de8441..256e887 100644
--- a/include/linux/input.h
+++ b/include/linux/input.h
@@ -1074,7 +1074,6 @@ static inline void input_set_abs_params(
dev->absbit[LONG(axis)] |= BIT(axis);
}
-extern struct class *input_class;
extern struct class input_dev_class;
#endif
next prev parent reply other threads:[~2005-10-28 6:47 UTC|newest]
Thread overview: 22+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <11304810253548@kroah.com>
2005-10-28 6:30 ` [PATCH] Input: convert drivers/macintosh to dynamic input_dev allocation Greg KH
2005-10-28 6:30 ` [PATCH] Input: convert sound/ppc/beep " Greg KH
2005-10-28 6:30 ` [PATCH] drivers/media: convert " Greg KH
2005-10-28 6:30 ` [PATCH] Input: show sysfs path in /proc/bus/input/devices Greg KH
2005-10-28 6:30 ` [PATCH] Input: export input_dev data via sysfs attributes Greg KH
2005-10-28 6:30 ` Greg KH [this message]
2005-10-28 6:30 ` [PATCH] INPUT: export input_dev_class so that input drivers can use it Greg KH
2005-10-28 6:30 ` [PATCH] INPUT: Fix oops when accessing sysfs files of nested input devices Greg KH
2005-10-28 6:30 ` [PATCH] INPUT: register the input class device sooner Greg KH
2005-10-28 6:30 ` [PATCH] INPUT: move the input class devices under their new input_dev devices Greg KH
2005-10-28 6:30 ` [PATCH] INPUT: rename input_dev_class to input_class to be correct Greg KH
2005-10-28 6:30 ` [PATCH] input core: remove custom-made hotplug handler Greg KH
2005-10-28 6:30 ` [PATCH] update required version of udev Greg KH
2005-10-28 6:30 ` [PATCH] Driver Core: Big kfree NULL check cleanup - Documentation Greg KH
2005-10-28 6:30 ` [PATCH] INPUT: Create symlinks for backwards compatibility Greg KH
2005-10-28 6:30 ` [PATCH] drivers/base - fix sparse warnings Greg KH
2005-10-28 6:30 ` [PATCH] kernel-doc: drivers/base fixes Greg KH
2005-10-28 6:30 ` [PATCH] DRIVER MODEL: Get rid of the obsolete tri-level suspend/resume callbacks Greg KH
2005-10-28 9:14 ` Russell King
2005-10-28 10:04 ` Takashi Iwai
2005-10-28 11:13 ` Russell King
2005-10-28 14:45 ` Takashi Iwai
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=11304810262929@kroah.com \
--to=gregkh@suse.de \
--cc=greg@kroah.com \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome