From: Arjan van de Ven <arjan@infradead.org>
To: "Michael S. Tsirkin" <mst@mellanox.co.il>
Cc: Andrew Morton <akpm@osdl.org>, Ingo Molnar <mingo@elte.hu>,
Zach Brown <zach.brown@oracle.com>,
openib-general@openib.org, linux-kernel@vger.kernel.org,
netdev@vger.kernel.org
Subject: Re: [PATCH] IB/mthca: comment fix
Date: Mon, 10 Jul 2006 13:45:03 +0200 [thread overview]
Message-ID: <1152531909.4874.22.camel@laptopd505.fenrus.org> (raw)
In-Reply-To: <20060710113112.GA26198@mellanox.co.il>
On Mon, 2006-07-10 at 14:31 +0300, Michael S. Tsirkin wrote:
> Quoting r. Arjan van de Ven <arjan@infradead.org>:
> > Subject: Re: [PATCH] IB/mthca: comment fix
> >
> > On Mon, 2006-07-10 at 14:14 +0300, Michael S. Tsirkin wrote:
> > > Hi Andrew,
> > > Here's a cosmetic patch for IB/mthca. Pls drop it into -mm and on.
> > >
> > > ---
> > >
> > > comment in mthca_qp.c makes it seem lockdep is the only reason WQ locks should
> > > be initialized separately, but as Zach Brown and Roland pointed out, there are
> > > other reasons, e.g. that mthca_wq_init is called from modify qp as well.
> >
> > ehh.. shouldn't the comment say that instead then? that's one tricky
> > thing and might as well have that documented in the code!
>
> Hmm. Okay. Maybe we should rename mthca_wq_init to mthca_wq_reset?
> This would make it clear that it does not init the spinlocks,
> but just resets the rest of the fields, would not it?
makes sense to me; my main concern is that we document the bug that was
there; unless you document such things.. these bugs tend to have a habit
of resurfacing later ;)
next prev parent reply other threads:[~2006-07-10 11:45 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2006-07-10 11:14 Michael S. Tsirkin
2006-07-10 11:18 ` Arjan van de Ven
2006-07-10 11:31 ` Michael S. Tsirkin
2006-07-10 11:45 ` Arjan van de Ven [this message]
2006-07-10 11:59 ` Michael S. Tsirkin
2006-07-10 15:18 ` [PATCH updated] " Michael S. Tsirkin
2006-07-10 21:15 ` [PATCHv2] " Michael S. Tsirkin
2006-07-10 21:20 ` Zach Brown
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1152531909.4874.22.camel@laptopd505.fenrus.org \
--to=arjan@infradead.org \
--cc=akpm@osdl.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@elte.hu \
--cc=mst@mellanox.co.il \
--cc=netdev@vger.kernel.org \
--cc=openib-general@openib.org \
--cc=zach.brown@oracle.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®