mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH 3/3] drivers/scsi/NCR5380.c: Replacing yield() with a better alternative
@ 2006-10-11 12:54 Amol Lad
  2006-10-11 17:52 ` Alan Cox
  0 siblings, 1 reply; 3+ messages in thread
From: Amol Lad @ 2006-10-11 12:54 UTC (permalink / raw)
  To: linux kernel; +Cc: James.Bottomley, kernel Janitors

For this driver schedule_timeout_schedule() seems to be a better
alternative. 

*Please see if the function should be called with 1 jiffy delay or more
is better*

Signed-off-by: Amol Lad <amol@verismonetworks.com>
---
diff -uprN -X linux-2.6.19-rc1-orig/Documentation/dontdiff linux-2.6.19-rc1-orig/drivers/scsi/NCR5380.c linux-2.6.19-rc1/drivers/scsi/NCR5380.c
--- linux-2.6.19-rc1-orig/drivers/scsi/NCR5380.c	2006-09-21 10:15:39.000000000 +0530
+++ linux-2.6.19-rc1/drivers/scsi/NCR5380.c	2006-10-11 17:57:02.000000000 +0530
@@ -347,7 +347,7 @@ static int NCR5380_poll_politely(struct 
 		if((r & bit) == val)
 			return 0;
 		if(!in_interrupt())
-			yield();
+			schedule_timeout_interruptible(1);
 		else
 			cpu_relax();
 	}



^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH 3/3] drivers/scsi/NCR5380.c: Replacing yield() with a better alternative
  2006-10-11 12:54 [PATCH 3/3] drivers/scsi/NCR5380.c: Replacing yield() with a better alternative Amol Lad
@ 2006-10-11 17:52 ` Alan Cox
  2006-10-12  4:29   ` Amol Lad
  0 siblings, 1 reply; 3+ messages in thread
From: Alan Cox @ 2006-10-11 17:52 UTC (permalink / raw)
  To: Amol Lad; +Cc: linux kernel, James.Bottomley, kernel Janitors

Ar Mer, 2006-10-11 am 18:24 +0530, ysgrifennodd Amol Lad:
> For this driver schedule_timeout_schedule() seems to be a better
> alternative. 
> 
> *Please see if the function should be called with 1 jiffy delay or more
> is better*

You want cond_resched() for this driver as its polling the hardware for
a change that should occur very soon. (Actually you want to throw the
hardware in the bin)

Alan


^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH 3/3] drivers/scsi/NCR5380.c: Replacing yield() with a better alternative
  2006-10-11 17:52 ` Alan Cox
@ 2006-10-12  4:29   ` Amol Lad
  0 siblings, 0 replies; 3+ messages in thread
From: Amol Lad @ 2006-10-12  4:29 UTC (permalink / raw)
  To: Alan Cox; +Cc: linux kernel, James.Bottomley, kernel Janitors


> You want cond_resched() for this driver as its polling the hardware for
> a change that should occur very soon. (Actually you want to throw the
> hardware in the bin)
> 

Replaced schedule_timeout_interruptible() with cond_resched()

Signed-off-by: Amol Lad <amol@verismonetworks.com>
---
diff -uprN -X linux-2.6.19-rc1-orig/Documentation/dontdiff linux-2.6.19-rc1-orig/drivers/scsi/NCR5380.c linux-2.6.19-rc1/drivers/scsi/NCR5380.c
--- linux-2.6.19-rc1-orig/drivers/scsi/NCR5380.c	2006-09-21 10:15:39.000000000 +0530
+++ linux-2.6.19-rc1/drivers/scsi/NCR5380.c	2006-10-11 17:57:02.000000000 +0530
@@ -347,7 +347,7 @@ static int NCR5380_poll_politely(struct 
 		if((r & bit) == val)
 			return 0;
 		if(!in_interrupt())
-			yield();
+			cond_resched();
 		else
 			cpu_relax();
 	}



^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2006-10-12  4:25 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2006-10-11 12:54 [PATCH 3/3] drivers/scsi/NCR5380.c: Replacing yield() with a better alternative Amol Lad
2006-10-11 17:52 ` Alan Cox
2006-10-12  4:29   ` Amol Lad

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®