* [patch 1/13] signal/timer/event fds v7 - anonymous inode source ...
@ 2007-03-19 23:47 Davide Libenzi
2007-03-20 1:07 ` Thomas Gleixner
0 siblings, 1 reply; 3+ messages in thread
From: Davide Libenzi @ 2007-03-19 23:47 UTC (permalink / raw)
To: Linux Kernel Mailing List
Cc: Andrew Morton, Linus Torvalds, Thomas Gleixner, Oleg Nesterov
This patch add an anonymous inode source, to be used for files that need
and inode only in order to create a file*. We do not care of having an
inode for each file, and we do not even care of having different names in
the associated dentries (dentry names will be same for classes of file*).
This allow code reuse, and will be used by epoll, signalfd and timerfd
(and whatever else there'll be).
Signed-off-by: Davide Libenzi <davidel@xmailserver.org>
- Davide
Index: linux-2.6.21-rc3.quilt/fs/anon_inodes.c
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ linux-2.6.21-rc3.quilt/fs/anon_inodes.c 2007-03-18 13:32:52.000000000 -0700
@@ -0,0 +1,204 @@
+/*
+ * fs/anon_inodes.c
+ *
+ * Copyright (C) 2007 Davide Libenzi <davidel@xmailserver.org>
+ *
+ * Thanks to Arnd Bergmann for code review and suggestions.
+ */
+
+#include <linux/file.h>
+#include <linux/poll.h>
+#include <linux/slab.h>
+#include <linux/init.h>
+#include <linux/fs.h>
+#include <linux/mount.h>
+#include <linux/module.h>
+#include <linux/kernel.h>
+#include <linux/magic.h>
+#include <linux/anon_inodes.h>
+
+#include <asm/uaccess.h>
+
+
+
+static int ainofs_delete_dentry(struct dentry *dentry);
+static struct inode *aino_getinode(void);
+static struct inode *aino_mkinode(void);
+static int ainofs_get_sb(struct file_system_type *fs_type, int flags,
+ const char *dev_name, void *data, struct vfsmount *mnt);
+
+
+
+static struct vfsmount *aino_mnt __read_mostly;
+static struct inode *aino_inode;
+static const struct file_operations aino_fops = { };
+static struct file_system_type aino_fs_type = {
+ .name = "ainofs",
+ .get_sb = ainofs_get_sb,
+ .kill_sb = kill_anon_super,
+};
+static struct dentry_operations ainofs_dentry_operations = {
+ .d_delete = ainofs_delete_dentry,
+};
+
+
+
+/**
+ * aino_getfd - creates a new file instance by hooking it up to and anonymous
+ * inode, and a dentry that describe the "class" of the file
+ * @pfd: [out] pointer to the file descriptor
+ * @dpinode: [out] pointer to the inode
+ * @pfile: [out] pointer to the file struct
+ * @name: [in] name of the "class" of the new file
+ * @fops [in] file operations for the new file
+ * @priv [in] private data for the new file (will be file's private_data)
+ *
+ * Creates a new file by hooking it on a single inode. This is useful for files
+ * that do not need to have a full-fledged inode in order to operate correctly.
+ * All the files created with aino_getfd() will share a single inode, by hence
+ * saving memory and avoiding code duplication for the file/inode/dentry setup.
+ */
+int aino_getfd(int *pfd, struct inode **pinode, struct file **pfile,
+ char const *name, const struct file_operations *fops, void *priv)
+{
+ struct qstr this;
+ struct dentry *dentry;
+ struct inode *inode;
+ struct file *file;
+ int error, fd;
+
+ error = -ENFILE;
+ file = get_empty_filp();
+ if (!file)
+ goto eexit_1;
+
+ inode = aino_getinode();
+ if (IS_ERR(inode)) {
+ error = PTR_ERR(inode);
+ goto eexit_2;
+ }
+
+ error = get_unused_fd();
+ if (error < 0)
+ goto eexit_3;
+ fd = error;
+
+ /*
+ * Link the inode to a directory entry by creating a unique name
+ * using the inode sequence number.
+ */
+ error = -ENOMEM;
+ this.name = name;
+ this.len = strlen(name);
+ this.hash = 0;
+ dentry = d_alloc(aino_mnt->mnt_sb->s_root, &this);
+ if (!dentry)
+ goto eexit_4;
+ dentry->d_op = &ainofs_dentry_operations;
+ /* Do not publish this dentry inside the global dentry hash table */
+ dentry->d_flags &= ~DCACHE_UNHASHED;
+ d_instantiate(dentry, inode);
+
+ file->f_path.mnt = mntget(aino_mnt);
+ file->f_path.dentry = dentry;
+ file->f_mapping = inode->i_mapping;
+
+ file->f_pos = 0;
+ file->f_flags = O_RDWR;
+ file->f_op = fops;
+ file->f_mode = FMODE_READ | FMODE_WRITE;
+ file->f_version = 0;
+ file->private_data = priv;
+
+ fd_install(fd, file);
+
+ *pfd = fd;
+ *pinode = inode;
+ *pfile = file;
+ return 0;
+
+eexit_4:
+ put_unused_fd(fd);
+eexit_3:
+ iput(inode);
+eexit_2:
+ put_filp(file);
+eexit_1:
+ return error;
+}
+
+static int ainofs_delete_dentry(struct dentry *dentry)
+{
+ /*
+ * We faked vfs to believe the dentry was hashed when we created it.
+ * Now we restore the flag so that dput() will work correctly.
+ */
+ dentry->d_flags |= DCACHE_UNHASHED;
+ return 1;
+}
+
+static struct inode *aino_getinode(void)
+{
+ return igrab(aino_inode);
+}
+
+/*
+ * A single inode exist for all aino files. On the contrary of pipes,
+ * aino inodes has no per-instance data associated, so we can avoid
+ * the allocation of multiple of them.
+ */
+static struct inode *aino_mkinode(void)
+{
+ int error = -ENOMEM;
+ struct inode *inode = new_inode(aino_mnt->mnt_sb);
+
+ if (!inode)
+ goto eexit_1;
+
+ inode->i_fop = &aino_fops;
+
+ /*
+ * Mark the inode dirty from the very beginning,
+ * that way it will never be moved to the dirty
+ * list because mark_inode_dirty() will think
+ * that it already _is_ on the dirty list.
+ */
+ inode->i_state = I_DIRTY;
+ inode->i_mode = S_IRUSR | S_IWUSR;
+ inode->i_uid = current->fsuid;
+ inode->i_gid = current->fsgid;
+ inode->i_atime = inode->i_mtime = inode->i_ctime = CURRENT_TIME;
+ return inode;
+
+eexit_1:
+ return ERR_PTR(error);
+}
+
+static int ainofs_get_sb(struct file_system_type *fs_type, int flags,
+ const char *dev_name, void *data, struct vfsmount *mnt)
+{
+ return get_sb_pseudo(fs_type, "aino:", NULL, AINOFS_MAGIC, mnt);
+}
+
+static int __init aino_init(void)
+{
+
+ if (register_filesystem(&aino_fs_type))
+ goto epanic;
+
+ aino_mnt = kern_mount(&aino_fs_type);
+ if (IS_ERR(aino_mnt))
+ goto epanic;
+
+ aino_inode = aino_mkinode();
+ if (IS_ERR(aino_inode))
+ goto epanic;
+
+ return 0;
+
+epanic:
+ panic("aino_init() failed\n");
+}
+
+fs_initcall(aino_init);
+
Index: linux-2.6.21-rc3.quilt/include/linux/anon_inodes.h
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ linux-2.6.21-rc3.quilt/include/linux/anon_inodes.h 2007-03-15 15:32:33.000000000 -0700
@@ -0,0 +1,15 @@
+/*
+ * include/linux/anon_inodes.h
+ *
+ * Copyright (C) 2007 Davide Libenzi <davidel@xmailserver.org>
+ *
+ */
+
+#ifndef _LINUX_ANON_INODES_H
+#define _LINUX_ANON_INODES_H
+
+int aino_getfd(int *pfd, struct inode **pinode, struct file **pfile,
+ char const *name, const struct file_operations *fops, void *priv);
+
+#endif /* _LINUX_ANON_INODES_H */
+
Index: linux-2.6.21-rc3.quilt/fs/Makefile
===================================================================
--- linux-2.6.21-rc3.quilt.orig/fs/Makefile 2007-03-15 15:19:22.000000000 -0700
+++ linux-2.6.21-rc3.quilt/fs/Makefile 2007-03-18 13:32:30.000000000 -0700
@@ -11,7 +11,7 @@
attr.o bad_inode.o file.o filesystems.o namespace.o aio.o \
seq_file.o xattr.o libfs.o fs-writeback.o \
pnode.o drop_caches.o splice.o sync.o utimes.o \
- stack.o
+ stack.o anon_inodes.o
ifeq ($(CONFIG_BLOCK),y)
obj-y += buffer.o bio.o block_dev.o direct-io.o mpage.o ioprio.o
Index: linux-2.6.21-rc3.quilt/include/linux/magic.h
===================================================================
--- linux-2.6.21-rc3.quilt.orig/include/linux/magic.h 2007-03-15 15:19:22.000000000 -0700
+++ linux-2.6.21-rc3.quilt/include/linux/magic.h 2007-03-15 15:33:16.000000000 -0700
@@ -14,6 +14,7 @@
#define ISOFS_SUPER_MAGIC 0x9660
#define JFFS2_SUPER_MAGIC 0x72b6
#define KVMFS_SUPER_MAGIC 0x19700426
+#define AINOFS_MAGIC 0x09041934
#define MINIX_SUPER_MAGIC 0x137F /* original minix fs */
#define MINIX_SUPER_MAGIC2 0x138F /* minix fs, 30 char names */
^ permalink raw reply [flat|nested] 3+ messages in thread* Re: [patch 1/13] signal/timer/event fds v7 - anonymous inode source ...
2007-03-19 23:47 [patch 1/13] signal/timer/event fds v7 - anonymous inode source Davide Libenzi
@ 2007-03-20 1:07 ` Thomas Gleixner
2007-03-20 1:38 ` Davide Libenzi
0 siblings, 1 reply; 3+ messages in thread
From: Thomas Gleixner @ 2007-03-20 1:07 UTC (permalink / raw)
To: Davide Libenzi
Cc: Linux Kernel Mailing List, Andrew Morton, Linus Torvalds, Oleg Nesterov
Davide,
On Mon, 2007-03-19 at 16:47 -0700, Davide Libenzi wrote:
> This patch add an anonymous inode source, to be used for files that need
> and inode only in order to create a file*. We do not care of having an
> inode for each file, and we do not even care of having different names in
> the associated dentries (dentry names will be same for classes of file*).
> This allow code reuse, and will be used by epoll, signalfd and timerfd
> (and whatever else there'll be).
>
> +int aino_getfd(int *pfd, struct inode **pinode, struct file **pfile,
> + char const *name, const struct file_operations *fops, void *priv)
> +{
> + struct qstr this;
> + struct dentry *dentry;
> + struct inode *inode;
> + struct file *file;
> + int error, fd;
> +
> + error = -ENFILE;
> + file = get_empty_filp();
> + if (!file)
> + goto eexit_1;
make this "return -ENFILE;" please
> + inode = aino_getinode();
> + if (IS_ERR(inode)) {
> + error = PTR_ERR(inode);
> + goto eexit_2;
Can you please use a bit more descriptive labels ?
e.g:
goto out_filp;
> + }
> +
> + error = get_unused_fd();
> + if (error < 0)
> + goto eexit_3;
e.g:
goto out_inode;
> + fd = error;
> +
> + /*
> + * Link the inode to a directory entry by creating a unique name
> + * using the inode sequence number.
> + */
> + error = -ENOMEM;
> + this.name = name;
> + this.len = strlen(name);
> + this.hash = 0;
> + dentry = d_alloc(aino_mnt->mnt_sb->s_root, &this);
> + if (!dentry)
> + goto eexit_4;
e.g:
goto out_fd;
> +static int ainofs_delete_dentry(struct dentry *dentry)
> +{
> + /*
> + * We faked vfs to believe the dentry was hashed when we created it.
> + * Now we restore the flag so that dput() will work correctly.
> + */
> + dentry->d_flags |= DCACHE_UNHASHED;
> + return 1;
> +}
Please put either "struct ainofs_dentry_operations ..." below the next
function or move ainofs_delete_dentry() above "struct
ainofs_dentry_operations ..."
It's annoying to lookup the protoypes and implemenation back and forth.
> +static struct inode *aino_getinode(void)
> +{
> + return igrab(aino_inode);
> +}
Please use "igrab(aino_inode);" directly in this one single place above.
That saves us a prototype and an useless static function with no value.
> +/*
> + * A single inode exist for all aino files. On the contrary of pipes,
> + * aino inodes has no per-instance data associated, so we can avoid
> + * the allocation of multiple of them.
> + */
> +static struct inode *aino_mkinode(void)
> +{
> + int error = -ENOMEM;
> + struct inode *inode = new_inode(aino_mnt->mnt_sb);
> +
> + if (!inode)
> + goto eexit_1;
return ERR_PTR(-ENOMEM);
> + inode->i_fop = &aino_fops;
> +}
> +
> +static int ainofs_get_sb(struct file_system_type *fs_type, int flags,
> + const char *dev_name, void *data, struct vfsmount *mnt)
> +{
> + return get_sb_pseudo(fs_type, "aino:", NULL, AINOFS_MAGIC, mnt);
> +}
Please put either "struct file_system_type aino_fs_typ ..." below this
function or move ainofs_get_sb() above "struct file_system_type
aino_fs_typ ..."
> +static int __init aino_init(void)
> +{
> +
> + if (register_filesystem(&aino_fs_type))
> + goto epanic;
> +
> + aino_mnt = kern_mount(&aino_fs_type);
> + if (IS_ERR(aino_mnt))
> + goto epanic;
> +
> + aino_inode = aino_mkinode();
> + if (IS_ERR(aino_inode))
> + goto epanic;
> +
> + return 0;
> +
> +epanic:
> + panic("aino_init() failed\n");
Panic ? It's not life critical - is it ?
A printk(KERN_ERR...) and a return -Exx would be sufficient.
tglx
^ permalink raw reply [flat|nested] 3+ messages in thread* Re: [patch 1/13] signal/timer/event fds v7 - anonymous inode source ...
2007-03-20 1:07 ` Thomas Gleixner
@ 2007-03-20 1:38 ` Davide Libenzi
0 siblings, 0 replies; 3+ messages in thread
From: Davide Libenzi @ 2007-03-20 1:38 UTC (permalink / raw)
To: Thomas Gleixner
Cc: Linux Kernel Mailing List, Andrew Morton, Linus Torvalds, Oleg Nesterov
On Tue, 20 Mar 2007, Thomas Gleixner wrote:
> > + error = -ENFILE;
> > + file = get_empty_filp();
> > + if (!file)
> > + goto eexit_1;
>
> make this "return -ENFILE;" please
Done
> > + inode = aino_getinode();
> > + if (IS_ERR(inode)) {
> > + error = PTR_ERR(inode);
> > + goto eexit_2;
>
> Can you please use a bit more descriptive labels ?
>
> e.g:
> goto out_filp;
Done
> > +static int ainofs_delete_dentry(struct dentry *dentry)
> > +{
> > + /*
> > + * We faked vfs to believe the dentry was hashed when we created it.
> > + * Now we restore the flag so that dput() will work correctly.
> > + */
> > + dentry->d_flags |= DCACHE_UNHASHED;
> > + return 1;
> > +}
>
> Please put either "struct ainofs_dentry_operations ..." below the next
> function or move ainofs_delete_dentry() above "struct
> ainofs_dentry_operations ..."
>
> It's annoying to lookup the protoypes and implemenation back and forth.
I prefer to have all data declarations at the beginning. but if you can
manage to have that requirement in the Coding Style, I'll change it ;)
> > +static struct inode *aino_getinode(void)
> > +{
> > + return igrab(aino_inode);
> > +}
>
> Please use "igrab(aino_inode);" directly in this one single place above.
> That saves us a prototype and an useless static function with no value.
Done
> > +/*
> > + * A single inode exist for all aino files. On the contrary of pipes,
> > + * aino inodes has no per-instance data associated, so we can avoid
> > + * the allocation of multiple of them.
> > + */
> > +static struct inode *aino_mkinode(void)
> > +{
> > + int error = -ENOMEM;
> > + struct inode *inode = new_inode(aino_mnt->mnt_sb);
> > +
> > + if (!inode)
> > + goto eexit_1;
>
> return ERR_PTR(-ENOMEM);
Done
> > + aino_mnt = kern_mount(&aino_fs_type);
> > + if (IS_ERR(aino_mnt))
> > + goto epanic;
> > +
> > + aino_inode = aino_mkinode();
> > + if (IS_ERR(aino_inode))
> > + goto epanic;
> > +
> > + return 0;
> > +
> > +epanic:
> > + panic("aino_init() failed\n");
>
> Panic ? It's not life critical - is it ?
>
> A printk(KERN_ERR...) and a return -Exx would be sufficient.
Done.
- Davide
^ permalink raw reply [flat|nested] 3+ messages in thread
end of thread, other threads:[~2007-03-20 1:40 UTC | newest]
Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2007-03-19 23:47 [patch 1/13] signal/timer/event fds v7 - anonymous inode source Davide Libenzi
2007-03-20 1:07 ` Thomas Gleixner
2007-03-20 1:38 ` Davide Libenzi
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®